お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2019-06-13 20:31:46

roswell
メンバ
登録日: 2008-10-30

testsaslauthd -u ユーザー -p パスワード で connect() : Permssion denied になる。

saslauthd で、

MECHANISMS="getpwent"

としており、

testsaslauthd の確認で、login時のアカウントとパスワードで正しく認識されるか確認したところ

yama@jpx20120007 ~> testsaslauthd -u yama -p ?????
connect() : Permission denied
0: ⏎ 

"Permission denied" が表示されてしまいます。
正しく動作していないように思うのですが、対処方法をご教示いただけますでしょうか?

環境や設定ファイルは、下記になります。

■ release
yama@jpx20120007 ~> lsb_release  -a
No LSB modules are available.
Distributor ID:    LinuxMint
Description:    LMDE 3 Cindy
Release:    3
Codename:    cindy

■ saslauthd version
yama@jpx20120007 ~> saslauthd -v
saslauthd 2.1.27
authentication mechanisms: sasldb getpwent kerberos5 pam rimap shadow ldap

■ saslauthd 設定ファイル抜粋
yama@jpx20120007 ~> cat /etc/default/saslauthd
#
# Settings for saslauthd daemon
# Please read /usr/share/doc/sasl2-bin/README.Debian for details.
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Description of this saslauthd instance. Recommended.
# (suggestion: SASL Authentication Daemon)
DESC="SASL Authentication Daemon"

# Short name of this saslauthd instance. Strongly recommended.
# (suggestion: saslauthd)
NAME="saslauthd"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent  -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam       -- use PAM
# rimap     -- use a remote IMAP server
# shadow    -- use the local shadow password file
# sasldb    -- use the local sasldb database file
# ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="getpwent"
...

オフライン

 

#2 2019-06-14 19:58:51

roswell
メンバ
登録日: 2008-10-30

Re: testsaslauthd -u ユーザー -p パスワード で connect() : Permssion denied になる。

>yama@jpx20120007 ~> testsaslauthd -u yama -p ?????
>connect() : Permission denied
>0: ⏎ 
>
>"Permission denied" が表示されてしまいます。
>正しく動作していないように思うのですが、対処方法をご教示いただけますでしょうか?

このメッセージを無視して、
SMTP AUTH 設定していきました。
無事動いているので、file の permission 関連なのかと思われます。

オフライン

 

#3 2019-06-14 20:47:39

ShiroAmada
メンバ
登録日: 2019-05-06

Re: testsaslauthd -u ユーザー -p パスワード で connect() : Permssion denied になる。

ソケットファイルのオープンエラーです。
sudo ls -laF /var/run/saslauthd/  すれば原因がわかると思います。
SMTP AUTH の設定後、無事動作しているとこのことですが、MECHANISMS="getpwent" のままで問題なかったでしょうか。

オフライン

 

Board footer

Powered by FluxBB