お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2011-03-06 20:59:33

atre206
メンバ
登録日: 2009-11-01

canon MG6130 プリンターのドライバーをインストールできません

Ubuntuの初心者です。
Canon MG6130のプリンターを購入しました。
WindowsのPCではCDからドライバーをインストールして正常に印刷できます。
USBでUbuntuのPC(単独)に接続し、プリンターのドライバーをインストールしようと
試みますがうまくいきません。
デスクトップにCanonからダウンロードした
 cnijfilter-common-2.60 と cnifilter-mg6100series-3.40-1-beb
のフォルダーがあります。
方法をご教示願います。

オフライン

 

#2 2011-03-06 21:46:52

makopi
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

デスクトップにCanonからダウンロードした
 cnijfilter-common-2.60 と cnifilter-mg6100series-3.40-1-beb
のフォルダーがあります。

http://cweb.canon.jp/drv-upd/bj/bjlinux340.html
に MG-6130 用の操作説明書がありますのでダウンロードして見てください。
それにインストール手順等の操作方法が書いてあります。

cnijfilter-common-2.60 というのは知りませんが。

オフライン

 

#3 2011-03-07 02:37:28

hir0
メンバ
登録日: 2008-09-28

Re: canon MG6130 プリンターのドライバーをインストールできません

チラッと見たらlinuxドライバ用取説が見つけられ無かったので、、、。
#2の参考URLからPIXUS MG5230用プリンタードライバー (debian)をダウンロードします。
ダウンロードされたファイルはデフォルトでホームディレクトリのダウンロードフォルダに保存されます。

ダブルクリックして解凍して下さい。
解凍されたフォルダ「cnijfilter-mg5100series-3.40-1-deb」の中に有る「install.sh」をダブルクリックします。

ダイアログが開きますので「端末な胃で実行する」を選択してください。
端末が開いてインストールが開始されます。パスワードが求められるので入力してください。
後は端末の指示にしたがって下さい。

オフライン

 

#4 2011-03-07 02:42:53

hir0
メンバ
登録日: 2008-09-28

Re: canon MG6130 プリンターのドライバーをインストールできません

オフライン

 

#5 2011-03-07 08:13:49

atre206
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

早速のご教示ありがとうございます。

cnijfilter-mg6100series-3.40-1-debの中にある install.shをダブルクリック後
表示される「端末内で実行する」のボタンをクリックすると端末画面?が瞬時現れますが
直ぐに消えてしまいます。
何度試みても同じ状況で次に進めません。
如何したものでしょうか?

オフライン

 

#6 2011-03-07 08:41:24

makopi
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

cnijfilter-mg6100series-3.40-1-debの中にある install.shをダブルクリック後
表示される「端末内で実行する」のボタンをクリックすると端末画面?が瞬時現れますが
直ぐに消えてしまいます。

説明書の手順を脚色して書くと
1. プリンターの電源を入れる。
2. [アプリケーション]-[アクセサリ]-[端末]で端末を起動する。
3. 端末内で cd コマンドで install.sh があるディレクトリへ移動する。
4. sudo ./install.sh を実行する。
5. あとは指示にしたがって入力する。

私の場合、10.04 と 10.10 で動作確認していますが使われているバージョンはいくつですか?

オフライン

 

#7 2011-03-07 11:18:26

atre206
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

本当にお世話をおかけします。ご指示の通りやってみましたがエラーが発生し進みません。

atre206@atre206-desktop:~$ cd cnijfilter-mg6100series-3.40-1-deb

atre206@atre206-desktop:~/cnijfilter-mg6100series-3.40-1-deb$ sudo ./install.sh

==================================================



Canon Inkjet Printer Driver Ver.3.40-1 for Linux

Copyright CANON INC. 2001-2010

All Rights Reserved.



==================================================

エラーが発生しました。パッケージ管理システムが特定できません。

atre206@atre206-desktop:~/cnijfilter-mg6100series-3.40-1-deb$


バージョンは10.10です。
よろしくお願いいたします。

オフライン

 

#8 2011-03-07 12:08:44

weyk
メンバ
登録日: 2009-04-03

Re: canon MG6130 プリンターのドライバーをインストールできません

内部で、rpmかdpkgか自動判別しているっぽいのですが、このメッセージが出るケースでは、どちらのコマンドもエラーとなってしまっている場合のようです。ubuntuではdpkgを使えるはずなので、
------
dpkg --version
------
にて、なにかエラーが出ていないか、確認してみてください。

オフライン

 

#9 2011-03-07 14:16:05

atre206
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

weykさん
ご教示の方法をどうすればいいのか「素人」で理解できません。
お手数ですが具体的な「やり方」をお教え願いませんでしょうか。
よろしくお願いいたします。

オフライン

 

#10 2011-03-07 14:48:20

weyk
メンバ
登録日: 2009-04-03

Re: canon MG6130 プリンターのドライバーをインストールできません

makopi さんのを参考に詳しく記載すると、
1. [アプリケーション]-[アクセサリ]-[端末]で端末を起動する。
2. dpkg --version を実行する。
です。

蛇足。
 「端末で実行してください」とか「端末で実行して結果を投稿してください」とかコマンドが書かれて「実行してください」と書かれていた場合、だいたい、この手順になります。
端末で実行する利点は、
・単にダブルクリックからの場合、引数を追加したり、前にsudoをついたりしない(右クリックからならいろいろできますが)
・実行したコマンドが実行後も確認できる。
・実行が終わっても結果が画面に残るので成否がわかる。また、失敗の場合には(表示されている内容から)原因の助けになる情報が得られる。
ということになります。
2番目、3番目の利点があるために、マウスで操作可能な場合でも、端末から操作をする場合も有ります。

※私のように、単に「実行してください」等と書かれた場合で、判断が付かない場合は書いた人に確認してみてください。

オフライン

 

#11 2011-03-07 20:06:49

atre206
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

本当にお世話をおかけします。

2. dpkg --version を実行する。

の後は何をどうすればいいのでしょうか?
幼稚な質問でしょうが、よろしくお願いいたします。

オフライン

 

#12 2011-03-07 20:25:27

makopi
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

atre206 さん

2. dpkg --version を実行する。

の後は何をどうすればいいのでしょうか?

weyk さんと同じ方向へ行っていますので改めて質問させていただきます。

1. [アプリケーション]-[アクセサリ]-[端末]で端末を起動する。
2. dpkg --version を実行する。
3. rpm --version を実行する。
4. #7 でやっていただいたように copy & paste してください。

install.sh では  weyk さんの言う通りパッケージの管理システムを自動判別をしているのですが、
dpkg コマンドと rpm コマンドが両方とも無い場合と両方とも有る場合はエラーを出す様です。

以前に rpm をインストールした覚えは無いでしょうか?

オフライン

 

#13 2011-03-07 20:58:39

atre206
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

本当にお世話をおかけします。

3. rpm --version を実行する。と RPM バージョン 4.8.1と表示されました。

4. #7 でやっていただいたように copy & paste してください。
 を実行すると#7と同じエラーメッセージです。
3. rpm --version を実行する。
どうやればいいのでしょうか?

オフライン

 

#14 2011-03-07 21:18:44

weyk
メンバ
登録日: 2009-04-03

Re: canon MG6130 プリンターのドライバーをインストールできません

 makopi さん、こんばんは。すいません、rpmと両方とも確認してもらわないとでしたね。
 自動は別が、手元で確認できないのですが、コマンドのチェックがrpm→dpkgという順だったような記憶があります。
 そして、配布元のサイトを見ていただくとわかるのですが、prmとdebでダウンロードが別々で、実際、、インストールするための*.debとか*.rpmは、どちらか一方しか入っていません。
そのため、「debでインストールするつもりでdebをダウンロードしたところの環境に、なぜかrpm --versionがエラーにならないと、その先で(dpkgならうまくゆくはずなのに)そのままエラーになってうまくゆかない」という、配布スクリプト側の不備っぽい感じがします。
(ダウンロードで分けているなら、この自動判別の方法って、いったい・・・)

原因がこれだとした場合、良い(簡単な)解決方法はちょっと思いつきません。install.shの判定部分をちょこちょこっと直せば良さそうですが、ファイルの編集をしていただくのはちょっと不安です。
(rpm版で入れちゃうのは本末転倒無気がするし・・・・rpmパッケージを削除しちゃうのもちょっと乱暴な気が。)

オフライン

 

#15 2011-03-07 21:28:47

makopi
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

atre206 さん

3. rpm --version を実行する。と RPM バージョン 4.8.1と表示されました。

これでわかりました。(多分)
一時的に rpm 関連のコマンドを使えなくなる様にしましょう。

1. [アプリケーション]-[アクセサリ]-[端末]で端末を起動する。
2. sudo apt-get remove rpm を実行する。
3. rpm --version を実行する。
4. 「プログラム 'rpm' はまだインストールされていません。(以下略)」が表示されればOKです。

あとは、 #6 の要領でインストールしていただければ良いと思います。

インストールに成功して、これからも rpm 関連のコマンドを使う様でしたら
端末内で sudo apt-get install rpm を実行してください。

オフライン

 

#16 2011-03-07 21:44:22

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: canon MG6130 プリンターのドライバーをインストールできません

https://forums.ubuntulinux.jp/viewtopic.php?pid=68673 に似ているような気が。
そのトピックの#10、#11にあるように、debファイルをダブルクリックするだけかも。

オフライン

 

#17 2011-03-07 21:44:52

hir0
メンバ
登録日: 2008-09-28

Re: canon MG6130 プリンターのドライバーをインストールできません

えーと、次どうするか?では無いです。
atre206さんの「システム環境がおかしいので確認してみましょう」と言うことで
dpkg --version

を実行した結果を下さいと言うことです。
dpkg --versionもrpm --versionもプリンタードライバをインストールするものでは有りません。
標準で備わっているべきであるdpkgを「判断できない」と標示されたのでdpkgのバージョンを標示することで、その存在と何かエラーを吐かないかとの期待ですので、実行結果を書き込まれないと次へと続きません。

*ライブUSB環境とかでは無いですよね?

オフライン

 

#18 2011-03-07 21:48:20

hir0
メンバ
登録日: 2008-09-28

Re: canon MG6130 プリンターのドライバーをインストールできません

あー、#13から凄く書き込みが、、、すみません #17 は無にしてください。

ブラウザを更新していなかったので#13で止まっている物と勘違いしてしまいました。

オフライン

 

#19 2011-03-07 21:59:51

atre206
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

makopiさん、hir0さん、weykさんこんばんは。
#15のとおり実行しましたところドライバーをインストールでき印刷可能となりました。
何にも分からない者を親切に最後までご指導いただき本当に感謝いたします。
今後とも皆様のご指導をよろしくお願いいたします。
ありがとうございました。

オフライン

 

#20 2011-03-07 22:11:11

makopi
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

STGSAGWAN さん、

https://forums.ubuntulinux.jp/viewtopic.php?pid=68673 に似ているような気が。
そのトピックの#10、#11にあるように、debファイルをダブルクリックするだけかも。

興味がありますので週末あたりに試してみます。

オフライン

 

#21 2011-03-08 22:12:31

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: canon MG6130 プリンターのドライバーをインストールできません

STGSAGWAN による投稿:

https://forums.ubuntulinux.jp/viewtopic.php?pid=68673 に似ているような気が。
そのトピックの#10、#11にあるように、debファイルをダブルクリックするだけかも。

上記発言を訂正します。
canonのインストールスクリプトを介さない方法は止めた方が無難ですね・・。
install.shをざっと読んでみたら、debファイルをインストールするだけでなく他にも色々と処理をやってるので。

オフライン

 

#22 2011-03-10 21:37:51

makopi
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

STGSAGWAN さん、

canonのインストールスクリプトを介さない方法は止めた方が無難ですね・・。
install.shをざっと読んでみたら、debファイルをインストールするだけでなく他にも色々と処理をやってるので。

週末は私用が出来たので今わかっている範囲ですが・・・。
2個のdeb ファイルをダブルクリックするだけではなく、[システム]-[システム管理]-[印刷] で登録作業をしてテスト印字が出来ます。
この登録作業の部分が install.sh の他の部分(URI,登録名等々)になると思われます。(コメントを追った程度ですが。)

これから私がやろうとしている事は
32bit 環境とまだテストしていないとなっていた 64bit 環境についても同様か?といった所でしょうか。

オフライン

 

#23 2011-03-10 22:47:45

hir0
メンバ
登録日: 2008-09-28

Re: canon MG6130 プリンターのドライバーをインストールできません

お使いのシステム環境に合わせて複数のインストール用debを用意されていて、どのパッケージファイルを使用するかは「install.sh」を使用してシステムを判別して適したパッケージファイルを選択して実行します。

なので「install.sh」がエラーを出した場合、手動でdebファイルをダブルクリックして解決したURLを参考に出されましたが、「install.sh」の中を覗いてみると、単純名部分の判定の他にも色々チェックを行なっているので簡単に「手動で」を解決策にしない方が無難。

と言うことだと思いますよ。

オフライン

 

#24 2011-03-10 23:10:23

makopi
メンバ
登録日: 2009-11-01

Re: canon MG6130 プリンターのドライバーをインストールできません

hir0 さん、

お使いのシステム環境に合わせて複数のインストール用debを用意されていて、どのパッケージファイルを使用するかは「install.sh」を使用してシステムを判別して適したパッケージファイルを選択して実行します。

なので「install.sh」がエラーを出した場合、手動でdebファイルをダブルクリックして解決したURLを参考に出されましたが、「install.sh」の中を覗いてみると、単純名部分の判定の他にも色々チェックを行なっているので簡単に「手動で」を解決策にしない方が無難。

と言うことだと思いますよ。

下手にまとめてしまうと「不確かな情報」になってしまうという事ですね?
結果は自分の中にしまっておく事にします。

オフライン

 

#25 2012-03-03 13:06:45

haiiro_shimeji
新しいメンバ
登録日: 2010-06-22

Re: canon MG6130 プリンターのドライバーをインストールできません

まったく同じところでハマりました。#14でweykさんが言っているとおりのスクリプトの不備だと思います。
質問者の方は解決しているようですが、次にハマった時のためにパッチを置いておきます。

cnijfilter.install.sh.diff

コード:

*** install.sh.orig     2012-03-03 12:49:29.857549662 +0900
--- install.sh  2012-03-03 12:49:35.773549774 +0900
***************
*** 1246,1252 ****

        ## Judge is the distribution supporting rpm? ##
        rpm --version 1> /dev/null 2>&1
!       c_system_rpm=$?

        ## Judge is the distribution supporting dpkg(debian)? ##
        dpkg --version 1> /dev/null 2>&1
--- 1246,1252 ----

        ## Judge is the distribution supporting rpm? ##
        rpm --version 1> /dev/null 2>&1
!       c_system_rpm=-1

        ## Judge is the distribution supporting dpkg(debian)? ##
        dpkg --version 1> /dev/null 2>&1

上記のcnijfilter.install.sh.diffを作成し、下のようにinstall.shに適用してから実行します。
$ patch install.sh < cnijfilter.install.sh.diff
# ./install.sh

MG6130にのスキャナ機能を使うためのドライバscangermpにも全く同じ問題があります。

scangearmp.install.sh.diff

コード:

*** install.sh.orig     2012-03-03 12:46:33.429546350 +0900
--- install.sh  2012-03-03 12:47:11.053547056 +0900
***************
*** 184,190 ****

        ## Judge is the distribution supporting rpm? ##
        rpm --version 1> /dev/null 2>&1
!       c_system_rpm=$?

        ## Judge is the distribution supporting dpkg(debian)? ##
        dpkg --version 1> /dev/null 2>&1
--- 184,190 ----

        ## Judge is the distribution supporting rpm? ##
        rpm --version 1> /dev/null 2>&1
!       c_system_rpm=-1

        ## Judge is the distribution supporting dpkg(debian)? ##
        dpkg --version 1> /dev/null 2>&1

上記のscangearmp.install.sh.diffを作成し、下のようにinstall.shに適用してから実行します。
$ patch install.sh < scangearmp.install.sh.diff
# ./install.sh

ドライバのバージョンが上がると多分パッチ適用失敗します。今は「更新日:2010年11月11日」と書いてありました。

オフライン

 

Board footer

Powered by FluxBB