お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2011-04-29 15:06:33

body-and-soul
メンバ
登録日: 2009-03-11

11.04アップグレードでX起動せず(NVIDIA)

11.04にアップグレードしたのですが、Xが起動しなくなりました。
エラーログをみるとNVIDIAモジュールがないといっていますので、これは失敗したかなと検索してみたらNVIDIAドライバは11.04に対応していない、そのためには新しいドライバをインストール必要があるとの情報を得ました。
そこで、以下から新しいドライバをダウンロードしてカーネルをリコンパイルしようとしたのですが、

http://news.softpedia.com/news/New-Nvidia-Linux-Driver-Supports-Ubuntu-11-04-196264.shtml

カーネルソースがないとのエラー。
そもそもUbuntuでは、他の配布形態になっているのかもしれないと思い、いろいろ探したのですが、まだ解決していません。

どなたかアドバイスを頂けると助かります。
よろしくお願いいたします。

オフライン

 

#2 2011-04-29 16:28:17

uotora
メンバ
登録日: 2008-06-18

Re: 11.04アップグレードでX起動せず(NVIDIA)

システム設定の中に「追加のドライバ」があります。クリックすれば「NVIDIAの高性能グラフィックスドライバ(バージョン current)
を有効にする。
「NVIDIA X Server Settings」がインストールされます。

オフライン

 

#3 2011-04-29 16:42:34

body-and-soul
メンバ
登録日: 2009-03-11

Re: 11.04アップグレードでX起動せず(NVIDIA)

すみません、Xが起動しないのです。
コマンドラインでの方法はあるでしょうか?

オフライン

 

#4 2011-04-29 20:50:21

hir0
メンバ
登録日: 2008-09-28

Re: 11.04アップグレードでX起動せず(NVIDIA)

http://www.nvidia.com/Download/index.aspx?lang=en-us
配布されている形式にあわせてコマンドを打てば良いのではないでしょうか。

パッケージなら 「dpkg -i   パッケージ名」makeが必用ならmakeしてmake install 等。

オフライン

 

#5 2011-04-29 20:52:43

zagan
メンバ
登録日: 2008-08-12

Re: 11.04アップグレードでX起動せず(NVIDIA)

詳しく無いので突っ込まれると困るんですが・・・
サブ&地デジ視聴マシンにGeforce 210を使っています。
リンク先は英語も苦手なので、頭っから読んで無いので、、、すみません。

β1位でクリーンインストールして、Nvidia周りのエラーというとJockey絡みで出てました。
それでもXで起動ししてました。ログイン画面の直前に英語でなにやら「ハードウェアがUnityに対応していない」とか言うようなメッセージを吐いてましたので、ログイン後に「追加のドライバ」で有効にしてあげたんですが、#1を読んで気になったので確認してみました。インストールされてるが有効ではないというメッセージです。
それでもUnityの機能はフルに使えてました(多分)。
で、今度は正式版をクリーンインストールしてみました。
問題なくインストール完了。やはりログイン画面直前で同様のメッセージ表示。
ログイン後、ドライバを適用。正常動作となっています。

なので、以下のパッケージ群に何か問題をかかえてるんじゃないでしょうか。
(Synapticでnvidiaを検索してみた結果です)
jockey-common
jockey-gtk
nvidia-common
nvidia-current
nvidia-settings
xserver-xorg-video-nouveau
一度インストール実行してみては?
既に入って入れば、再インストールとか。それでもダメだったら、xorgあたり?

オフライン

 

#6 2011-04-29 21:11:49

body-and-soul
メンバ
登録日: 2009-03-11

Re: 11.04アップグレードでX起動せず(NVIDIA)

ありがとうございます。

とりあえず、/etc/X11/xorg.conf の中の
    Driver         "nvidia"

    Driver         "nouveau"
に書き換えることによって startx に成功しました。
が、これは nvidia のドライバではなく Xorg なのです。

不思議なのは、[システム]の[システム管理]の[追加のドライバ]を見ると、NVIDIA 関連が三項目あって、その中央にある、

  ○ NVIDIAの高性能グラフィクス・ドライバー(バージョンcurrent)[推奨]

の先頭の○が緑色になっているのですが、パネル下部の表示を見ると「このドライバは有効ですが、現在使用していません」となっていることです。
つまり、インストールはされているが使用されていない、ということなのでしょうか?

どうも不思議です。
お気づきの点などありましたら、ご教示頂ければ幸いです。

オフライン

 

#7 2011-04-30 10:32:26

body-and-soul
メンバ
登録日: 2009-03-11

Re: 11.04アップグレードでX起動せず(NVIDIA)

 不完全解決(?)したのでご報告します。

 [システム]の[システム管理]の[追加のドライバ]の以下の項目を、ちょっと心配しながらも「削除」しました。
  ○ NVIDIAの高性能グラフィクス・ドライバー(バージョンcurrent)[推奨]
 そして再び、これを「有効」にするとインストールが始まりました。そして再起動。
 すると、Xが起動しません。うんざりしながら/etc/X11/xorg.confを見ると次の記述。
    Driver         "nouveau"
 これを次の記述で置き換え、
    Driver         "nvidia"
 startxするとXが起動、念の為に再起動すると無事にXが起動しました。

 しかし、ここで再度、[システム]の[システム管理]の[追加のドライバ]を見ると、
  ○ NVIDIAの高性能グラフィクス・ドライバー(バージョンcurrent)[推奨]
 この○が緑色になっているのですが、パネル下部の表示を見ると「このドライバは有効ですが、現在使用していません」となっています。
 うーんと思わず唸りましたが、しかし、/etc/X11/xorg.confでは確かにドライバは"nvidia"です。これを信用するしかないと思ってはいますが、どうもよくわかりません。

 以上、とても完全解決とはいきませんが、まあとりあえずはXも起動しているのでヨシとします。

オフライン

 

#8 2011-04-30 17:40:16

marin
メンバ
登録日: 2007-02-13

Re: 11.04アップグレードでX起動せず(NVIDIA)

 >「このドライバは有効ですが、現在使用していません」となっています。

 自分の場合も10.10でもこのようになっていました。今朝、11.04にアップグレードしましたが
同じように表示されています。jockeyに何か問題でもあるんでしょうか。

 それから次のコマンドでドライバーの状況がわかります。アップグレード直後の状態です。

  $ dkms status
   nvidia-current, 270.41.06, 2.6.38-8-generic, i686: installed
   nvidia-current, 270.41.06, 2.6.35-29-generic, i686: installed

「installed」のところが「build」になっていた場合は

  $ sudo dkms install -m nvidia-current -v 270.41.06 -k 2.6.38-8-generic

でinstallができます。

 DKMSについては以下が参考になります。

 https://forums.ubuntulinux.jp/viewtopic.php?id=9860




  

オフライン

 

#9 2011-04-30 19:03:35

body-and-soul
メンバ
登録日: 2009-03-11

Re: 11.04アップグレードでX起動せず(NVIDIA)

 なるほど、こういうツールがあるんですね。初めて知りました。
 私のところでは以下のようになります。

$ dkms status
nvidia-current, 270.41.06, 2.6.38-8-generic-pae, i686: installed
tp-smapi, 0.40, 2.6.38-8-generic-pae, i686: installed

 marinさんとは表示が異なりますが、こんなものでしょうか?

オフライン

 

#10 2011-04-30 20:40:51

marin
メンバ
登録日: 2007-02-13

Re: 11.04アップグレードでX起動せず(NVIDIA)

>$ dkms status
 nvidia-current, 270.41.06, 2.6.38-8-generic-pae, i686: installed
 tp-smapi, 0.40, 2.6.38-8-generic-pae, i686: insta

これでいいと思います。
カーネルのアップデートがあった場合、自動でその新しいカーネルでも使えるようになっています。
但し、古くなったカーネルからは削除されますので、その都度、DKMSコマンドでインストール
してください。

 /usr/src以下に両ドライバーのフォルダーがあると思います。tp-smapiについては私には
よくわかりません。

オフライン

 

#11 2011-04-30 20:46:42

body-and-soul
メンバ
登録日: 2009-03-11

Re: 11.04アップグレードでX起動せず(NVIDIA)

 ありがとうございました。
 これにてクローズとさせて頂きたいと思います。

 教訓は、事前調査もせずに軽々にバージョンアップしてはならないということですね。
 これまで失敗したことがなかったとしても。

オフライン

 

#12 2011-05-08 13:47:38

Mamapapa
メンバ
登録日: 2010-01-05

Re: 11.04アップグレードでX起動せず(NVIDIA)

すみません、横から失礼します。

$ dkms status
を実行しても、何も表示されないのですが、この場合はどうすればよいのでしょうか?

オフライン

 

#13 2011-05-08 14:19:47

hmatsue
アドバイザ
登録日: 2009-03-10

Re: 11.04アップグレードでX起動せず(NVIDIA)

Mamapapa による投稿:

すみません、横から失礼します。

$ dkms status
を実行しても、何も表示されないのですが、この場合はどうすればよいのでしょうか?

Mamapapaさんの使用機器、これまでに試した内容、現在の状態など不明ですが、基本的には別の話題(似たような症状であったとしても)だと思いますので、別トピックを起こしていただいた方がよいかと思います。

オフライン

 

#14 2011-05-09 20:53:59

Mamapapa
メンバ
登録日: 2010-01-05

Re: 11.04アップグレードでX起動せず(NVIDIA)

hmatsue さん

わかりました。新しく立てます。
ありがとうございました。

オフライン

 

Board footer

Powered by FluxBB