お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2012-09-06 16:31:12

roswell
メンバ
登録日: 2008-10-30

[質問] cvs pserver proxy経由でのアクセスについて

社内からproxy経由で、cvs pserverに接続を試みたのですがアクセス出来ませんでした。
cvsのoptionの指定方法に問題があるのでしょうか?
ご教示お願いします。

yama@roswell:~$ cvs -d ":pserver:proxy=proxy.company.co.jp;proxyport=10080:anonymous@cvs.namazu.org:/storage/cvsroot" login
Logging in to :pserver:proxy=proxy.company.co.jp;proxyport=10080@cvs.namazu.org:2401/storage/cvsroot
cvs [login aborted]: hostname nor servname provided, or not known

環境は、
yama@roswell:~$ uname -a
Linux roswell 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
yama@roswell:~$ cvs --version | grep -i version
Concurrent Versions System (CVS) 1.12.13-MirDebian-6 (client/server)

cvs infoでは、
`proxy=HOSTNAME'
`proxyport=PORT'
     ...
     For example, to connect pserver via a web proxy listening on port
     8000 of www.myproxy.net, you would use a method of:

          :pserver;proxy=www.myproxy.net;proxyport=8000:PSERVER_CONNECTION_STRING

     *NOTE_ In the above example, PSERVER_CONNECTION_STRING is still
     required to connect and authenticate to the CVS server, as noted
     ...

     These options first appeared in CVS version 1.12.7 and are valid as
     modifcations to the `gserver' and `pserver' connection methods.

とあり、

cvs 1.12.7以降で対応されいる様なので、proxy経由でアクセス出来ると思うのですが...

オフライン

 

#2 2012-09-06 17:38:42

hito
管理者
登録日: 2007-03-18

Re: [質問] cvs pserver proxy経由でのアクセスについて

:pserver(セミコロン)proxy=……であるべきところが、:pserver(コロン)proxy=……になっているように見えます。

ここを再確認してみて頂けますか?

オフライン

 

#3 2012-09-06 18:19:14

roswell
メンバ
登録日: 2008-10-30

Re: [質問] cvs pserver proxy経由でのアクセスについて

hito による投稿:

:pserver(セミコロン)proxy=……であるべきところが、:pserver(コロン)proxy=……になっているように見えます。

ここを再確認してみて頂けますか?

hitoさん、

yama@roswell:~$ cvs -d ":pserver;proxy=proxy.company.co.jp;proxyport=10080:anonymous@cvs.namazu.org:/storage/cvsroot" login
Logging in to :pserver:anonymous@cvs.namazu.org:2401/storage/cvsroot
CVS password:

となり、正しく動作しました。
ご教示ありがとうございました。

オフライン

 

Board footer

Powered by FluxBB