お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2012-11-12 14:08:57

ponk
メンバ
登録日: 2010-04-24

ソフトウェアアップデートできません。

■環境
Ubuntu12.04(インストールした直後)

ソフトウェアアップデートができません。
アップデートマネージャーにてアップデートをインストールしようとすると
「パッケージファイルのダウンロードに失敗しました。インターネット接続を確認してください。」
というメッセージが出現します。
現れたメッセージの詳細をクリックすると以下の情報が現れます。

Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/t/tzdata/tzdata_2012e-0ubuntu0.12.04.1_all.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc-bin_2.15-0ubuntu10.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6_2.15-0ubuntu10.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-pkg4.12_0.8.16~exp12ubuntu10.5_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/g/gnupg/gpgv_1.4.11-3ubuntu2.1_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/g/gnupg/gnupg_1.4.11-3ubuntu2.1_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt_0.8.16~exp12ubuntu10.5_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-inst1.4_0.8.16~exp12ubuntu10.5_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/d/dbus/libdbus-1-3_1.4.18-1ubuntu1.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apparmor/apparmor_2.7.102-0ubuntu3.4_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/o/openldap/libldap-2.4-2_2.4.28-1.1ubuntu4.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/p/parted/libparted0debian1_2.3-8ubuntu5.1_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/libx/libxml2/libxml2_2.7.8.dfsg-5.1ubuntu4.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/c/colord/colord_0.1.16-2ubuntu0.1_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/u/udev/udev_175-0ubuntu9.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/m/mesa/libgl1-mesa-dri_8.0.4-0ubuntu0.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/x/xorg-server/xserver-xorg-core_1.11.4-0ubuntu10.8_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/m/mesa/libgl1-mesa-glx_8.0.4-0ubuntu0.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/x/x11-utils/x11-utils_7.6+4ubuntu0.1_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/g/gnome-media/gnome-media_3.4.0-0ubuntu3.1_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/language-pack-en-base/language-pack-en-base_12.04+20120801_all.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/language-pack-gnome-en-base/language-pack-gnome-en-base_12.04+20120801_all.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-opengl_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-svg_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-declarative_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqtgui4_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-xmlpatterns_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-network_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-script_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-sql_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-dbus_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-xml_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqtcore4_4.8.1-0ubuntu4.3_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/m/mesa/libxatracker1_8.0.4-0ubuntu0.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/libx/libxslt/libxslt1.1_1.1.26-8ubuntu1.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/u/update-manager/update-manager_0.156.14.11_all.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/u/update-manager/update-manager-core_0.156.14.11_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/aptdaemon/python-aptdaemon_0.43+bzr805-0ubuntu6_all.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/aptdaemon/aptdaemon-data_0.43+bzr805-0ubuntu6_all.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/u/update-notifier/update-notifier-common_0.119ubuntu8.6_all.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/m/mesa/libglu1-mesa_8.0.4-0ubuntu0.2_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/shadow/passwd_4.1.4.2+svn3283-3ubuntu5.1_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-utils_0.8.16~exp12ubuntu10.5_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/i/isc-dhcp/isc-dhcp-client_4.1.ESV-R4-0ubuntu5.5_i386.deb Hash Sum mismatch
Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/i/isc-dhcp/isc-dhcp-common_4.1.ESV-R4-0ubuntu5.5_i386.deb Hash Sum mismatch


また端末よりsudo apt-get updateしますと最終的に

W: GPG エラー: http://jp.archive.ubuntu.com precise Release: 以下の署名が無効です: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: gzip:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_precise-security_universe_source_Sources の取得に失敗しました  ハッシュサムが適合しません

E: Some index files failed to download. They have been ignored, or old ones used instead.

といったメッセージが現れアップデートできません。


アップデートできない原因と対策方法をご教授いただけると幸いです。

オフライン

 

#2 2012-11-13 13:11:21

ponk
メンバ
登録日: 2010-04-24

Re: ソフトウェアアップデートできません。

アップデートマネージャーにてアップデートを何度か試していたところ、アップデートできました。
理由は不明です。
sudo apt-get updateに関しては未だに以下の警告が最後に出力されます。

W: gzip:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_precise-security_universe_binary-i386_Packages の取得に失敗しました  ハッシュサムが適合しません

W: http://security.ubuntu.com/ubuntu/dists/precise-security/restricted/i18n/Index の取得に失敗しました 

E: Some index files failed to download. They have been ignored, or old ones used instead.

アップデートできた後はGPGエラーは出現しなくなりました。
どなたかの参考になるかと思いましたので投稿しました。

オフライン

 

#3 2013-01-23 09:31:12

ponk
メンバ
登録日: 2010-04-24

Re: ソフトウェアアップデートできません。

しばらくそのまま使用していましたが、やはりアップデートでの不具合が多発しているので、どなたかお知恵をお貸しください。
アップデートマネージャーを立ち上げると以下のメッセージが立ち上がります。

パッケージ情報を初期化できませんでした
パッケージ情報の初期化中に解決できない問題が発生しました。
'update-manager'パッケージのバグとして、以下のエラーメッセージを含めてレポートしてください:
'E:パッケージファイル /var/lib/apt/lists/jp.archive.ubuntu.com_ubuntu_dists_precise_universe_binary-i386_Packages を解釈することができません (1), E:パッケージリストまたはステータスファイルを解釈またはオープンすることができません。'

どうすれば良いのでしょうか?

オフライン

 

#4 2013-01-23 10:44:04

Tako090929
メンバ
登録日: 2009-09-29

Re: ソフトウェアアップデートできません。

インターネット接続に不具合があるようです。

私も最近経験した事例は、pc起動直後には繋がっているが頻繁に途切れるというものでした。

あなたのインターネット接続の方式は不明ですが、おおもとのモデムとかルーターを再起動してみてはいかがでしょうか。
私の場合はCATVのモデム再起動で解消しました。

オフライン

 

#5 2013-01-23 13:02:24

ponk
メンバ
登録日: 2010-04-24

Re: ソフトウェアアップデートできません。

Tako090929さん

ご回答ありがとうございます。
インターネット接続は問題ないと思われます。
今現在も該当マシンから書き込みをしています。
その他の原因はないのでしょうか?

オフライン

 

#6 2013-01-23 13:34:35

Tako090929
メンバ
登録日: 2009-09-29

Re: ソフトウェアアップデートできません。

proxy?

インデックスファイルのダウンロードに失敗しているので、あとはプロキシがあるのかなとおもいます。

オフライン

 

#7 2013-01-23 23:14:42

bybywin
メンバ
From: 日本国群馬県
登録日: 2011-04-22

Re: ソフトウェアアップデートできません。

12.04LTSでTako090929様同じ様な状態になりました、あれやこれやするのも勉強
なので苦労されるのも、スキル向上の為には良いと思いますが、精神衛生上良くないので、
12.04.1LTSを新規にインストールする事お薦めします。

バグが解決されており、スッキリ、シャッキリでした.

オフライン

 

#8 2013-01-24 09:33:10

ponk
メンバ
登録日: 2010-04-24

Re: ソフトウェアアップデートできません。

Tako090929さん
bybywinさん

ご返答ありがとうございます。
直近では難しそうですが、近日中に12.04.1LTSしてみます。

オフライン

 

#9 2013-01-30 15:45:48

ponk
メンバ
登録日: 2010-04-24

Re: ソフトウェアアップデートできません。

12.04.1LTSを再インストールしましたが、相変わらず不具合が発生します。
こちらで実行したのは12.04.1LTSを再インストールした直後に
LANG=C xdg-user-dirs-gtk-update
でホームディレクトリを英語名にしたのみです。

現状のhistory
xxxx@xxxx:~$ history
    1  LANG=C xdg-user-dirs-gtk-update
    2  exit
    3  ifconfig
    4  sudo apt-get update
    5  sudo apt-get upgrade

atp-get updateの結果は以下の状態です。
xxxx@xxxx:~$ sudo apt-get update
[sudo] password for xxxx:
無視 http://archive.ubuntulinux.jp precise InRelease
無視 http://archive.ubuntulinux.jp precise InRelease                           
ヒット http://archive.ubuntulinux.jp precise Release.gpg                       
ヒット http://archive.ubuntulinux.jp precise Release.gpg                       
ヒット http://archive.ubuntulinux.jp precise Release                           
ヒット http://archive.ubuntulinux.jp precise Release                           
ヒット http://archive.ubuntulinux.jp precise/main Sources                     
無視 http://jp.archive.ubuntu.com precise InRelease                           
無視 http://jp.archive.ubuntu.com precise-updates InRelease                   
無視 http://jp.archive.ubuntu.com precise-backports InRelease                 
無視 http://security.ubuntu.com precise-security InRelease                     
ヒット http://security.ubuntu.com precise-security Release.gpg
ヒット http://security.ubuntu.com precise-security Release     
ヒット http://security.ubuntu.com precise-security/main Sources               
ヒット http://security.ubuntu.com precise-security/restricted Sources         
ヒット http://security.ubuntu.com precise-security/multiverse Sources         
ヒット http://security.ubuntu.com precise-security/main i386 Packages         
ヒット http://security.ubuntu.com precise-security/restricted i386 Packages   
ヒット http://security.ubuntu.com precise-security/multiverse i386 Packages   
ヒット http://security.ubuntu.com precise-security/main TranslationIndex       
ヒット http://security.ubuntu.com precise-security/multiverse TranslationIndex
ヒット http://security.ubuntu.com precise-security/restricted TranslationIndex
ヒット http://security.ubuntu.com precise-security/universe TranslationIndex   
取得:1 http://security.ubuntu.com precise-security/universe Sources [22.1 kB] 
取得:2 http://security.ubuntu.com precise-security/universe i386 Packages [78.1 kB]
ヒット http://security.ubuntu.com precise-security/main Translation-en         
ヒット http://security.ubuntu.com precise-security/multiverse Translation-en   
ヒット http://security.ubuntu.com precise-security/restricted Translation-en   
ヒット http://security.ubuntu.com precise-security/universe Translation-en     
ヒット http://archive.ubuntulinux.jp precise/main i386 Packages               
ヒット http://archive.ubuntulinux.jp precise/main TranslationIndex
ヒット http://jp.archive.ubuntu.com precise Release.gpg                       
取得:3 http://jp.archive.ubuntu.com precise-updates Release.gpg [198 B]       
ヒット http://archive.ubuntulinux.jp precise/multiverse Sources
無視 http://archive.ubuntulinux.jp precise/multiverse TranslationIndex
ヒット http://jp.archive.ubuntu.com precise-backports Release.gpg
ヒット http://jp.archive.ubuntu.com precise Release             
ヒット http://jp.archive.ubuntu.com precise-updates Release                   
無視 http://jp.archive.ubuntu.com precise-updates Release                     
ヒット http://jp.archive.ubuntu.com precise-backports Release                 
ヒット http://jp.archive.ubuntu.com precise/main Sources                       
ヒット http://jp.archive.ubuntu.com precise/restricted Sources 
ヒット http://jp.archive.ubuntu.com precise/multiverse Sources 
ヒット http://jp.archive.ubuntu.com precise/main i386 Packages 
ヒット http://jp.archive.ubuntu.com precise/restricted i386 Packages
ヒット http://jp.archive.ubuntu.com precise/universe i386 Packages
ヒット http://jp.archive.ubuntu.com precise/main TranslationIndex
ヒット http://jp.archive.ubuntu.com precise/multiverse TranslationIndex
ヒット http://jp.archive.ubuntu.com precise/restricted TranslationIndex
ヒット http://jp.archive.ubuntu.com precise/universe TranslationIndex
無視 http://jp.archive.ubuntu.com precise-updates/main Sources/DiffIndex
無視 http://jp.archive.ubuntu.com precise-updates/restricted Sources/DiffIndex
無視 http://jp.archive.ubuntu.com precise-updates/universe Sources/DiffIndex
取得:4 http://jp.archive.ubuntu.com precise-updates/multiverse Sources [4,737 B]
100% [4 Sources bzip2 5,000 B] [ヘッダの待機中です] [ヘッダの待   
bzip2: Data integrity error when decompressing.
    Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

無視 http://jp.archive.ubuntu.com precise-updates/main i386 Packages/DiffIndex
無視 http://jp.archive.ubuntu.com precise-updates/restricted i386 Packages/DiffIndex
無視 http://jp.archive.ubuntu.com precise-updates/multiverse i386 Packages/DiffIndex
ヒット http://jp.archive.ubuntu.com precise-updates/main TranslationIndex
ヒット http://jp.archive.ubuntu.com precise-updates/multiverse TranslationIndex
ヒット http://jp.archive.ubuntu.com precise-updates/restricted TranslationIndex
取得:5 http://jp.archive.ubuntu.com precise-updates/universe TranslationIndex [2,850 B]
ヒット http://jp.archive.ubuntu.com precise-backports/main Sources             
ヒット http://jp.archive.ubuntu.com precise-backports/restricted Sources       
ヒット http://jp.archive.ubuntu.com precise-backports/multiverse Sources       
ヒット http://jp.archive.ubuntu.com precise-backports/main i386 Packages       
ヒット http://jp.archive.ubuntu.com precise-backports/restricted i386 Packages
ヒット http://jp.archive.ubuntu.com precise-backports/multiverse i386 Packages
ヒット http://jp.archive.ubuntu.com precise-backports/main TranslationIndex   
ヒット http://jp.archive.ubuntu.com precise-backports/multiverse TranslationIndex
ヒット http://jp.archive.ubuntu.com precise-backports/restricted TranslationIndex
ヒット http://jp.archive.ubuntu.com precise-backports/universe TranslationIndex
取得:6 http://jp.archive.ubuntu.com precise/universe Sources [6,239 kB]       
取得:7 http://jp.archive.ubuntu.com precise/multiverse i386 Packages [155 kB] 
ヒット http://jp.archive.ubuntu.com precise/main Translation-en               
ヒット http://jp.archive.ubuntu.com precise/multiverse Translation-ja         
ヒット http://jp.archive.ubuntu.com precise/restricted Translation-ja         
ヒット http://jp.archive.ubuntu.com precise/restricted Translation-en         
ヒット http://jp.archive.ubuntu.com precise/universe Translation-ja           
ヒット http://jp.archive.ubuntu.com precise/universe Translation-en           
ヒット http://jp.archive.ubuntu.com precise-updates/main Sources               
ヒット http://jp.archive.ubuntu.com precise-updates/restricted Sources         
ヒット http://jp.archive.ubuntu.com precise-updates/universe Sources           
ヒット http://jp.archive.ubuntu.com precise-updates/main i386 Packages         
ヒット http://jp.archive.ubuntu.com precise-updates/restricted i386 Packages   
ヒット http://jp.archive.ubuntu.com precise-updates/multiverse i386 Packages   
ヒット http://jp.archive.ubuntu.com precise-updates/multiverse Translation-ja 
ヒット http://jp.archive.ubuntu.com precise-updates/multiverse Translation-en
取得:8 http://jp.archive.ubuntu.com precise-backports/universe Sources [24.3 kB]
取得:9 http://jp.archive.ubuntu.com precise-backports/universe i386 Packages [25.7 kB]
ヒット http://jp.archive.ubuntu.com precise-backports/main Translation-en     
ヒット http://jp.archive.ubuntu.com precise-backports/multiverse Translation-en
ヒット http://jp.archive.ubuntu.com precise-backports/restricted Translation-en
ヒット http://jp.archive.ubuntu.com precise-backports/universe Translation-en 
取得:10 http://jp.archive.ubuntu.com precise-updates/universe i386 Packages [228 kB]
取得:11 http://jp.archive.ubuntu.com precise/main Translation-ja [477 kB]     
取得:12 http://jp.archive.ubuntu.com precise/multiverse Translation-en [112 kB]
エラー http://jp.archive.ubuntu.com precise-updates/multiverse Sources         
  406  Not Acceptable
取得:13 http://jp.archive.ubuntu.com precise-updates/main Translation-ja [477 kB]
取得:14 http://jp.archive.ubuntu.com precise-updates/main Translation-en [286 kB]
取得:15 http://jp.archive.ubuntu.com precise-updates/restricted Translation-en [10.7 kB]
ヒット http://archive.ubuntulinux.jp precise/main Translation-ja               
エラー http://archive.ubuntulinux.jp precise/multiverse i386 Packages         
  404  Not Found [IP: 160.26.2.181 80]
無視 http://archive.ubuntulinux.jp precise/main Translation-ja_JP             
無視 http://archive.ubuntulinux.jp precise/main Translation-en                 
無視 http://archive.ubuntulinux.jp precise/multiverse Translation-ja_JP
無視 http://archive.ubuntulinux.jp precise/multiverse Translation-ja
無視 http://archive.ubuntulinux.jp precise/multiverse Translation-en
212 B を 30秒 で取得しました (6 B/s)
W: GPG エラー: http://jp.archive.ubuntu.com precise-updates Release: 以下の署名が無効です: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: http://archive.ubuntulinux.jp/ubuntu-ja-non-free/dists/precise/multiverse/binary-i386/Packages の取得に失敗しました  404  Not Found [IP: 160.26.2.181 80]

W: gzip:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_precise-security_universe_source_Sources の取得に失敗しました  ハッシュサムが適合しません

W: gzip:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_precise-security_universe_binary-i386_Packages の取得に失敗しました  ハッシュサムが適合しません

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise_universe_source_Sources の取得に失敗しました  ハッシュサムが適合しません

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise_multiverse_binary-i386_Packages の取得に失敗しました  ハッシュサムが適合しません

W: http://jp.archive.ubuntu.com/ubuntu/dists/precise-updates/multiverse/source/Sources の取得に失敗しました  406  Not Acceptable

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise-updates_universe_binary-i386_Packages の取得に失敗しました  Encountered a section with no Package: header

W: http://jp.archive.ubuntu.com/ubuntu/dists/precise-updates/universe/i18n/Index の取得に失敗しました 

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise-backports_universe_source_Sources の取得に失敗しました  ハッシュサムが適合しません

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise-backports_universe_binary-i386_Packages の取得に失敗しました  ハッシュサムが適合しません

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise_main_i18n_Translation-ja の取得に失敗しました  Encountered a section with no Package: header

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise_multiverse_i18n_Translation-en の取得に失敗しました  Encountered a section with no Package: header

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise-updates_main_i18n_Translation-ja の取得に失敗しました  Encountered a section with no Package: header

W: gzip:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise-updates_main_i18n_Translation-en の取得に失敗しました  Encountered a section with no Package: header

W: copy:/var/lib/apt/lists/partial/jp.archive.ubuntu.com_ubuntu_dists_precise-updates_restricted_i18n_Translation-en の取得に失敗しました  Encountered a section with no Package: header

E: Some index files failed to download. They have been ignored, or old ones used instead.
xxxx@xxxx:~$


どなたか、対処法を伝授していただけないでしょうか。

オフライン

 

#10 2013-02-01 16:51:45

ponk
メンバ
登録日: 2010-04-24

Re: ソフトウェアアップデートできません。

Uuntu10.04を使用していた際にはこのような不具合が起こっていなかったため、一旦Uuntu10.04に戻しました。(再インストール)
戻したところ不具合は発生していません。
Ubuntuは自宅と職場の全3台で使用していますが、このような不具合が出るのは該当1台のみなので、該当機種による問題なのかもしれません。

オフライン

 

#11 2013-05-20 18:20:43

kita20xx
新しいメンバ
登録日: 2013-05-20

Re: ソフトウェアアップデートできません。

私もponkさんと同じ症状が出ました。
何度 apt-get update しても直らなかったのですが、以下の手順を行ったら直りました。
ちなみに私がインストールした Ubuntu のバージョンは 12.04.2 (AMD64) です。

1. /var/lib/apt/listsディレクトリを削除(リネームでもOK)

コード:

rm -r /var/lib/apt/lists
# mv /var/lib/apt/lists /var/lib/apt/lists_bk でもOK

2. 新規でlistsディレクトリとpartialディレクトリを作成

コード:

mkdir /var/lib/apt/lists
mkdir /var/lib/apt/lists/partial

3.apt-get の不要なキャッシュを削除

コード:

apt-get autoclean
apt-get clean

4.アップデートを実施(2回くらい)

コード:

apt-get update

上記の手順を実施したらうまくいきました。
正直なぜかは分かりませんが、インストール時に何か不要なファイルやキャッシュが残ってしまっているのかもしれません...

前述しましたが、直った理由をご説明できません。
参考程度にしていただけたら幸いです。

オフライン

 

#12 2013-07-25 17:00:55

ponk
メンバ
登録日: 2010-04-24

Re: ソフトウェアアップデートできません。

kita20xxさん

ご助言いただき、ありがとうございます。
こちらも同様の手順を試したところ、解決したようです。
しばらく、この状態で様子をみます。
また、同様の不具合が生じましたら、こちらに書き込みをします。

オフライン

 

Board footer

Powered by FluxBB