お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2013-11-08 19:20:19

yzk0402
メンバ
登録日: 2013-11-08

音がでなくなり,調べたら/proc/asound/cardsありません...

どうかお助け下さい.

先日,wavesurferというプログラムをインストールし,
その際,OpenSoundSystemをつかうように〜みたいな説明のサイトを見ていじくっていたら,音が出なくなってしまいました.

その後,Ubuntuのサポートページを見ながら,修復しようと試みたのですが,
他サイトでよく手始めに表示している「/proc/asound/cards」がありません.
ディレクトリ「asound」自体がありません...

いろいろ努力はしたのですが,どうにも手が負えなさそうなので,何方様か助けて下さい...

以下は,自分で試したコマンドの出力結果です.

$ lspci | egrep -i multimedia\|audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

----- ----- -----
$ lspci -v -s `lspci | grep -i audio | sed -e 's/\(\w*\)\s.*/\1/'`
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
    Subsystem: ASUSTeK Computer Inc. Device 108d
    Flags: bus master, fast devsel, latency 0, IRQ 5
    Memory at f7e18000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>

----- ----- -----
$ cat /proc/asound/cards
cat: /proc/asound/cards: そのようなファイルやディレクトリはありません

----- ----- -----
$ aplay -l
aplay: device_list:252: サウンドカードが見つかりません...

----- ----- -----
$ aplay -L
default
    Playback/recording through the PulseAudio sound server

オフライン

 

#2 2013-11-09 10:37:13

Mocchi
管理者
登録日: 2009-05-17

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

yzk0402 による投稿:

その際,OpenSoundSystemをつかうように〜みたいな説明のサイトを見ていじくっていたら,音が出なくなってしまいました.

どのような操作をしたのか、思い出せる範囲で構いませんので、提示してください。

オフライン

 

#3 2013-11-09 17:48:16

yzk0402
メンバ
登録日: 2013-11-08

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

/usr/bin/pactl load-module module-oss
sudo dpkg-reconfigure linux-sound-base

上のコマンドを実行した記憶があります.

オフライン

 

#4 2013-11-09 21:30:17

Mocchi
管理者
登録日: 2009-05-17

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

ありがとうございます。

それでは、以下のコマンドを再度実行してください。選択肢に「ALSA」「OSS」「デフォルト」が出ますので、そこで「ALSA」を選択してください。
$ sudo dpkg-reconfigure linux-sound-base

選択したら、システムをリブートしてください。ALSAが有効になり、「/proc/asound/cards」を見つけることができるようになると思います。

次に、wavesurferというアプリケーションを使えるようにする方法なのですが、Ubuntuのバージョンによって方法が異なります。お使いのUbuntuのバージョンを教えてください。

オフライン

 

#5 2013-11-10 14:56:46

yzk0402
メンバ
登録日: 2013-11-08

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

Mocchi による投稿:

ありがとうございます。

それでは、以下のコマンドを再度実行してください。選択肢に「ALSA」「OSS」「デフォルト」が出ますので、そこで「ALSA」を選択してください。
$ sudo dpkg-reconfigure linux-sound-base

選択したら、システムをリブートしてください。ALSAが有効になり、「/proc/asound/cards」を見つけることができるようになると思います。

回答ありがとうございます.
実行してみたのですが,設定は既に「ALSA」になっており,
一応もう一度選択直し,リブートを行ったのですが,解決されていませんでした...

バージョンは13.10です.

オフライン

 

#6 2013-11-10 17:02:29

Mocchi
管理者
登録日: 2009-05-17

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

yzk0402 による投稿:

実行してみたのですが,設定は既に「ALSA」になっており,
一応もう一度選択直し,リブートを行ったのですが,解決されていませんでした...

了解しました。原因を特定したいので、以下の3つのコマンドの出力を教えてください。

$ dpkg -l | grep 'alsa-'

$ dpkg -l | grep ' oss'

$ ls /etc/modprobe.d/


yzk0402 による投稿:

バージョンは13.10です.

13.04以降であれば、osspdというパッケージをインストールするだけで、Open Sound Systemアプリケーションで音声入出力ができようになっています。ですので今回の場合は、ALSAを有効にできれば目的を達成できると思います。

オフライン

 

#7 2013-11-11 22:03:16

yzk0402
メンバ
登録日: 2013-11-08

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

お手数かけます.
以下,コマンドの出力になります.

----- ----- ----- ----- -----

$ dpkg -l |grep 'alsa-'
ii  alsa-base                                 1.0.25+dfsg-0ubuntu4                    all          ALSA driver configuration files
ii  alsa-utils                                1.0.25-4ubuntu2                         amd64        Utilities for configuring and using ALSA

----- ----- ----- ----- -----

$ dpkg -l |grep 'oss'
ii  libflac8:amd64                            1.3.0-1                                 amd64        Free Lossless Audio Codec - runtime C library
ii  libieee1284-3:amd64                       0.2.11-11                               amd64        cross-platform library for parallel port access
ii  libkrosscore4                             4:4.11.2-0ubuntu2                       amd64        Kross Core Library
ii  libwavpack1:amd64                         4.60.1-3                                amd64        audio codec (lossy and lossless) - library
ii  libwxgtk2.8-0:amd64                       2.8.12.1-11ubuntu4                      amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
ii  oss4-base                                 4.2-build2005-2ubuntu1                  amd64        Open Sound System - base package
ii  oss4-dkms                                 4.2-build2005-2ubuntu1                  amd64        Open Sound System - DKMS module sources

----- ----- ----- ----- -----

$ ls /etc/modprobe.d/
alsa-base.conf              blacklist-rare-network.conf  oss4-base.conf
blacklist-ath_pci.conf      blacklist-watchdog.conf      oss4-base_noALSA.conf
blacklist-firewire.conf     blacklist.conf               oss4-base_noOSS3.conf
blacklist-framebuffer.conf  dkms.conf                    vmwgfx-fbdev.conf
blacklist-modem.conf        iwlwifi.conf
blacklist-oss.conf          mlx4.conf

----- ----- ----- ----- -----

Mocchi による投稿:

13.04以降であれば、osspdというパッケージをインストールするだけで、Open Sound Systemアプリケーションで音声入出力ができようになっています。ですので今回の場合は、ALSAを有効にできれば目的を達成できると思います。

そうなんですか!ありがとうございます!

オフライン

 

#8 2013-11-11 22:43:11

Mocchi
管理者
登録日: 2009-05-17

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

どうもありがとうございます。確認したところ、ファイル「/etc/modprobe.d/oss4-base_noALSA.conf」がALSAを無効にしているようです。このファイルはパッケージ「oss4-base」に由来します。このパッケージをアンインストールして再起動すれば、ALSAが有効になると思います。

合わせて、パッケージ「oss4-dkms」もアンインストールすることをお奨めします。

オフライン

 

#9 2013-11-12 06:18:41

yzk0402
メンバ
登録日: 2013-11-08

Re: 音がでなくなり,調べたら/proc/asound/cardsありません...

Mocchi による投稿:

どうもありがとうございます。確認したところ、ファイル「/etc/modprobe.d/oss4-base_noALSA.conf」がALSAを無効にしているようです。このファイルはパッケージ「oss4-base」に由来します。このパッケージをアンインストールして再起動すれば、ALSAが有効になると思います。

合わせて、パッケージ「oss4-dkms」もアンインストールすることをお奨めします。

無事音が出ました!
ここ最近ずっと困っていたので助かりました.
ありがとうございました!

オフライン

 

Board footer

Powered by FluxBB