お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2008-03-31 11:03:05

akira_penguin
メンバ
登録日: 2008-03-31

xubuntuでブランクスクリーンにさせない方法は

xubuntuを使っています。

複数のパソコンを同時に立ち上げるので、常にデスクトップを表示しておきたいのです。

スクリーンセーバーを無効にし、電源管理でスクリーンのロックをしないようにしても、数10分でブランクスクリーンになっていまいます。
なにかキーを押すと画面は再表示されます。

ubuntuでは同様の設定をすると常にデスクトップを表示出来ています。

どなたか解決策をご存じないでしょうか?

オフライン

 

#2 2008-03-31 18:36:30

Shibata
管理者
From: 東京
登録日: 2006-10-25

Re: xubuntuでブランクスクリーンにさせない方法は

Xubuntuは使っていないので、Xubuntuでの設定については他の方にお任せするとして、ディスプレイ側の省電力機能が有効になっていたりはしないでしょうか。Ubuntuでは消えないのは、ディスプレイ側のそれを無効化しているからという可能性もあります。

オフライン

 

#3 2008-04-01 01:35:51

anoir
モデレータ
From: Berkeley, CA
登録日: 2007-01-13

Re: xubuntuでブランクスクリーンにさせない方法は

xset -q

のScreen SaverとDPMSのところはどうなってますか。現在使っているマシンでは

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

になっています。この辺が怪しいかなと思います。

オフライン

 

#4 2008-04-01 10:17:58

akira_penguin
メンバ
登録日: 2008-03-31

Re: xubuntuでブランクスクリーンにさせない方法は

xset -q
の該当箇所です。

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
DPMS (Energy Star):
  Standby: 1200    Suspend: 1800    Off: 2400
  DPMS is Enabled
  Monitor is On

GUIでの設定が反映されていないようです。
また、 /etc/X11/xorg.conf の DPMS オプションをコメントにしても同様でした。

実際に以下のようにするにはどうすれば良いでしょうか?

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

できれば Xfce の起動スクリプトで対処したいのですが、どのファイルなのか知る方法がわかりません。

オフライン

 

#5 2008-04-01 12:15:56

anoir
モデレータ
From: Berkeley, CA
登録日: 2007-01-13

Re: xubuntuでブランクスクリーンにさせない方法は

xset dpms 0 0 0

でDPMSのところのStandby, Suspend, Offを0に設定できます。

http://xjman.dsl.gr.jp/man/man1/xset.1x.html

/etc/X11/xinit/xinitrcにでもスクリプトをおけばいいですが、単にgnome-power-managerを自動開始アプリケーションへ加えてしまうほうが簡単だと思います。

オフライン

 

#6 2008-04-02 10:16:39

akira_penguin
メンバ
登録日: 2008-03-31

Re: xubuntuでブランクスクリーンにさせない方法は

gnome-power-manager をインストールして設定してみました。
やはり数分でブランクスクリーンになるので xset q で確認してみました。

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

となり、

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600

が原因ではないかと思います。

結局、 /etc/X11/Xsession.d/98x11-local_xset というファイルを作成し、以下の3行を保存しました。

xset s 0 0
xset +dpms
xset dpms 0 0 0

Xfce の設定ファイルなど、もっと良い方法があれば教えていただけないでしょうか?

オフライン

 

#7 2008-04-02 12:48:31

anoir
モデレータ
From: Berkeley, CA
登録日: 2007-01-13

Re: xubuntuでブランクスクリーンにさせない方法は

スクリーンセーバーが原因であれば、そちらの設定で直るはずです。もしかして、Ubuntuでインストールしたマシーンを途中でxubuntu-desktopを使ってxfceに変えていますか?

gnome-power-managerで設定した値は毎回起動されていれば保存されるはずです。

オフライン

 

#8 2008-04-02 13:09:55

akira_penguin
メンバ
登録日: 2008-03-31

Re: xubuntuでブランクスクリーンにさせない方法は

いえ、ubuntu-desktop はインストールしていません。

DPMS について gnome-power-manager の設定は反映されているようなので、DPMS については anoir さんの言われていることは正しいと思います。

問題は xset q の結果で言うと以下の部分です。

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600

xubuntu のスクリーンセーバーの設定に関わらず、上記の状態です。このため、10分後にブランクスクリーンとなってしまうようです。

バグでしょうか?

実際に xubuntu を使用されている方はおられませんか?

オフライン

 

#9 2008-04-02 16:05:24

yukion
メンバ
登録日: 2007-03-11

Re: xubuntuでブランクスクリーンにさせない方法は

私は、Xubuntu7.04 を使用しています。
akira_penguin さんは 7.10 でしょうか?
バージョン違いだと、項目や表示に違いがあるかも知れませんが、ご参考になればと思い、私のPCでのxset -qの結果を貼っておきます。

Screensaver Settings で
ーーーーーーー*ーーーーーーーー*ーーーーーーーー*ーーーーーーー
Display Modes タブの
 Mode : Only One Screen Saver(スクリーンセーバーあり)
 Lock Screen はチェックなし(無効の状態)
Advanced タブの
 モニタのパワーマネジメント欄で
 Power Management Enable をチェックした状態で(有効にした状態)
xset -qの結果は
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
・・・・
DPMS (Energy Star):
  Standby: 3600    Suspend: 3600    Off: 7200
  DPMS is Enabled
  Monitor is On
となります。
ーーーーーーー*ーーーーーーーー*ーーーーーーーー*ーーーーーーーー
Display Modes タブの
Mode : Disable Screen Saver(スクリーンセーバーなし)
 Lock Screen はチェックなし(無効の状態)
Advanced タブの
 モニタのパワーマネジメント欄で
 Power Management Enable のチェックを外した状態で(無効にした状態)
xset -qの結果は
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
・・・
DPMS (Energy Star):
  Standby: 3600    Suspend: 3600    Off: 7200
  DPMS is Disabled
となりました。

私のXubuntu では、スクリーンセーバーなし・パワーマネージメント無効の状態で、PCを放置してみても、ブランクスクリーンとなることはありませんでした。
akira_penguin さんの xset -q の結果と違うところは、
DPMS is Disabled か DPMS is Enabled か 
というところでしょうか。

7.10 を使ってないので、よく分からないのですが、
最初の設定のところで、「電源管理でスクリーンのロック」を無効とされているようですが、それはパワーマネージメントを無効とする操作なのでしょうか?手元で確認出来ないので、失礼な発言でしたら、ご容赦ください。

オフライン

 

#10 2008-04-02 16:51:48

akira_penguin
メンバ
登録日: 2008-03-31

Re: xubuntuでブランクスクリーンにさせない方法は

みなさん、ご相談ありがとうございました。

以下の理由で、今回のパソコン固有の問題またはインストール時の問題と判断いたします。

・自分の他のパソコンではちゃんと設定できている
・7.04でちゃんと設定できているという情報を頂いた

再インストールをして検証いたします。

事後となりましたが、xubuntu で以下のパソコンを再利用できないかと思っておりました。

FMV-BIBLO NE3/45LR
CPU : Celeron 450MHz
MEM : 192MB(最大)
HDD : 10GB
GPU : ATI Technorogies Inc Rage Mobility P/M AGP 2x

ubuntu-desktop はさすがに重たいです。HDDを新しいものに変えれば多少は改善するとは思うのですが。

ありがとうございました。

最後の編集者: akira_penguin (2008-04-02 20:59:57)

オフライン

 

Board footer

Powered by FluxBB