お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2008-05-05 05:44:42

pul
新しいメンバ
登録日: 2008-05-05

GNOMEの文字コードを常にEUC-JPにする方法

はじめまして。

GNOMEの文字コードに関して質問があります。

「端末」→「文字コードの設定」で「EUC-JP」を選択しても
ターミナルを閉じると次に開く時には元のUTF-8に戻ってしまいます。

ターミナルを閉じても、次開いたときにUTF-8に戻らずEUC-JPのままにする
にはどうすれば良いでしょうか?

オフライン

 

#2 2008-05-05 16:40:22

Shibata
管理者
From: 東京
登録日: 2006-10-25

Re: GNOMEの文字コードを常にEUC-JPにする方法

GNOME自体をEUC-JPで運用したいというわけではなく、端末(gnome-terminal)のみのエンコーディングを設定したいということですよね。

英語フォーラム
Launchpad
bugzilla
などの記述を見る限り、今は手がないっぽいです。

オフライン

 

#3 2008-05-06 23:43:20

pul
新しいメンバ
登録日: 2008-05-05

Re: GNOMEの文字コードを常にEUC-JPにする方法

端末のみのエンコーディング設定に関しては、現状では方法がみつからないようですね。
ありがとうございます。

では、GNOME自体をEUC-JPで運用する方法はあるのでしょうか?

結局やりたいことは、Ubuntu(UTF-8)からVine Linux(EUC-JP)に
sshでログインしたときの日本語文字化けを無くすことです。

オフライン

 

#4 2008-05-07 11:37:39

tani
メンバ
登録日: 2006-10-20

Re: GNOMEの文字コードを常にEUC-JPにする方法

GNOMEというかシステム全体をEUCにするのはちょっと大変というかトラブルの元なので、
他の文字コードの設定ができそうなクライアントとかを試してみるのはどうでしょうか。
例えばSecPanelというSSHのGUIクライアントとかがあるみたいですね。(まだ試して
いないので設定できるかどうかわかりませんが。。。)

オフライン

 

#5 2008-05-07 12:16:14

yama
メンバ
登録日: 2006-10-23

Re: GNOMEの文字コードを常にEUC-JPにする方法

pul による投稿:

結局やりたいことは、Ubuntu(UTF-8)からVine Linux(EUC-JP)に
sshでログインしたときの日本語文字化けを無くすことです。

では、mltermはどうでしょう。多言語対応の端末エミュレータです。

オフライン

 

#6 2008-05-07 13:23:02

f0705
メンバ
登録日: 2007-05-03

Re: GNOMEの文字コードを常にEUC-JPにする方法

私は kterm をインストールして対処しています。
メインは Vine なので逆の場合が多いですが。
8.04 でも UTF-8 環境は、一部の全角文字が半角となってしまう問題
https://bugs.launchpad.net/ubuntu-jp-improvement/+bug/191250
は修正されなかったですね。
この問題が無くなれば ubuntu へ完全に移行したいけど、、、

オフライン

 

#7 2008-05-07 21:47:51

pul
新しいメンバ
登録日: 2008-05-05

Re: GNOMEの文字コードを常にEUC-JPにする方法

多くの返信ありがとうございます。

やはりシステム全体の文字コードを変えるのは、リスクが高いようですね。
コメントいただいた、SecPanel, mlterm, ktermを試してみたいと思います。

オフライン

 

#8 2008-05-08 11:40:48

s_k
メンバ
登録日: 2008-04-18

Re: GNOMEの文字コードを常にEUC-JPにする方法

>結局やりたいことは、Ubuntu(UTF-8)からVine Linux(EUC-JP)に
>sshでログインしたときの日本語文字化けを無くすことです。
この要件を満たすだけならOpenSSHで対応できます。
こんな感じの設定です。

SSHサーバにてsshでログインするユーザの「$HOME/.ssh/environment 」ファイルを作成します。

・ファイル内容
 LANG=<sshでログインしたいときに使う文字コード>

※環境変数名=値で好きなだけ書けます。

「/etc/ssh/sshd_config」に以下の設定を追加します。

 PermitUserEnvironment yes

※規定値は「no」です。
「/etc/init.d/ssh reload」で設定をリロードすれば完了です。

ただ申し訳ないですが、GNOME端末からの文字化けがこれで解消するかは私がLinuxを利用するマシン(Alix2)にビデオ出力がないのでわからないです。

最後の編集者: s_k (2008-05-08 11:41:17)

オフライン

 

#9 2008-05-09 15:39:11

demento
メンバ
登録日: 2008-05-09

Re: GNOMEの文字コードを常にEUC-JPにする方法

はじめまして。
わたしは下記のサイトのツールを使っています。
コンパイル時に、ローカルとリモート(固定であれば)の文字コードを指定しておけば、
cocot ssh [email protected]
のようにして接続することで自動的に文字コードを変換してくれます。
また、多分端末エミュレータは問いません。
//TildaとGnome端末しかかくにんしていませんが

http://vmi.jp/software/cygwin/cocot.html

最後の編集者: demento (2008-05-09 15:41:12)

オフライン

 

#10 2008-05-09 18:19:15

pul
新しいメンバ
登録日: 2008-05-05

Re: GNOMEの文字コードを常にEUC-JPにする方法

返信ありがとうございます。

ktermをインストールして試したら、文字化けが直りました。
ありがとうございます。
SecPanel, mltermも試してみたいと思います。

OpenSSHによる対処ですが、文字化けは直りませんでした。
私の設定方法がまずかったのかもしれませんので、
もう少し試してみます。

cocotに関しては、インストールできませんでした。
紹介していただいたサイトからソフトをダウンロードし、
「./configure」「make」「make install」の順でインストールしようと
したのですが、「./configure」の段階で下記のエラーが出てしまい
インストールできませんでした。

cocotもぜひ試してみたいので、頑張ってインストールしたいと思います。

-------- ./configure で出たエラーメッセージ -------

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

オフライン

 

#11 2008-05-09 18:22:14

hito
管理者
登録日: 2007-03-18

Re: GNOMEの文字コードを常にEUC-JPにする方法

build-essentialパッケージをインストールしてください。

# インストールしてもほかの箇所でも引っかかるかもしれませんが、
# それはその周辺20行ぐらいを貼れば誰かが答えられるかと。

オフライン

 

#12 2008-05-09 20:26:44

f0705
メンバ
登録日: 2007-05-03

Re: GNOMEの文字コードを常にEUC-JPにする方法

ちょっと脱線しますが cocot は意外と使い道があるかも。
kterm 上で UTF-8 のファイルを emacs -nw で開くと文字化けして
しまいますが、

cocot -t EUC-JP -p UTF-8 -- emacs -nw tmp.txt

とすれば文字化けも直り、一部の全角文字が半角になることも回避
できました。ただ RHEL clone 系のディストリビューションでは
kterm が提供されなくなったので仕方なく自分でコンパイルして
いますが ubuntu もいずれそうなるのではないかと心配。
mlterm も良いのですがちょっぴり重い。

オフライン

 

#13 2008-05-10 04:21:58

pul
新しいメンバ
登録日: 2008-05-05

Re: GNOMEの文字コードを常にEUC-JPにする方法

build-essentialパッケージをインストールしたら、
cocotのインストールができました!
ありがとうございます。

cocot -t UTF-8 -p EUC-JP ssh [email protected]
で、UbuntuからVine Linuxにログインしたら、文字化けしていませんでした。
助かりました。

cocot -t EUC-JP -p UTF-8 -- emacs -nw tmp.txt
のような使い方もできるんですね。なるほど〜


mlterm試したのですが、文字化けは直っていませんでした。
設定が必要なのかな。。。

SecPanelは使い方がちょっと分かりませんでした。
少し調べてみます。

オフライン

 

#14 2014-08-14 10:52:22

bebel
メンバ
登録日: 2010-08-11

Re: GNOMEの文字コードを常にEUC-JPにする方法

pul による投稿:

はじめまして。

GNOMEの文字コードに関して質問があります。

「端末」→「文字コードの設定」で「EUC-JP」を選択しても
ターミナルを閉じると次に開く時には元のUTF-8に戻ってしまいます。

ターミナルを閉じても、次開いたときにUTF-8に戻らずEUC-JPのままにする
にはどうすれば良いでしょうか?

相当前の既に終わった話題にコメントするのも何だとは思いますが、まさに同じことを思って探していたところ、解決策と思われる情報を見つけたので、自分の覚書のためにも書いておこうかと。

情報元:http://www.wheel.gr.jp/~dai/fonts/pcf_on_ubuntu.html

このページの下の方に書いてある方法が(少なくとも私にとっては)バッチリでした。
抜粋すると、
まず準備として、"EUC-JP"ロケールを以下のコマンドで作成(既にロケールが存在するならもちろん不要)

% sudo locale-gen ja_JP.EUC-JP

その上で、「LANG=ja_JP.EUC-JP」の設定でgnome-terminalを「--disable-factoryオプション付で」起動すると、最初から「端末」→「文字コードの設定」が"EUC-JP"になるようです。

% env LANG=ja_JP.EUC-JP gnome-terminal --disable-factory

私の環境だと起動時にglibのエラーが一個表示されるんですが、まぁ特に影響無いみたいなので気にしない(^^;)

オフライン

 

Board footer

Powered by FluxBB