お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2017-12-10 19:00:24

mizai
メンバ
登録日: 2017-12-05

croutonを使ったインストールで32bit版を指定できますか?

先日こちらでお世話になり、Xubuntuのインストールができました。
その節はありがとうございました。

設定などでつまづく事が多いので、インストールされているXubuntuを調べました。
・Ubuntu 16.04.3 LTS
・aarch64
使っているパソコンは32bitなのですが、64bitがインストールされています。
croutonを使って、32bit版を指定することは可能でしょうか?

(32bit版に64bit版がインストールされているのが原因なのかと考えています。)

■使っているパソコン
Chromebook c101PA(ARM系32bit)

■コマンド lsb release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:     Ubuntu 16.04.3 LTS
Release:          16.04
Codename:      xenial

■コマンド uname -m

aarch64

■困っている症状
いろいろとネットで同じ症状を調べ、対応しているのですが、同じように動きません。

・日本語設定ができない。
・ubuntuソフトウェアセンターでインストールできない。(ソフトウェアセンター含む)

■Xubuntuをインストールした時のコマンド

sudo sh ~/Downloads/crouton -r xenial -t xfce-desktop,keyboard,audio,extension,xiwi,touch


海外のサイトでは、インテルのCPUでは32bit版の指定ができると合ったのですが、
ARMでの情報はわかりませんでした。(-a i386   -a i686など)

勉強不足で理解していないことが多いのは承知しております。
アドバイス頂けますと幸いです。

オフライン

 

#2 2017-12-11 05:35:52

route15519
メンバ
From: 愛知県
登録日: 2011-01-05

Re: croutonを使ったインストールで32bit版を指定できますか?

そもそもが間違っています。
C101PAは、CPU:最大6コア、 ARM 64-bit processor, 最大2.0GHz デュアルコアCortex-A72およびクアッドコア Cortex-A53
搭載の64bit機です。
http://neos21.hatenablog.com/entry/2017/01/08/234540
機種は違うようですが、かなり試行錯誤されているようです。

オフライン

 

#3 2017-12-11 08:06:34

mizai
メンバ
登録日: 2017-12-05

Re: croutonを使ったインストールで32bit版を指定できますか?

お返事ありがとうございます。
CPUの件、勉強不足でした。訂正ありがとうございます。

ただおすすめ頂いたサイトも参考にさせて頂いていますが、こちらと同様にしても、上手く実行できませんでした。

現在の思考錯誤を整理すると
・trusty GUI起動しない(sudo startxfce4で起動しない)
・chrome 関連使えない(インストールできない)

・xenial に変更し、GUI起動出来るようになる。

日本語に変更できない
・ibus-mozcがインストールできない
・ubuntu ソフトウェアセンターでインストールするとエラーがでる
・その他、Webで情報を探しても、同じ症状でも解決できないことが多い

trusty→xenial で解決したことがあるので、32bitが原因なのかと考えていました。
ここが原因でないことはわかりましたので、もう少し試行錯誤したいと思います。

アドバイスありがとうございます。

オフライン

 

#4 2017-12-11 19:16:17

rohizuka
メンバ
登録日: 2009-06-25

Re: croutonを使ったインストールで32bit版を指定できますか?

aarch64でインストールされているのでしたら、バイナリパッケージの対応アーキテクチャはarm64です。
ibus-mozcのバイナリパッケージの対応アーキテクチャは、16.04では amd64 armhf i386のみでarm64はありません。
17.10からはarm64も入っています。
https://packages.ubuntu.com/xenial/ibus-mozc
https://packages.ubuntu.com/artful/ibus-mozc

mizai による投稿:

日本語に変更できない
・ibus-mozcがインストールできない
・ubuntu ソフトウェアセンターでインストールするとエラーがでる
・その他、Webで情報を探しても、同じ症状でも解決できないことが多い

trusty→xenial で解決したことがあるので、32bitが原因なのかと考えていました。
ここが原因でないことはわかりましたので、もう少し試行錯誤したいと思います。

”パッケージが存在しないからインストールできない”といったかんじのエラーメッセージがでていませんか?

オフライン

 

#5 2017-12-11 20:33:53

mizai
メンバ
登録日: 2017-12-05

Re: croutonを使ったインストールで32bit版を指定できますか?

アドバイスありがとうございます。

■パッケージが存在しないからインストールできない”といったかんじのエラーメッセージがでていませんか?

多分そのようなメッセージだったと思います。

ただ一度アンインストールしておりまして、再現することができません。
(別の質問でもしているのですが、SDカードにインストールを試みているのですが、SDカードのフォーマットが上手くいかず手こずっています)

いちど17.10以降のバージョンで試してみます。
確認できましたらご報告致します。

オフライン

 

#6 2017-12-11 22:52:24

mizai
メンバ
登録日: 2017-12-05

Re: croutonを使ったインストールで32bit版を指定できますか?

その後、ローカルにXubuntu 17.10をインストールしました。

ibus-mozcはインストールもインストールできました。
ありがとうございます。

ただ、今回もSoftwareが使えませんでした。
(ソフトウェアセンター?のプリインストールの方です)

起動はするのですが、アプリ(ソフトウェア?)が全く表示されずグレーのままです。
一度再起動はしてみたのですが、状況は変わりませんでした。

ただ、本来の質問とは別件となりますので、どうしても改善しない場合は別途質問させて頂きたいと思います。

ご回答ありがとうございました。

オフライン

 

Board footer

Powered by FluxBB