お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2008-05-06 00:09:09

June
メンバ
登録日: 2008-05-02

8.04 音がまったく出ません

まったくの初心者でxpからUbuntuに転向しようとチャレンジしてますがいきなり躓いてます。
8.04をインストールしてみましたがサウンドがまったく出ません。デフォルトのRhythmboxでCDを聞こうとしても、CDは認識されて演奏されていますが音はまったく出ません。ウェブ上の動画も音が出ませんし、ライブラジオなどもダメです。

  サウンドカード: REALTEK ALC880 8−channel(オンボード) で
  
  [システム] [設定] [サウンド] のデバイスにある
  HDA ATI SB(Alsa mixer)
  Realtek ALC880(OSS Mixer)

 などを設定しシステムを再起動させてみましたがまったく音が出ません。色々とググって見ましたが初心者の私ではこれといった対策を見つけることができませんでした。
 どなたか、具体的にどうすればよいか教えてやってください。

オフライン

 

#2 2008-05-06 01:44:23

LinuxBeginner
メンバ
登録日: 2008-02-18

Re: 8.04 音がまったく出ません

私も7.10からアップグレードした際、同様のトラブルがありましたが、
http://haraita9283.blog98.fc2.com/blog-entry-103.html の ”解決法” 以下の実施と、
システム→設定→セッション にある、”自動起動するプログラム”タブの中の
”PluseAudio”のチェックを外したところ、問題が解決しました。
ご参考まで。

オフライン

 

#3 2008-05-06 13:58:50

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

LinuxBeginnerさん、ありがとうございます。しかしながらまったく対処できません。
まずデバイスの情報を確かめると以下のようになります。
----------------------------------------------------------------------------------------------
  cat /proc/asound/devices
    0: [ 0]   : control
    1:        : sequencer
    4: [ 0- 0]: hardware dependent
  16: [ 0- 0]: digital audio playback
  24: [ 0- 0]: digital audio capture
  28: [ 0- 4]: digital audio capture
  33:        : timer
----------------------------------------------------------------------------------------------
  aplay -l
  **** ハードウェアデバイス PLAYBACK のリスト ****
  カード 0: SB [HDA ATI SB], デバイス 0: ALC880 Analog [ALC880 Analog]
    サブデバイス: 1/1
    サブデバイス #0: subdevice #0
----------------------------------------------------------------------------------------------
私のサウンドカードは REALTEK ALC880 なのですが、aplay -lの結果を見るとカードの認識が間違っているように思うのですがこれでよいのでしょうか?
また、”PluseAudio”のチェックを外してみて再起動してみても変化はありませんでした。
いろいろとサイトを検索しながら格闘していますが今のところまったくダメです。

オフライン

 

#4 2008-05-07 12:39:56

HoneSONG
メンバ
From: Shizuoka, Japan
登録日: 2008-04-30

Re: 8.04 音がまったく出ません

こんにちは。

June による投稿:

サウンドカード: REALTEK ALC880 8−channel(オンボード) 

以下のトピックが参考になるかもしれません。端末からalsamixerを実行して、音量を最大にできる項目はすべて最大にしてみるとか…音が極端に小さくなっているという可能性もありますから。
http://forum.ubuntulinux.jp/viewtopic.php?pid=8345
http://memo.officebrook.net/20080328.html
http://linux.iuplog.com/default.asp?item=94639

オフライン

 

#5 2008-05-07 18:16:41

LinuxBeginner
メンバ
登録日: 2008-02-18

Re: 8.04 音がまったく出ません

お役に立てなかったようで、失礼しました。

ところで、音はUSB接続の外部スピーカーで鳴らしているのでしょうか?
もしそうであれば、通常のミニジャック出力を使えば、音が出る場合もあるようですね。
http://www.technorati.jp/blogs/hautciel.blog.shinobi.jp

あと、やはりPulseAudioがらみでいろいろあるようです。
もしかしたら参考になるかもしれませんので、一応いくつかURLを載せておきます。
http://fun.poosan.net/sawa/index.php?UID=1209314329
http://d.hatena.ne.jp/lch/20080506

Alisa mixerにも癖があるようです。
http://www.igune.com/archives/270

alsaのドライバーの設定とか。
http://od.kururu.info/?p=30


参考になればよいのですが。

オフライン

 

#6 2008-05-07 19:26:21

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

HoneSONGさん、情報提供ありがとうございます。
一通り試してみましたが、

  http://forum.ubuntulinux.jp/viewtopic.php?pid=8345 の
  Realtek HD Audio driver をインストールしてみましたが、
   --------------------------------------------------------------------------------------------------------
   configure: error: Sufficiently new version of libasound not found.
   make: *** ターゲットが指定されておらず, makefile も見つかりません.  中止.
   make: *** ターゲット `install' を make するルールがありません.  中止.
   ln: creating symbolic link `/dev/sndstat': File exists
   cp: cannot create regular file `/usr/share/sounds/alsa/test.wav': Permission denied
   Remove Folder.....
   --------------------------------------------------------------------------------------------------------
  でインストールできず。
  < Synaptic パッケージマネージャで、linux-backports-modules-2.6.22-14-rt をインストールしました。 >
  をやってみましたが何も変わらず。他のサイトもやってみましたがダメでした。

LinuxBeginnerさん、再度の情報提供ありがとうございます。これからチャレンジしてみます。

皆さんからアドバイスをいただくのですが、なにしろLinux初心者のためなにをどうすれば・・・状態です。一つ一つ勉強しながら取り組みますのでよろしくお願いします。


  

オフライン

 

#7 2008-05-09 01:59:32

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

LinuxBeginnerさん、一通りチェックしてみましたがだめでした。海外のサイトも検索し翻訳しながら試して見ましたが、私ごときではどうにもなりませんでした。色々とやってるうちにシステムは不安定になるわ、フリーズするわ、起動不能になるはで、その度に再インストールしてやりましたがもう疲れました。またLinuxから遠のきそうです。(Ubuntuならと思ったのですが・・・)
 閲覧数を見ると同様の症状の方が多くいると思われますので、上級者の方で解決できそうな方は是非とも詳細な情報を提供してやってください。お願いします。

オフライン

 

#8 2008-05-09 10:55:20

LinuxBeginner
メンバ
登録日: 2008-02-18

Re: 8.04 音がまったく出ません

REALTEK ALC880は手こずっている方が多いようですね。

Googleのキャッシュにこんなものがありました。
http://72.14.235.104/search?q=cache:oia4UY8_eRIJ:pc11.2ch.net/test/read.cgi/linux/1183177389/742-793+ubuntu+REALTEK%E3%80%80ALC880%E3%80%808%E2%88%92channel&hl=ja&ct=clnk&cd=3&gl=jp&lr=lang_ja
750 :login:Penguin:2007/08/18(土) 22:56:24 ID:eyI7WSei
    >>748
    音量コントロール開いても、ヘッドホン用のボリュームは表示されないんで困っています。
    サウンドカードはRealtek ALC880というのが載っているみたいです。

759 :login:Penguin:2007/08/19(日) 07:35:07 ID:FlJIAniq
    750です

    音量コントロールのRealtek ALC880(OSS mixer)には、表示するトラックの選択として
    Volume
    Line-in
    Microphone
    CD
    In-gain
    Digital-1
    しかありません。

    HDA Intel (Alsamixer)の方は、
    PCM
    Front
    Surround
    Center
    LFE
    Line-in
    CD
    Microphone
    IEC958
    Capture
    Capture1
    Capture2
    Channel Mode
    Input Source
    Input Source
    Input Source
    しかないんです。

765 :login:Penguin:2007/08/20(月) 23:11:06 ID:ehS/Dm2t
    >>759
    おれはsuseとubuntuとwindowsのマルチブートにしてるが、
    suse10.0がまさにその状態で、イヤホンだめでスピーカはOKだった(10.2にしたら直った)
    ubuntu7.04とwin2000はイヤホンもスピーカもおk

    ライブラリが足りないんだよ、きっと。
    alsa関連かたっぱしから入れてみたら?


と言うことで、ライブラリを片っ端から追加、と言う手もあるようです。

オフライン

 

#9 2008-05-09 11:17:18

hito
管理者
登録日: 2007-03-18

Re: 8.04 音がまったく出ません

ALC880はチップのリビジョンやらサウスブリッジやらによって挙動が違うのですが、
マザーボード名を教えて頂けますか?

正式な型番と購入時期がわかるとうれしいです。

オフライン

 

#10 2008-05-09 15:31:11

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

hito による投稿:

ALC880はチップのリビジョンやらサウスブリッジやらによって挙動が違うのですが、
マザーボード名を教えて頂けますか?

正式な型番と購入時期がわかるとうれしいです。

M/B型番 : ASUSTek P5RD2-TVM
購入時期 : 2006/10

他に情報が必要でしたら提供します。すみませんがよろしくお願いします。

最後の編集者: June (2008-05-09 15:32:14)

オフライン

 

#11 2008-05-09 17:10:08

hito
管理者
登録日: 2007-03-18

Re: 8.04 音がまったく出ません

す……すいません、マザーボードがマイナーすぎて詳細なデバイス情報がどこにも
転がっていませんでしたorz

sudo lspciの結果を貼り付けて頂けると、何かわかるかもしれません。

# あと、この種の複数チャネル出力を持つサウンドカードで起こることがあるのが、
# 「LINE出力から出るべき音声がなぜかマイク入力(とか)から出ている」
# などということもあります。もし試しておられなければ、ほかのジャックにさして
# みてください。

オフライン

 

#12 2008-05-09 17:51:19

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

>す……すいません、マザーボードがマイナーすぎて詳細なデバイス情報がどこにも
>転がっていませんでしたorz

・・; たしかに某有名PCshop製ではあるが、有名メーカー製ではない。

>sudo lspciの結果を貼り付けて頂けると、何かわかるかもしれません。

コード:

sudo lspci

00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:11.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 81)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200]
02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

あと、ジャックに関しては以前に試しましたがどれも反応無しでした。
Windows xpではサウンドを再生していない状態では微かなノイズが聞こえますが、Ubuntuではまったく無音です。

何か分かりましたらアドバイスお願いします。

最後の編集者: June (2008-05-09 17:55:50)

オフライン

 

#13 2008-05-11 00:09:56

Sizuya
新しいメンバ
登録日: 2008-05-10

Re: 8.04 音がまったく出ません

こんばんわ。
僕もUbuntuを入れてから音が出ずに悩みました。

半日がかりで問題解決に当たってたときに次の報告がフォーラムの中にあるのを見つけたので実行してみました。
http://forum.ubuntulinux.jp/viewtopic.php?id=87

結果、音が出るようになりました。
参考になればとおもい、書き込みさせていただきます。

追記:
3.[音量コントローラ]に[スイッチ]タブが出現するので、そこで、External Amplifierのチェックを外す。
とありますが、最初もし、External Amplifier以外のものが表示されている場合、
何度かそのチェックをクリックすると画面が更新されてExternalAmplifierが表示されるようになります。

オフライン

 

#14 2008-05-11 01:30:51

HoneSONG
メンバ
From: Shizuoka, Japan
登録日: 2008-04-30

Re: 8.04 音がまったく出ません

遅レスになりましたが。

June による投稿:

configure: error: Sufficiently new version of libasound not found.
   make: *** ターゲットが指定されておらず, makefile も見つかりません.  中止.
   make: *** ターゲット `install' を make するルールがありません.  中止.
   ln: creating symbolic link `/dev/sndstat': File exists
   cp: cannot create regular file `/usr/share/sounds/alsa/test.wav': Permission denied
   Remove Folder.....
   --------------------------------------------------------------------------------------------------------
  でインストールできず。

これはlibasoundをビルドするためのパッケージが足りてないと思います。Ubuntuは、初期状態では開発環境はほとんどと言っていいほど整っていないので、

sudo apt-get build-dep libasound

を端末から実行した後、ビルドしてみてください。

オフライン

 

#15 2008-05-11 05:01:42

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

皆様、情報ありがとうございます。

Sizuya による投稿:

半日がかりで問題解決に当たってたときに次の報告がフォーラムの中にあるのを見つけたので実行してみました。
http://forum.ubuntulinux.jp/viewtopic.php?id=87

結果、音が出るようになりました。
参考になればとおもい、書き込みさせていただきます。

追記:
3.[音量コントローラ]に[スイッチ]タブが出現するので、そこで、External Amplifierのチェックを外す。
とありますが、最初もし、External Amplifier以外のものが表示されている場合、
何度かそのチェックをクリックすると画面が更新されてExternalAmplifierが表示されるようになります。

これは既に確認済みで、私のシステムの[音量コントローラ]-[編集]-[設定]には External Amplifier なるものがどこに見当たりませんでした。


HoneSONG による投稿:

これはlibasoundをビルドするためのパッケージが足りてないと思います。Ubuntuは、初期状態では開発環境はほとんどと言っていいほど整っていないので、

    sudo apt-get build-dep libasound

を端末から実行した後、ビルドしてみてください。

実行結果:

コード:

sudo apt-get build-dep libasound
E: ロック /var/lib/dpkg/lock が取得できませんでした - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

この様に表示されgetできませんでした。
私のシステムには libasound2 なるものが既に存在しますがいかがなものでしょうか?

オフライン

 

#16 2008-05-11 07:10:12

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

すみません。自己訂正です。

June による投稿:

この様に表示されgetできませんでした。
私のシステムには libasound2 なるものが既に存在しますがいかがなものでしょうか?

これは、Synapticパッケージマネージャを起動中に sudo apt-get build-dep libasound を実行したためと分かりました。その後もう一度 sudo apt-get build-dep libasound を実行したところ以下のようになりました。

コード:

 alsaconf: not found
zen@zen-desktop:~/ドキュメント/realtek-linux-audiopack-5.01$ sudo apt-get build-dep libasound
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
E: libasound のソースパッケージが見つかりません

その後、試しに以下を実行しました。

コード:

 sudo apt-get build-dep libasound2
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
以下のパッケージが新たにインストールされます:
  autotools-dev build-essential debhelper diffstat doxygen dpkg-dev
  gcc-4.2-multilib gcc-multilib gettext html2text intltool-debian lib64gcc1
  lib64gomp1 libc6-amd64 libc6-dev-amd64 libtimedate-perl patch po-debconf
  python2.4 python2.4-dev python2.4-minimal quilt
アップグレード: 0 個、新規インストール: 22 個、削除: 0 個、保留: 0 個。
16.7MB のアーカイブを取得する必要があります。
この操作後に追加で 54.1MB のディスク容量が消費されます。
続行しますか [Y/n]? y

そして、http://www.realtek.com.tw/downloads/dow … Down=falseから reaktek-linux-audiopack-5.01.tar.bz2 をダウンロードし ./install したところ、

コード:

・・・
・・・
##ここから、途中で確認できたエラーメッセージ。
mkdir: ディレクトリ `/usr/include/alsa' を作成できません: Permission denied
make[3]: *** [install-alsasoundincludeHEADERS] エラー 1
make[3]: ディレクトリ `/home/zen/ドキュメント/realtek-linux-audiopack-5.01/alsa-lib-1.0.15/include/sound' から出ます
make[2]: *** [install-am] エラー 2
make[2]: ディレクトリ `/home/zen/ドキュメント/realtek-linux-audiopack-5.01/alsa-lib-1.0.15/include/sound' から出ます
make[1]: *** [install-recursive] エラー 1
make[1]: ディレクトリ `/home/zen/ドキュメント/realtek-linux-audiopack-5.01/alsa-lib-1.0.15/include' から出ます
make: *** [install-recursive] エラー 1
##ここまで、途中で確認できたエラーメッセージ。
・・・
・・・
##以下、最後のエラーメッセージ。
configure: error: Sufficiently new version of libasound not found.
make: *** ターゲットが指定されておらず, makefile も見つかりません.  中止.
make: *** ターゲット `install' を make するルールがありません.  中止.
cp: cannot create link `/usr/lib64/libasound.so.2': Permission denied
cp: cannot create link `/usr/lib64/libasound.so.2.0.0': Permission denied
cp: cannot stat `/usr/lib/pkgconfig/alsa.pc': No such file or directory
ln: creating symbolic link `/dev/sndstat': File exists
cp: cannot create regular file `/usr/share/sounds/alsa/test.wav': Permission denied
Remove Folder.....
./install: 101: alsaconf: not found

となりました。

Permission denied(許されない許可) → なぜ許されないんだ!!
Sufficiently new version of libasound not found(あたらいいバージョンのlibasoundが
みつからない) → 新しいバージョンは libasound2 じゃないのか!!

わたしはLinux初心者のため上記の意味するところが理解できません。orz


すみません。訂正追記です。

Permission denied で思い当たり ./install を sudo ./install としたところすこしかわりました。

コード:

・・・
・・・
##最後のエラーメッセージ
configure: error: this packages requires a curses library
make: *** ターゲットが指定されておらず, makefile も見つかりません.  中止.
make: *** ターゲット `install' を make するルールがありません.  中止.
Remove Folder.....
./install: 101: alsaconf: not found

途中にもエラーが出てましたが分かりません。(インストール中のlogファイルの作成方法が分からない)

長々と醜い投稿になってしまってすみません。

最後の編集者: June (2008-05-11 07:33:27)

オフライン

 

#17 2008-05-11 11:39:31

HoneSONG
メンバ
From: Shizuoka, Japan
登録日: 2008-04-30

Re: 8.04 音がまったく出ません

June による投稿:

libasound2

す、すいません。alsaドライバをconfigureしてインストールしているものだと思って見当違いなアドバイスをしてました ^^;
RealtekのHPから落とせるドライバをインストールしようとしているのですね。

June による投稿:

コード:

・・・
・・・
##最後のエラーメッセージ
configure: error: this packages requires a curses library

エラーメッセージを見ると、curses libraryがこのパッケージには必要だが見つからないぞと言われています。

オフィシャルのフォーラムでも同じような報告がありまして、
http://ubuntuforums.org/showthread.php?t=753318
この人はその後cursesとdevという名前が付くパッケージをかたっぱしから入れて、インストールには成功したようですが、再起動後ボリュームアイコンをクリックするとエラーが出てしまうようになったようです (対処法のレスが付いてますが、それに対しての返事が無いのでどうなったのかは不明)。
ALC 880は一癖も二癖もありそうですね…。

オフライン

 

#18 2008-05-11 14:25:44

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

HoneSONG様、皆様、ありがとうございます。音が出るようになりました!!

HoneSONG による投稿:

オフィシャルのフォーラムでも同じような報告がありまして、
http://ubuntuforums.org/showthread.php?t=753318
この人はその後cursesとdevという名前が付くパッケージをかたっぱしから入れて、インストールには成功したようですが、再起動後ボリュームアイコンをクリックするとエラーが出てしまうようになったようです (対処法のレスが付いてますが、それに対しての返事が無いのでどうなったのかは不明)。
ALC 880は一癖も二癖もありそうですね…。

上記のリンクをたどっていきついた
http://ubuntuforums.org/showthread.php?t=616845
の方法を試したところヘッドホン、スピーカーからしっかりと再生されています。(ハードの機能が100%使えているかはまだ不明です)

ただ、現状では再起動したところノーマルモードでは起動できなくなっていますのでリカバリーモードでの検証結果です。Ubunntu8.04をインストールした直後のデフォルトの状態で上記の対策が有効かどうかは分かりませんので、これから再インストールして最初からやってみたいと思います。
遅くなるかもしれませんが詳細は後ほど結果報告します。

オフライン

 

#19 2008-05-11 19:37:37

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

取り合えず音は出るようになったのでまとめます。
PC環境  M/B : ASUSTek P5RD2-TVM
  sound card : REALTEK ALC880 8−channel(オンボード)

1. インストール : Ubuntu 8.04 日本語ローカライズド Desktop CD
2. 再起動
3. 最新の状態にアップデート : 再起動後に画面右上のパネルにアップデートのアイコンが表示されるのでクリックしてアップデート
4. グラフィックドライバーのインストール
5. 再起動

ここから重要 参考サイト : ubuntu forums(英語)
何をするかというと、/etc/modprobe.d/alsa-base のファイルに options snd-hda-intel model=3stack を書き加えましょう。ということらしい・・・^^;
3stackの部分はそれぞれのカードによって変わるので以下の手順で確認する。

6. デバイスカードの確認
----------------------------------------------------------------------------------
cat /proc/asound/card0/codec#* | grep Codec  !!端末から実行
Codec: Realtek ALC880                 !!ALC880を確認
----------------------------------------------------------------------------------
もしくは、
----------------------------------------------------------------------------------
aplay -l
**** ハードウェアデバイス PLAYBACK のリスト ****
カード 0: SB [HDA ATI SB], デバイス 0: ALC880 Analog [ALC880 Analog]
  サブデバイス: 0/1
  サブデバイス #0: subdevice #0
----------------------------------------------------------------------------------

7.上記リンクページから 6.で確認した自分のカードのところを探す。
----------------------------------------------------------------------------------
・・・
・・・
Model name Description
---------- -----------
ALC880
3stack 3-jack in back and a headphone out
3stack-digout 3-jack in back, a HP out and a SPDIF out
5stack 5-jack in back, 2-jack in front
5stack-digout 5-jack in back, 2-jack in front, a SPDIF out
6stack 6-jack in back, 2-jack in front         !!私の場合はこれ、6stackを確認
6stack-digout 6-jack with a SPDIF out
・・・
・・・
----------------------------------------------------------------------------------
6stackが重要

7. 次に、/etc/modprobe.d/alsa-base を変更
----------------------------------------------------------------------------------
sudo gedit /etc/modprobe.d/alsa-base           !!端末から実行
・・・
・・・
# Prevent abnormal drivers from grabbing index 0   !!ファイルの最後から二番目にある項目
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
options snd-hda-intel model=6stack             !!ここに新たに書き加えた
# Ubuntu #62691, enable MPU for snd-cmipci
----------------------------------------------------------------------------------

8. 保存してPCを再起動する。
以上で音は鳴るようになっているはずです。(私の場合はこれでOkでした)
ヘッドフォン、スピーカーがつながっていることを確認し、[アプリケーション][サウンドとビデオ][Rhythbox]を起動してCDを再生してみる。
[システム][設定][サウンド]のデバイスタグの音量の再生でテストボタンをクリックして確認。以前は無音だったが正常に再生されている。
これでダメだったらこのセクションでは解決できないと思われます。

ただデフォルトの設定では出力されていない端子があったので以下の手順で設定した。
9. 画面右上の音量コントロールのアイコンを右クリックし音量調節ツールを開くを選択。
ファイル→デバイスの選択でデバイスを確認(私はの場合は HDA ATI SB(Alsa mixer))。
次に、編集→設定をクリックし表示するトラックの選択で、Front、Surround、Center、Sideにチェックを入れると音量コントロールのウインドウにリアルタイムでそれぞれのトラックが表示される。トラックの下の赤×印はサウンドがoffの状態なので、クリックしてonにすれば各端子から出力されるようになった。
ちなみに、私のサウンドカードとトラックの対応は下の通りだった。

    トラック        PCの端子
      Front → headphone or speaker
Surround → rear speaker
    Center → center/subwoofer
       Side   → side speaker

*尚、マイクなどの出力端子に関しては確認してません。マイク持ってないから・・・

以上で、8.04 音がまったく出ませんは私Juneに限っては取り合えず解決することができました。同じような症例の方は今までの投稿を参考に、また、まったく違う症例の方は新たな投稿により必ず解決の方法が見つかると思います。(致命的なバグでなければ)

LinuxBeginner、HoneSONG、hito、Sizuyaの皆さんありがとうございました。とくに HoneSONGさんの情報で解決に至ったことについては深く感謝してます。

追記:しかし、たった一行のことで2週間も悩み苦労したとは・・・orz

オフライン

 

#20 2008-05-11 22:00:40

HoneSONG
メンバ
From: Shizuoka, Japan
登録日: 2008-04-30

Re: 8.04 音がまったく出ません

約二週間の格闘、お疲れ様でした:cool:
それと、詳細な事後レポートありがとうございます。きっと、この先この情報で助けられる人が何人もいると思います。

Windowsからの乗り換えではまったく勝手が違って最初は大変でしょうが (事実、私も7.04時代に乗り換えたうちの一人です。最初は何度も浮気しました…:P) 、Ubuntuには素晴らしいフォーラムがあります。他のディストリビューションにもそれぞれの魅力があります。長い目で愛してあげてください。

最後の編集者: HoneSONG (2008-05-11 22:02:09)

オフライン

 

#21 2008-07-14 22:22:08

Grooki
新しいメンバ
登録日: 2008-07-14

Re: 8.04 音がまったく出ません

こんにちは、初めて投稿いたします、Grookiと申します。

私も先日、Ubuntuをインストールし、最初の試練として「音がまったく鳴らない」問題に
直面したばかりでした。まったくの素人ですが、フォーラムの記事で大変勉強させていただいております。

ので、もしも誰かの問題解決の助けになるならば幸せだと思い、私のケースでの問題解決過程を
貼り付けておきたいと思いました。

当方のPC環境は、SOTECのノートPC、「Winbook WA354B」…10万円未満の安パソコンです。
XPとUbuntu8.04のデュアルブートです。本家版CDをインストール後、日本語チームの
レポジトリ等を追加しました。Anthyも同様に後付けです。

サウンドデバイスはコマンド検索で以下のとおり。

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SI7012 [SiS SI7012], device 0: Intel ICH [SiS SI7012]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

私のPCの場合、#2の記事の方法も試したのですがダメでしたので、
「アプリケーションの追加と削除」および「Synaptic パッケージマネージャ」で、
「PulseAudio」関連のアプリ等を検索し、片っ端からアンインストールしたところ、
再起動を待たずに音が出るようになりました。

ただ、複数のアプリで音を重ねて出すことはできません。
私の作業環境の場合、そうした使い方はほとんどしていないので、
この点はとくにストレスとはなっていません。

サウンドドライバはALSA Mixerです
(Volume Control→ファイル→デバイスの変更→0: に表示されているデバイス)。
「システム」→「設定」→「サウンド」→も、初期設定のまま変えていません。

「編集」→「設定(preference)」では、
Headphone Jack sense , Line Jack sense ,External Amplifier のチェックははずしています。
「Option」での「Surround Jack Mode」では、「Independent」を選択しています。
音量の調節は、私のPCでの場合、「Master Surround」と「PCM」で調節するようです。
「Master」を上下しても音量に変化ありませんでした。この辺は、音が出さえすれば
愛嬌として許せる範囲でしょうか(笑

この辺は、CDを鳴らしながら、一個一個チェックを外したりつけたりして手探りで調節
していきました。

長々書きましたが、PulseAudioを完全にアンインストールするという手段が
私の場合有効でした。おすすめできる方法かは分かりませんが、
少しでも同じ問題を抱えた誰かの助けになるならば幸いです。

オフライン

 

#22 2008-07-17 16:01:22

honma
メンバ
登録日: 2008-06-09

Re: 8.04 音がまったく出ません

私のノートPCは音がチャント出てますが肝心のもう一台のDESKTOPが音が出ません。
今日ALSAのページでやっと該当する対策を見つけましたが他のページにALSAそのものが
アップデートされていました。今度は多くのサウンドカードに対応するらしい。近いうちにUbuntu様のALSAのアップデートがあるだろうから期待してそれまで待つ事にしました。
そのページのURL : http://bugtrack.alsa-project.org/main/index.php/Main_Page
------------------------------------------------------
とは思いましたが新たにALSAがサポートするサウンドカード表を見たら自分のもの(Intel 82801BA-ICH2)はサポート外だった。またその対策なるものはかなり前のドライバー等ををインストール方法であり次のUbuntu9.xxまで待つか新しいバージョンのドライバーをインストールかも考えましたが自分のサウンドカードがサポートされる可能性は残念ながら低いと判断しました。
そこであるブログでSound BlasterがLinuxで簡単に認識され音が出たと言う記事があり発売元のCreaitiveの商品を調べたら新しくUSBタイプのSound Blaster Play!なるものがAmazon等で2000円ちょっとで発売されていた。
賭けとは思いましたが早速購入しドライバー等インストールしテストする。しかし,このUSB audioが0の位置にないので端末でsudo gedit /etc/modprobe.d/alsa-baseのコマンドを打ち記入されているoptions snd-usb-audio index=-2の所index=0
に変更し保存し再起動してyoutubeを見るとなんとUSBheadphoneから見事に音が出ました。
ついでに今回WindowsとUbuntuとの音の相違点を調べる?ためとUbuntuではカーソルがふらついて疲れるので
試験的にWindowsにVMwareを入れて見たら起動の遅いのは仕方ないがなによりカーソルがふらつくことはなくなり助かりました。そして意外!Sound BlasterとAlsaも使わずに本体から音が出ました。もっと早くVMwareを使って見るべきたった。これで一ヶ月以上も悩まされた音の問題もお蔭様で解決しました。ここの先輩諸氏の記事は勉強になり大変有難うございました。

最後の編集者: honma (2008-09-06 20:23:19)

オフライン

 

#23 2008-07-31 18:32:34

syosinnsya
メンバ
登録日: 2008-06-20

Re: 8.04 音がまったく出ません

#19のJuneさんの書き込みに質問です。

7で、自分のサウンドカードを探すのはわかったのですが、「私の場合はこれ、6stackを確認」とあるのですが、なぜそれなのですか?
どういう基準でそれを選んだのですか?

ちなみに私のサウンドボードはRealtek ALC882です。

オフライン

 

#24 2008-08-27 01:35:32

June
メンバ
登録日: 2008-05-02

Re: 8.04 音がまったく出ません

本日、久しぶりにフォーラムにきてみたら質問されてたので既に解決済みかもしれませんが一応回答します。

syosinnsya による投稿:

#19のJuneさんの書き込みに質問です。

7で、自分のサウンドカードを探すのはわかったのですが、「私の場合はこれ、6stackを確認」とあるのですが、なぜそれなのですか?
どういう基準でそれを選んだのですか?

自分のPCのサウンドカードを見たところ、I/O Portが背面に6jack、前面に2jackあったので、それに適合しているが6stackであったということです。


私ごとですが、WindowsXPからUbuntuに完全移行したいと思ってトライしていましたが、どうしてもできないことがあってしばらくUbuntuから離れています。

オフライン

 

#25 2008-08-30 01:14:59

syosinnsya
メンバ
登録日: 2008-06-20

Re: 8.04 音がまったく出ません

おかげで音が出るようになりました。

解答ありがとうございます。

オフライン

 

Board footer

Powered by FluxBB