お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2018-03-28 12:46:53

koinaka11
新しいメンバ
登録日: 2018-03-28

HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

・Ubuntuの【バージョン】
Ubuntu 16.04 LTS

・あなたが使っているPCの【ハードウェア的な情報】
HP Pavilion 500-305jp  Windows 8.1 Update
CPU AMD A10-6700 APU 3.7GHz
グラフィックス radeon hd 8670d
チップセット AMD A78 FCH
メモリ4GB  500GB HDD

・その状態に至るまでの操作
LinuxLive USB Creatorを使って項目などはデフォルト設定のままUbuntu 16.04 LTSのLive USBを作成しました。
USBは 8GB BUFFALO USB FLASH DISKです。

その後パソコンを再起動し、F10を押したままBIOSの設定欄で起動順序を変更。
上から、
UEFI ブート ソース
USBハードディスクドライブ
UEFI: IPv4 Realtek PCIe GBE Family Contoroller
UEFI: IPv6 Realtek PCIe GBE Family Contoroller
USB ディスケット/CD
Windows Boot Manager (最初にLINUXを試した時点ではありましたが、現在削除済で代わりにUbuntsuとあります。)

レガシー ブート ソース ; 無効

「Try Ubuntsu without installing」で起動
Firefoxなど入っていたソフトなどを一通り試して左上の「Ubuntsu 16.04 LTSのインストール」を実行。

下記2項目にチェックを入れました。
「Ubuntsuのインストール中にアップデートをダウンロードする」
「グラフィックス、wifi機器、Flash,MP3やその他のメディアに必要なサードパーティソフトウェアをインストールする」

「ディスクを削除してUbuntsuをインストール」を選択

インストールが完了し、「いますぐ再起動する」

すると下記の画面になりました。

「Checking media presence
Media present
Start PXE over IPv4」

その後下記の表示が出ました。
「起動デバイスが見つかりません。
ハードディスクにオペレーティングシステムをインストールしてください。
ハードディスク-(3FO)
F2 システム診断
詳しくは、http;//www.hp.com/go/techcenter/startupを参照してください。」

起動ができないので調べていたところBoot Repairというものあると知り、Ubuntu ソフトウェアセンターで探しましたが見つかりませんでした。
PPAの追加をしようとしましたが「Y PPA Manager」というのも見つかりませんでした。

Live USBでの使用時にとても軽かったので主に用途はサブ機としてのネット閲覧を考えております。

インストールも3度試しましたが起動できず、Zorin OSというものを試しましたがインストールはされたようでしたが同じく起動はできませんでした。

何かアドバイスなど頂けましたら幸いです。
宜しくお願い致します。

オフライン

 

#2 2018-03-29 06:23:05

aaabbbcccdddeeefffggghhh
メンバ
登録日: 2008-02-25

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

koinaka11 による投稿:

「Checking media presence
Media present
Start PXE over IPv4」

その画面はブートローダーの優先順位に問題がある場合に表示されるようです。
BIOSの設定を見直してみてください。

Windows起動時に「Checking Media Presence、Start PXE over IP4」が表示される場合の解決法【BIOS設定でブートローダー優先順位を変更】
https://www.iyamaittane.com/entry/start-ip4/

オフライン

 

#3 2018-03-29 09:56:47

koinaka11
新しいメンバ
登録日: 2018-03-28

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

お返事ありがとうございます。

早速BIOSの設定で起動順序を上から

「ubuntsu
USBハードディスクドライブ
USB ディスケット/CD
UEFI: IPv4 Realtek PCIe GBE Family Contoroller
UEFI: IPv6 Realtek PCIe GBE Family Contoroller」

に変更し変更を保存して終了をしましたが、やはり

「>> Checking Media Presence......
>> Media Present......
>> Start PXE over IPv4.」

と表示されてしまいました。
再度BIOSに入るとubuntsuを一番上にして保存したはずが

「USBハードディスクドライブ
USB ディスケット/CD
UEFI: IPv4 Realtek PCIe GBE Family Contoroller
UEFI: IPv6 Realtek PCIe GBE Family Contoroller
ubuntsu」

となっており、一番下に来てしまいます。
何度か試すも一番下に来てしまうため、再度ubuntsuを一番上にして、左上タブの「ファイル」→「デフォルト値の変更」→「現在の設定をデフォルトとして保存」をやってみましたが同じ結果でした。

USBを差してのubunstuの起動はできるようです。

「起動順序」の一番下にレガシーブートソースというのがあるのですが、これは関係ないでしょうか?
現在は無効になっております。

オフライン

 

#4 2018-03-29 22:04:23

tosri
メンバ
登録日: 2015-04-30

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

koinaka11様

koinaka11 による投稿:

「USBハードディスクドライブ
USB ディスケット/CD
UEFI: IPv4 Realtek PCIe GBE Family Contoroller
UEFI: IPv6 Realtek PCIe GBE Family Contoroller
ubuntsu」

となっており、一番下に来てしまいます。
何度か試すも一番下に来てしまうため、再度ubuntsuを一番上にして、左上タブの「ファイル」→「デフォルト値の変更」→「現在の設定をデフォルトとして保存」をやってみましたが同じ結果でした。

USBを差してのubunstuの起動はできるようです。

Bootできない問題はubuntsuの優先順位が「UEFI: IPv4 Realtek PCIe GBE Family Contoroller
UEFI: IPv6 Realtek PCIe GBE Family Contoroller」の上にないのが問題です。usbのUbuntuができるのは「UEFI: IPv4 Realtek PCIe GBE Family Contoroller
UEFI: IPv6 Realtek PCIe GBE Family Contoroller」の上にあるからです。
ubuntuを上位に持ってきて保存しても保存が効かないのはハードの問題だと思います。それなら
「UEFI: IPv4 Realtek PCIe GBE Family Contoroller
UEFI: IPv6 Realtek PCIe GBE Family Contoroller」を無効にすれば良いと思います。
参考URlは
http://s.webry.info/sp/wxw.at.webry.info/201710/article_2.html
ハードウエアのBIOS設定はいろいろ問題が起こる可能性がありますので購入した時の説明書等を参考にご自身の責任でお願いいたします。

オフライン

 

#5 2018-03-30 14:44:08

koinaka11
新しいメンバ
登録日: 2018-03-28

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

お返事ありがとうございます。

早速いただいたアドバイスを参考に

ubuntsu」
USBハードディスクドライブ
USB ディスケット/CD
UEFI: IPv4 Realtek PCIe GBE Family Contoroller : 無効
UEFI: IPv6 Realtek PCIe GBE Family Contoroller : 無効

として起動してみたのですが、

>> Checking Media Presence......
>> Media Present......
>> Start PXE over IPv4.

の表示が出ずに、

起動デバイスが見つかりません。
ハードディスクにオペレーティングシステムをインストールしてください。
ハードディスク-(3FO)
F2 システム診断
詳しくは、http;//www.hp.com/go/techcenter/startupを参照してください。

となりました。そこで

ubuntsu」
USBハードディスクドライブ : 無効
USB ディスケット/CD : 無効
UEFI: IPv4 Realtek PCIe GBE Family Contoroller : 無効
UEFI: IPv6 Realtek PCIe GBE Family Contoroller : 無効

とubuntsuのみで保存して起動しましたが結果は同じでした。気になるのは起動順序でubuntsuを一番上で保存するも、毎度一番下になってしまっていることです。
Zorin OSでも同じように試したのですが、一緒の現象でした。
ハードディスクのチェックもしましたが合格となっているのでHDDは壊れていないと思うのですが。

起動デバイスが見つかりませんとの表示なのですが、通常であればubuntsuというもの以外にubuntsuのブートマネージャーのようなものがあるのでしょうか?

オフライン

 

#6 2018-03-30 15:50:14

tosri
メンバ
登録日: 2015-04-30

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

koinaka11 による投稿:

ubuntsu」
USBハードディスクドライブ : 無効
USB ディスケット/CD : 無効
UEFI: IPv4 Realtek PCIe GBE Family Contoroller : 無効
UEFI: IPv6 Realtek PCIe GBE Family Contoroller : 無効

とubuntsuのみで保存して起動しましたが結果は同じでした。気になるのは起動順序でubuntsuを一番上で保存するも、毎度一番下になってしまっていることです。
Zorin OSでも同じように試したのですが、一緒の現象でした。
ハードディスクのチェックもしましたが合格となっているのでHDDは壊れていないと思うのですが。

起動デバイスが見つかりませんとの表示なのですが、通常であればubuntsuというもの以外にubuntsuのブートマネージャーのようなものがあるのでしょうか?

「起動順序でubuntsuを一番上で保存するも、毎度一番下になってしまっている」のはHDDの問題ではありません。BIOSのFirmwareの問題です。
Bootできないのは多分HDDにEFI Partitionが存在しないからだと思います。UEFIのパソコンなのでEFI Partitionを作成する必要があります。またはレガシーBIOSに変更してやるとうまく行くかもしれません。
EFI Partitionの確認はLive USBのGpartedで見ることができます。
参考URLは
https://wiki.ubuntulinux.jp/UbuntuTips/Install/UEFI
https://kledgeb.blogspot.jp/2016/04/ubuntu-1604-uefi-1-uefipcubuntu-1604.html
https://kledgeb.blogspot.jp/2016/04/ubuntu-1604-uefi-2-uefipcubuntu-1604.html
などを調べてください。
私はレガシーBIOSで使用しております。(UEFIの長所がわからないので)

詳しくはUEFI BIOSを使用してる方からアドヴァイスがあるかもしれません。

オフライン

 

#7 2018-03-31 11:45:09

koinaka11
新しいメンバ
登録日: 2018-03-28

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

お返事ありがとうございます。

頂いた、
https://kledgeb.blogspot.jp/2016/04/ubuntu-1604-uefi-1-uefipcubuntu-1604.html
を参考にGParted Partition Editorを起動すると

パーティション  Name                    ファイルシステム   容量          使用済み  空き          フラグ
/dev/sda1   EFI System Partition   fat32              512.00MB   4.43MiB    507.57MiB   boot,esp
/dev/sda2                                 ext4               461.83GiB   12.15GiB   449.68Gib   
/dev/sda3                                 linux-swap       3.43GiB      0.00B       3.43GiB
未割り当て                                                       1.02MiB       ...            ...

表示されEFIパーティションがあるようなのですが、これと別なのでしょうか?

レガシーBIOSで試してみたく調べたのですがレガシー→UEFIへの変更はあるのですが、レガシーへの変更が見つからず、大変恐縮ですがもしお分かりでしたら参考URLなど頂けますでしょうか。

オフライン

 

#8 2018-03-31 13:41:51

tosri
メンバ
登録日: 2015-04-30

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

koinaka11 による投稿:

GParted Partition Editorを起動すると

パーティション  Name                    ファイルシステム   容量          使用済み  空き          フラグ
/dev/sda1   EFI System Partition   fat32              512.00MB   4.43MiB    507.57MiB   boot,esp
/dev/sda2                                 ext4               461.83GiB   12.15GiB   449.68Gib   
/dev/sda3                                 linux-swap       3.43GiB      0.00B       3.43GiB
未割り当て                                                       1.02MiB       ...            ...

表示されEFIパーティションがあるようなのですが、これと別なのでしょうか?

レガシーBIOSで試してみたく調べたのですがレガシー→UEFIへの変更はあるのですが、レガシーへの変更が見つからず、大変恐縮ですがもしお分かりでしたら参考URLなど頂けますでしょうか。

EFIパーティションはそれです。Ubuntu をインストールした時にHDDの先頭にあるBoot loaderが正しくできていないかんじがします。
BIOSはパソコンmother boardにより異なるのでパソコンを購入した時の説明書を調べたほうが速いです。
レガシー→UEFIへの変更を見つけておられるので、その逆をすればそれで変更できないですか。(UEFIを無効にするとか)レガシーBIOSに変更したあと再度Ubuntuをインスールする必要があります。そうすればEFIパーティションはなくなっております。
「ディスクを削除してUbuntsuをインストール」を選択」をする場合はすでにUbuntuやWindowsがインストールされている場合、共存してインストールする選択肢が追加されます。となってるのでUbuntuをインスールする前にGpartedにてHDDのすべてのpartitionを削除したほうが賢明だと思います。
次のURLは参考です。
https://search.yahoo.co.jp/image/search?p=uefi+bios+%E3%83%AC%E3%82%AC%E3%82%B7%E3%83%BC&ei=UTF-8&rkf=1
https://kledgeb.blogspot.jp/2016/04/ubuntu-1604-1-ubuntu-1604ubuntuubuntu.html

オフライン

 

#9 2018-03-31 15:23:24

koinaka11
新しいメンバ
登録日: 2018-03-28

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

お返事ありがとうございます。

その後、再インストールをし、レガシーBIOSを有効でいろいろ変えてやってみたのですが、
WRROE : No boot disk has been detected or the disk has failed.
となり、起動できませんでした。

現状の自分の知識では解決するのは難しいと思われるので、残念ですが、Linuxの使用はあきらめようと思います。

tosri様、aaabbbcccdddeeefffggghhh様、わざわざお時間割いていただきありがとうございました。

オフライン

 

#10 2018-03-31 16:39:42

tosri
メンバ
登録日: 2015-04-30

Re: HDDにインストールしての起動ができません。(起動デバイスが見つかりません)

koinaka11 による投稿:

その後、再インストールをし、レガシーBIOSを有効でいろいろ変えてやってみたのですが、
WRROE : No boot disk has been detected or the disk has failed.
となり、起動できませんでした。

現状の自分の知識では解決するのは難しいと思われるので、残念ですが、Linuxの使用はあきらめようと思います。

tosri様、aaabbbcccdddeeefffggghhh様、わざわざお時間割いていただきありがとうございました。

https://ubuntuforums.org/showthread.php?t=2301474
上記URL英語ですがnetで翻訳すれば大筋は理解できると思います。それによるとSecure boot onになっておりませんか。もしonならSecure boot offにすればbootできるかもしれないです。

オフライン

 

Board footer

Powered by FluxBB