お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2020-05-03 22:28:41

TranslucentFoxHuman
メンバ
登録日: 2020-04-28

GNOME Boxesが動きません。

環境は、Lubuntu 18.04です。
DELL Inspiron-3280-AIO上ににインストールされています。
GNOME Boxesのバージョンは、3.28.1です。

Lubuntu 20.04を試すために、GNOME Boxesをインストールして、予めダウンロード(http://cdimage.ubuntu.com/lubuntu/releases/20.04/release/lubuntu-20.04-desktop-amd64.iso より)しておいたイメージを指定しましたが、起動できませんでした。
仮想化支援が無効なせいかと思い、BIOS設定を確認しましたが、それらしい設定項目は見当たりませんでした。

トラブルシューティングログは以下のとおりです。

コード:

Broker URL: qemu+unix:///session
Domain: boxes-unknown
UUID: 8d2759c5-7192-44bd-b636-33747fb179a9
Persistent: yes
Cpu time: 0
Memory: 2097152 KiB
Max memory: 3885388 KiB
CPUs: 4
State: GVIR_DOMAIN_STATE_SHUTOFF

Domain config:
------------------------------------------------------------
<domain type="kvm">
  <name>boxes-unknown</name>
  <uuid>8d2759c5-7192-44bd-b636-33747fb179a9</uuid>
  <title>lubuntu-20</title>
  <metadata>
    <boxes:gnome-boxes xmlns:boxes="https://wiki.gnome.org/Apps/Boxes">
      <os-state>installed</os-state>
      <media>/home/translucentfoxhuman/ダウンロード/CD_Image/lubuntu-20.04-desktop-amd64.iso</media>
    </boxes:gnome-boxes>
  </metadata>
  <memory unit="KiB">2097152</memory>
  <currentMemory unit="KiB">2097152</currentMemory>
  <vcpu placement="static">4</vcpu>
  <os>
    <type arch="x86_64" machine="pc-i440fx-bionic">hvm</type>
    <boot dev="hd"/>
  </os>
  <features>
    <acpi/>
    <apic/>
  </features>
  <cpu mode="custom" match="exact" check="partial">
    <model fallback="allow">Westmere-IBRS</model>
    <topology sockets="1" cores="2" threads="2"/>
  </cpu>
  <clock offset="utc">
    <timer name="rtc" tickpolicy="catchup"/>
    <timer name="pit" tickpolicy="delay"/>
    <timer name="hpet" present="no"/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <pm>
    <suspend-to-mem enabled="no"/>
    <suspend-to-disk enabled="no"/>
  </pm>
  <devices>
    <emulator>/usr/bin/kvm-spice</emulator>
    <disk type="file" device="disk">
      <driver name="qemu" type="qcow2" cache="writeback"/>
      <source file="/home/translucentfoxhuman/.local/share/gnome-boxes/images/boxes-unknown"/>
      <target dev="hda" bus="ide"/>
      <address type="drive" controller="0" bus="0" target="0" unit="0"/>
    </disk>
    <disk type="file" device="cdrom">
      <driver name="qemu" type="raw"/>
      <source file="/home/translucentfoxhuman/&#x30C0;&#x30A6;&#x30F3;&#x30ED;&#x30FC;&#x30C9;/CD_Image/lubuntu-20.04-desktop-amd64.iso" startupPolicy="optional"/>
      <target dev="hdc" bus="ide"/>
      <readonly/>
      <address type="drive" controller="0" bus="1" target="0" unit="0"/>
    </disk>
    <controller type="usb" index="0" model="ich9-ehci1">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x7"/>
    </controller>
    <controller type="usb" index="0" model="ich9-uhci1">
      <master startport="0"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x0" multifunction="on"/>
    </controller>
    <controller type="usb" index="0" model="ich9-uhci2">
      <master startport="2"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x1"/>
    </controller>
    <controller type="usb" index="0" model="ich9-uhci3">
      <master startport="4"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x2"/>
    </controller>
    <controller type="pci" index="0" model="pci-root"/>
    <controller type="ide" index="0">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x01" function="0x1"/>
    </controller>
    <controller type="virtio-serial" index="0">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x06" function="0x0"/>
    </controller>
    <controller type="ccid" index="0">
      <address type="usb" bus="0" port="2"/>
    </controller>
    <interface type="user">
      <mac address="52:54:00:cc:a4:7d"/>
      <model type="rtl8139"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x03" function="0x0"/>
    </interface>
    <smartcard mode="passthrough" type="spicevmc">
      <address type="ccid" controller="0" slot="0"/>
    </smartcard>
    <serial type="pty">
      <target type="isa-serial" port="0">
        <model name="isa-serial"/>
      </target>
    </serial>
    <console type="pty">
      <target type="serial" port="0"/>
    </console>
    <channel type="spicevmc">
      <target type="virtio" name="com.redhat.spice.0"/>
      <address type="virtio-serial" controller="0" bus="0" port="1"/>
    </channel>
    <channel type="spiceport">
      <source channel="org.spice-space.webdav.0"/>
      <target type="virtio" name="org.spice-space.webdav.0"/>
      <address type="virtio-serial" controller="0" bus="0" port="2"/>
    </channel>
    <input type="tablet" bus="usb">
      <address type="usb" bus="0" port="3"/>
    </input>
    <input type="mouse" bus="usb">
      <address type="usb" bus="0" port="4"/>
    </input>
    <input type="keyboard" bus="usb">
      <address type="usb" bus="0" port="5"/>
    </input>
    <input type="mouse" bus="ps2"/>
    <input type="keyboard" bus="ps2"/>
    <graphics type="spice">
      <listen type="none"/>
      <image compression="off"/>
    </graphics>
    <sound model="ac97">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x04" function="0x0"/>
    </sound>
    <video>
      <model type="qxl" ram="65536" vram="65536" vgamem="16384" heads="1" primary="yes"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x0"/>
    </video>
    <redirdev bus="usb" type="spicevmc">
      <address type="usb" bus="0" port="6"/>
    </redirdev>
    <redirdev bus="usb" type="spicevmc">
      <address type="usb" bus="0" port="1.1"/>
    </redirdev>
    <redirdev bus="usb" type="spicevmc">
      <address type="usb" bus="0" port="1.2"/>
    </redirdev>
    <redirdev bus="usb" type="spicevmc">
      <address type="usb" bus="0" port="1.3"/>
    </redirdev>
    <hub type="usb">
      <address type="usb" bus="0" port="1"/>
    </hub>
    <memballoon model="virtio">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x07" function="0x0"/>
    </memballoon>
  </devices>
</domain>
------------------------------------------------------------

仮想化支援が有効にできないPCでも、仮想マシンを使う方法はありますでしょうか。
確か、このPCで、WindowsでVirtualBoxを使ったときはできたと思います。

GNOME Boxesでできないのならば、何か、GPLライセンスで提供される仮想マシンソフトウェアを教えていただけると幸いです。

オフライン

 

#2 2020-05-05 11:06:58

yutarine
メンバ
登録日: 2011-10-15

Re: GNOME Boxesが動きません。

最近はあまり使っていませんが、以前に少しばかりGNOME Boxesを使っていました。
そのときの経験からすると、GNOME Boxesは作成した仮想マシンを起動するのにやや難がある印象です。
それでも仮想マシンの起動は出来るようにはなったのでそのときの方法について書いておきます。
(あくまで使っていた当時でのことなので、いまでは改善されてるのかも。あと仮想化支援についてはよく分かってないので触れません)
(あと自分の環境はLubuntuではなくUbuntu 18.04なので、そのあたりの違いはあるかも)

自分が試した中でGNOME Boxesでの仮想マシンの起動が成功するようになった方法としては、
・GNOME Boxesを一度終了して再度起動して試す
・GNOME Boxesの設定ファイルを削除する(ホームディレクトリ以下の.config内のgnome-boxesディレクトリ)
・(kvmグループにユーザーを登録する)←この方法はあまり関係ないかも?
・GNOME Boxesをアプリケーションメニューではなく端末から起動する
です。あとうまく行かないときはパソコンの再起動も試すといいかも知れません。
そのあたり自分の以下のブログ記事に雑にまとめてあるので参考までのリンク貼っておきます
https://yutarine.blogspot.com/2018/08/g … 4-lts.html

そういえば試そうとしているLubuntu 20.04だけ起動しないんでしょうか?他のOSやバージョンのイメージファイルファイルでは試されましたか?

オフライン

 

#3 2020-05-05 13:59:49

TranslucentFoxHuman
メンバ
登録日: 2020-04-28

Re: GNOME Boxesが動きません。

ありがとうございます。正常に起動できました。

kvmに登録して、設定ファイルを削除して、システムを再起動後、端末から起動することで起動できました。

手元にFreeDOS、Lubuntu 20.04の2つがあったのですが、どちらも正常です。

本当にありがとうございます。

オフライン

 

Board footer

Powered by FluxBB