お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2021-02-06 00:38:36

bayou
ゲスト

unmet dependenciesエラー 解決できません

こんばんは、いつもお世話になっています。
原因はオーディオソフトのaudaciousの関係のようなのですが、エラーでアップデートできず困っています。
求められるまま --fix-broken install をしても、また --fix-broken install を求められます。
たとえば、下記のような感じです。
お知恵をお貸しいただきたく、よろしくお願いいたします。
ハードウエアはDELLのLatitude E5500 その他、lubuntuのバージョンは20.04です。


*****@*****-E5500:~$ sudo apt dist-upgrade
[sudo] password for *****:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
audacious-plugins : Depends: libaudqt2 (>= 4.1-0build4~ubuntu20.04) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
*****@*****-E5500:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libaudqt5
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libaudqt2
The following NEW packages will be installed:
  libaudqt2
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/125 kB of archives.
After this operation, 499 kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 446534 files and directories currently installed.)
Preparing to unpack .../libaudqt2_4.1-0build4~ubuntu20.04_amd64.deb ...
Unpacking libaudqt2:amd64 (4.1-0build4~ubuntu20.04) ...
dpkg: error processing archive /var/cache/apt/archives/libaudqt2_4.1-0bu
ild4~ubuntu20.04_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/libaudqt.so.2', which is
also in package libaudqt5:amd64 4.0.5-0build1~ubuntu20.04
Errors were encountered while processing:
/var/cache/apt/archives/libaudqt2_4.1-0build4~ubuntu20.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
*****@*****-E5500:~$ sudo apt autoremove libaudqt5
[sudo] password for akira:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
audacious-plugins : Depends: libaudqt2 (>= 4.1-0build4~ubuntu20.04) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
*****@*****-E5500:~$

 

#2 2021-02-06 04:42:03

bayou
ゲスト

Re: unmet dependenciesエラー 解決できません

software updater に下記のメッセージが表示されました。

The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f
Transaction failed: The package system is broken
The following packages have unmet dependencies:

audacious-plugins: Depends: audacious-plugins-data (= 4.1-0build2~ubuntu20.04) but 4.1-0build2~ubuntu20.04 is installed
                   Depends: libaudcore5 (>= 4.1-0build4~ubuntu20.04) but 4.1-0build4~ubuntu20.04 is installed
                   Depends: libaudqt2 (>= 4.1-0build4~ubuntu20.04) but it is not installed
                   Depends: libavcodec58 (>= 7:4.2) but 7:4.2.4-1ubuntu0.1 is installed
                   Depends: libavformat58 (>= 7:4.1) but 7:4.2.4-1ubuntu0.1 is installed
                   Depends: libavutil56 (>= 7:4.0) but 7:4.2.4-1ubuntu0.1 is installed
                   Depends: libcdio-cdda2 (>= 10.2+2.0.0) but 10.2+2.0.0-1 is installed
                   Depends: libcurl3-gnutls (>= 7.16.2) but 7.68.0-1ubuntu2.4 is installed
                   Depends: libmodplug1 (>= 1:0.8.8.5) but 1:0.8.9.0-2build1 is installed
                   Depends: libqt5core5a (>= 5.12.2) but 5.12.8+dfsg-0ubuntu1 is installed
                   Depends: libqt5gui5-gles (>= 5.11.0~rc1) but it is not installed
                   Depends: libqt5widgets5 (>= 5.11.0~rc1) but 5.12.8+dfsg-0ubuntu1 is installed
                   Depends: libstdc++6 (>= 5.2) but 10.2.0-5ubuntu1~20.04 is installed
                   Depends: libwavpack1 (>= 4.40.0) but 5.2.0-1ubuntu0.1 is installed
                   Depends: libxcomposite1 (>= 1:0.4.5) but 1:0.4.5-1 is installed
                   Depends: zlib1g (>= 1:1.1.4) but 1:1.2.11.dfsg-2ubuntu1.2 is installed

 

#3 2021-02-06 05:46:58

bayou
ゲスト

Re: unmet dependenciesエラー 解決できません

片っ端から sudo add-apt-repository --remove ppa:  とやっていきましたら、解決できました。
お騒がせいたしました。

 

Board footer

Powered by FluxBB