お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2008-06-23 13:28:46

tnc
メンバ
登録日: 2008-03-22

OpenOffice.orgで日本語入力が出来ません

OpenOffice.orgを起動して日本語入力を試みたのですが全く受け付けません。
アルファベットでしか入力出来ずに困って降ります。
何か、解決策があれば教えて下さい。
因みに、他のソフトでは全く問題ありません。
以下のサイトで質問したのですがデストリビュージョンに問題があるのではと指摘を受けましたので
どなたかアドバイスを頂けないでしょうか。
http://oooug.jp/faq/index.php?faq/4/1099

開発者サイドとやり取りできればよいのですが英語での表記であるために出来ません。
上記のサイトだとアップデートでインストールされたものはUbuntuの開発バージョンだとのことです。
初心者くずれで誠に恐縮ですがよろしくお願い致します。

オフライン

 

#2 2008-06-23 20:13:34

tnc
メンバ
登録日: 2008-03-22

Re: OpenOffice.orgで日本語入力が出来ません

試しにGnomeで立ち上げたところ日本語入力ができました。
これは、KDEのバグかもしれないですね。
どなたかKDEの修復が出来る方がいらっしゃいましたらレスをお願い致します。

オフライン

 

#3 2008-06-23 21:06:13

koisan1949
メンバ
From: Hyogo, Japan
登録日: 2007-11-11

Re: OpenOffice.orgで日本語入力が出来ません

 tncさん、私の環境は、Fujitsu FMV c-600 P4 2.4GHz, 1Gb
 Ubuntu8.04+KDE3.59+KDE4.0 + ATOK3です。
 また、sotecのUbuntu7.10+KDE+ATOK3でも問題ないです。
 これらの環境で、貴君の症状に遭遇したことがありません。
 KDEのOpenOffice.org2.4で、何ら問題なく日本語で入力できてます。
 そのため、日本語の入力に関しては疑義を生じたことがありません。
 申し訳ないですが、何ら解決策への助言ができません。

最後の編集者: koisan1949 (2008-06-23 21:10:05)

オフライン

 

#4 2008-06-23 22:59:24

tnc
メンバ
登録日: 2008-03-22

Re: OpenOffice.orgで日本語入力が出来ません

koisan1949 による投稿:

 tncさん、私の環境は、Fujitsu FMV c-600 P4 2.4GHz, 1Gb
 Ubuntu8.04+KDE3.59+KDE4.0 + ATOK3です。
 また、sotecのUbuntu7.10+KDE+ATOK3でも問題ないです。
 これらの環境で、貴君の症状に遭遇したことがありません。
 KDEのOpenOffice.org2.4で、何ら問題なく日本語で入力できてます。
 そのため、日本語の入力に関しては疑義を生じたことがありません。
 申し訳ないですが、何ら解決策への助言ができません。

koisan1949さんレスありがとうございます。
そちらは、日本語入力でATOK3を使っておられるのですね。
自分は標準搭載のscimを使っております。
やはりKDEとscimとの間でバグが生じているのかもしれないですね。
因みにAnthy以外にも日本語入力用のIMがあるのですが、どれを使用してもKDEだと
OpenOffice.org2.4での日本語入力は出来ないようです。
解決策が見つかるまでは、Gnome上で立ち上げるしかないようです。

オフライン

 

#5 2008-06-23 23:25:21

anoir
モデレータ
From: Berkeley, CA
登録日: 2007-01-13

Re: OpenOffice.orgで日本語入力が出来ません

他のアプリケーションで日本語入力はできるのでしょうか。以下のスレッドにKDEでの日本語入力の話題があります。

http://forum.ubuntulinux.jp/viewtopic.php?id=2170

またKDEのバージョンなどはかかれたほうがいいですね。

オフライン

 

#6 2008-06-23 23:34:57

tnc
メンバ
登録日: 2008-03-22

Re: OpenOffice.orgで日本語入力が出来ません

anoir による投稿:

他のアプリケーションで日本語入力はできるのでしょうか。以下のスレッドにKDEでの日本語入力の話題があります。

http://forum.ubuntulinux.jp/viewtopic.php?id=2170

上記のリンク先で参加させて頂いたので状況は把握しております。
現状と似ておりますが解決には至ってないようです。

anoir による投稿:

またKDEのバージョンなどはかかれたほうがいいですね。

KDE3.56  KDE4.0のいずれも試しましたが日本語入力は出来ません。
また、Firefox3.0でレスを入力しておりますが問題なく動作しております。
問題は、OpenOffice.org2.4での日本語入力が全く出来ない状況です。

オフライン

 

#7 2008-06-23 23:44:59

anoir
モデレータ
From: Berkeley, CA
登録日: 2007-01-13

Re: OpenOffice.orgで日本語入力が出来ません

上記のリンク先で参加させて頂いたので状況は把握しております。
現状と似ておりますが解決には至ってないようです。

おっとこれは失礼しました。

オフライン

 

#8 2008-06-24 00:00:15

ikuya
モデレータ
From: Osaka
登録日: 2006-10-20

Re: OpenOffice.orgで日本語入力が出来ません

Japanese Teamのリポジトリは追加されていますか?

もし追加されているなら、
cat /etc/X11/xinit/xinput.d/scim-bridge
の結果を張りつけてください。
オフィシャルのリポジトリにあるscim-bridgeでは、KDE環境(SKIMが動作していると)ではXIMが動作しません。

オフライン

 

#9 2008-06-24 00:04:55

tnc
メンバ
登録日: 2008-03-22

Re: OpenOffice.orgで日本語入力が出来ません

コード:

kazu@kazu-desktop:~$ cat /etc/X11/xinit/xinput.d/scim-bridge
XIM=SCIM
XIM_PROGRAM=/usr/bin/scim
XIM_ARGS="-d"
XIM_PROGRAM_SETS_ITSELF_AS_DAEMON=yes
if [ -e /usr/lib/gtk-2.0/*/immodules/im-scim-bridge.so ]; then
    GTK_IM_MODULE=scim-bridge
else
    GTK_IM_MODULE=xim
fi
if [ -e /usr/lib/qt3/plugins/inputmethods/im-scim-bridge.so ]; then
    QT_IM_MODULE=scim-bridge
else
    QT_IM_MODULE=xim
fi

DEPENDS="scim | skim, scim-bridge-agent, scim-bridge-client-gtk | scim-bridge-client-qt"

レスありがとうございます。
取り合えずコードをアップしておきます。
お役に立てば幸です。

オフライン

 

#10 2008-06-24 01:11:02

ikuya
モデレータ
From: Osaka
登録日: 2006-10-20

Re: OpenOffice.orgで日本語入力が出来ません

うーむ、特に問題ありませんね。

どうしてもKDE上でOOoを使用したいのなら、ローカライズ版Kubuntuを使うといいかもしれません。

オフライン

 

#11 2008-06-26 09:27:36

hardy
メンバ
登録日: 2008-05-12

Re: OpenOffice.orgで日本語入力が出来ません

ikuyaさん による投稿:

うーむ、特に問題ありませんね

ja_JPがscim-bridgeにリンクしていないだけじゃないですかね。
私の日本語ローカライズしていないubuntu8.04+kubuntu-desktop(パッケージ)でscim scim-bridgeどちらでもKDE上のOpenOfficeで日本語入力ができます。

オフライン

 

#12 2008-06-27 00:55:50

silvercat1
メンバ
登録日: 2008-05-12

Re: OpenOffice.orgで日本語入力が出来ません

私も遭遇しました。検索をして解決しました。
多分、これで大丈夫だと思います。
http://forum.ubuntulinux.jp/viewtopic.php?id=2170
をご覧ください。

オフライン

 

#13 2008-06-27 03:11:39

tnc
メンバ
登録日: 2008-03-22

Re: OpenOffice.orgで日本語入力が出来ません

silvercat1 による投稿:

私も遭遇しました。検索をして解決しました。
多分、これで大丈夫だと思います。
http://forum.ubuntulinux.jp/viewtopic.php?id=2170
をご覧ください。

レスありがとうございました。
リンク先でお邪魔していたにも関わらず肝心な事を見逃しておりました。
取り合えず、sudo ln -s /usr/bin/scim ~/.kde4/Autostart/scimを実行して
.KDE4のフォルダーからscimの実行ファイルをコピーして.KDEのフォルダーへ貼り付けて見たけど
なにも変わりませんでした。

問題は、この後に起こりました。
結局ですね、Sibataさんのレスにもありましたが skim-auto-start のインストールを行い
再起動したところ無事にOpenOffice.orgでの日本語入力が可能になりました。
やはりscimの自動起動に問題があったようです。

最後の編集者: tnc (2008-06-27 03:12:04)

オフライン

 

#14 2008-06-27 03:53:32

silvercat1
メンバ
登録日: 2008-05-12

Re: OpenOffice.orgで日本語入力が出来ません

よかったですね。こちらの環境では、skim-auto-start のインストールも、
デスクトップの日本語環境も設定できませんでした。
日本語環境は諦めて、結局、コマンドで
sudo ln -s /usr/bin/scim ~/.kde4/Autostart/scim 
sudo ln -s /usr/bin/scim ~/.kde/Autostart/scim を
それぞれの環境で実行することでしか解決できませんでした。

そちらではデスクトップの日本語環境は通常どおり使えていますで
しょうか。お聞かせください。

オフライン

 

#15 2008-06-27 10:19:28

tnc
メンバ
登録日: 2008-03-22

Re: OpenOffice.orgで日本語入力が出来ません

silvercat1さんを初めとしてレスを頂いた皆さんのお陰でどうにか復旧致しました。
取り合えず、スレ立てた手前、纏めをしておきます。

まず、私の現在までの環境の変遷を下記の通りに纏めてみました。

Ubuntu8.04 → KDE3.56 → KDE4.0

尚、現在はGDMで起動しております。理由はKDMだと起動およびシャットダウン時に若干違いがあり
戸惑う場面があるのと、gnome環境からKDE環境を追加してあるのでgnome環境をメインに使用した
ほうが使い勝手がよかったのでGDMを採用しています。
お陰で、使い勝手はよいのですがスタートメニューのアイコンが「?」になってはいますが動作は問題ありません。因みに、KDM環境で動作させると「?」の表記は消えて正常なアイコンが表示されます。

ちょっと横道にそれたので起動修正します。
えーと、日本語環境に至ってはランゲージパック(gnome) (KDE) 両環境をインストール設定することに
よって正常動作します。自分の場合は、両環境のランゲージパックをインストールして動作しております。
特にKDE環境ではランゲージパック以外に kde-i18n-ja と kde-l10n-ja はアプリケーションの
日本語化には必要です。 それとscim関係については、gnome環境から移行時には特にいじらず
そのままの環境で使用しておりました。
その後、KDE環境においてはOpenOffice.orgの日本語入力の際にsicmの動作に問題が生じました。
結局、その時はsicmはFirefox3やその他のアプリでは正常動作していたのでOpenOffice.orgのほうに問題があるのではないかと想い、OpenOffice.orgの日本語フォーラムサイトで質問してみました。
ところが、OpenOffice.orgのフォーラムサイドからの回答ではUbuntuでは正常動作しているとのことでした。それと、レスを頂いた方からの指摘でUbuntuデストリで配布されているOpenOffice.orgは
オリジナルではなくUbuntuの開発者がパッチを入れたバージョンとのことでした。

結局、また振り出しに戻った訳で自分なりにひとつずつ原因を追求してみることにしました。
まず、KDEではなくgnomeで立ち上げてみることにしました。
すると、なんら問題なく日本語入力が正常に行えました。
これで原因は、KDMの環境に問題があることが判明しました。
でも、KDMのどこに原因があるかまでは特定出来ずに苦慮しておりましたところsicmの動作に問題が
あるのではないかと、指摘を受けましたのでなるほどと思いました。 

その後、sicm回りを点検して見たのですが私では原因追求に至らずレスを待っておりました。
そうこうしているうちにsilvercat1さんよりレスを頂きました。
リンク先で参加していたにも関わらず肝心なところを見逃しておりました。
原因はsicmの自動起動にあったようです。
特に、OpenOffice.orgの動作においては非常に重要なことであったようです。
原因が特定出来たところで、skim-auto-startのインストールを行いシステムを再起動して
OpenOffice.orgを起動したところ正常な動作にもどりました。
前々からタイピング中に強制終了やハングアップなどの異常動作があったのもこれが原因かなと
思っております。

最後の編集者: tnc (2008-06-27 10:39:15)

オフライン

 

Board footer

Powered by FluxBB