お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2008-12-22 00:43:29

ltakeshi
新しいメンバ
登録日: 2008-10-12

ubuntu8.10においての、libltdl3について

こんばんわ、ltakeshiです。
先日EPSONのEP-801Aを購入し、http://www.avasys.jp/lx-bin2/linux/spc/DL2.do
に従いスキャナの設定を行おうとしていたのですが、iscan_2.15.0-3_i386.debをインストールしようとすると、libltdl3に依存しているということでインストール出来ませんでした。そこで、aptiudeで探して見たところ、ubuntu8.10ではlibltdl3はなくlibltdl7というパッケージが存在したため、そちらをインストールしました。
そして、もう一度ドライバのインストールを行おうとしたのですが、今度もlibltdl3に依存しているためインストールで来ませんでした。
そこで、おうかがいしたいのですが、ubuntu8.10にlibltdl3のパッケージは存在しているのでしょうか?
また、存在していない場合はどのような対応をしたらEP-801Aのスキャナを使えるようになるのでしょうか。
ご教示お願いいたします。

オフライン

 

#2 2008-12-22 07:12:26

sumiyota
メンバ
From: 茨城県
登録日: 2007-06-09

Re: ubuntu8.10においての、libltdl3について

こんにちは、ltakeshiさん。

私はEPSON/PX-A620を使用しています。当方でUbuntu8.10でAVASYSのドライバをインストールする時にはどうやらPulseAudioを削除しないとダメみたいでした。(PulseAudioを削除しないとlibltdl3をインストールできないようでした)

ですがドライバのインストールは成功したものの、動作しませんでした。。。。。その他の問題もあり、今はUbuntu8.04を使っています。(もちろんプリンタは簡単に動作します)

あまり参考にならずに済みません。。。。

最後の編集者: sumiyota (2008-12-22 07:17:09)

オフライン

 

#3 2008-12-22 08:13:22

のんき
メンバ
登録日: 2007-03-04

Re: ubuntu8.10においての、libltdl3について

ltakeshiさんへ
AVASYSのホームページを見てみますとEP-801Aのドライバ動作確認はUbuntu 8.04までと
なっています。Ubuntu 8.10でkernel環境が変わっているため対応できないのではないでしょうか。
対応するまで待つしかないのではないでしょうか。

オフライン

 

#4 2008-12-27 15:53:54

ltakeshi
新しいメンバ
登録日: 2008-10-12

Re: ubuntu8.10においての、libltdl3について

ltakeshiです。
結局debパッケージでインストールすることを諦めて、暇を見てはソースファイルをコンパイルしようとしています。が、どうも上手くコンパイル出来ません。なので、おとなしく対応するまで待とうとおもいます。
ありがとうございました。

オフライン

 

#5 2008-12-31 08:50:37

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: ubuntu8.10においての、libltdl3について

仮想環境のゲストOS 8.10で試したらとりあえずインストールに成功しています。
以下、debファイル、ソースビルドの2通りの方法です。
なお、スキャナは持っていないので動作確認は一切出来ていません。
参考になればと思い、下記に記します。

1) debファイルでインストールする方法(libltdl3への依存性は8.04のlibltdl3パッケージを無理矢理インストールして解決)
# http://packages.ubuntu.com/hardy/libltdl3 から libltdl3 のdebファイルをダウンロード後、
$ sudo dpkg -i libltdl3_1.5.26-1ubuntu1_i386.deb
$ wget http://linux.avasys.jp/drivers/iscan/2.15.0/iscan_2.15.0-3_i386.deb
$ sudo dpkg -i iscan_2.15.0-3_i386.deb
※libltdl3は8.04のパッケージなので「バージョン混在」ということになり荒っぽい方法です。(参考URL: http://ubuntuforums.org/showthread.php?t=978407)

2) ソースからビルドしてインストールする方法
$ sudo apt-get update
$ sudo apt-get install build-essential
$ sudo apt-get install gdk-imlib11-dev libltdl7-dev libsane-dev libgtk2.0-dev
$ wget http://linux.avasys.jp/drivers/iscan/2.15.0/iscan_2.15.0-3.tar.gz
$ tar xzf iscan_2.15.0-3.tar.gz
$ cd iscan-2.15.0
$ mkdir libltdl
$ cd libltdl
$ ln -s /usr/lib/libltdl.la .
$ cd ..
$ ./configure
$ make
$ sudo make install

※意味は分からないのですが、ビルド中に ../libltdl/libltdl.la が無いというエラーがでるので、/usr/lib/libltdl.laへのシンボリックリンクを作ることで対処してます。
※configure時の細かなオプションはつけていないので、必要に応じて工夫してみてください。
オプションは、configure -- の後にTabを打てば補完されて表示されます。

スキャナ使えるといいですね。

オフライン

 

#6 2009-01-04 07:39:12

0778102
新しいメンバ
登録日: 2008-12-13

Re: ubuntu8.10においての、libltdl3について

初めまして、ここで紹介されている
>1) debファイルでインストールする方法(libltdl3への依存性は8.04のlibltdl3パッケージを
>無理矢理インストールして解決)

この方法で、8.10にセットアップしてAVASYSのドライバーがインストールすることが
できました。

早速、EPSONのEP-801Aを接続して
iscanとXsaneともに動作することが確認できました。

大変、助かりました

オフライン

 

Board footer

Powered by FluxBB