お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2009-01-17 10:40:05

pirupiru
メンバ
登録日: 2009-01-01

firefoxがつかえなくなりました。

jre(Java Runtime Enviroment)をインストールしようとおもい、ここのページを参考に作業していました。

http://www.java.com/ja/download/help/5000010500.xml

インストールは完了し、有効化と設定のセッションに進みました。

firefoxの2まですすみ、最後の

>>
Firefox 1.5 以降のバージョンをインストールした場合は、「ツール」メニューに「Java Console」が追加されます。次のコマンドで Firefox の extensions ディレクトリに移動し、ffjcext.zip を解凍します。

cd /usr/lib/firefox-1.4/extensions
unzip /usr/java/jre1.6.0/lib/deploy/ffjcext.zip 
<<

のコマンドを行った後にfirefoxを再起動しようとすると、

(firefox:6011): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...

(firefox:6011): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.

(firefox:6011): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.
INTERNAL ERROR on Browser End: Could not get the plugin manager
System error?:: Successr

とのメッセージが端末に現れ、firefoxが立ち上がらなくなりました。firefoxは再インストールできたのですが、やはりjreのインストールはできませんでした。なにがまずかったのでしょうか?端末のメッセージは今の自分には手に負えません。だれか助言をお願いします。

オフライン

 

#2 2009-01-17 11:40:39

hir0
メンバ
登録日: 2008-09-28

Re: firefoxがつかえなくなりました。

インストールしようとしたjavaのバージョンはリンク先で分かりましたが、
ubuntuのバージョンとブラウザのバージョンと実際に行った手順とコマンドを書いたほうが
アドバイスがもらいやすくなるかかも。

エラーの内容はプラグインのリンク元がおかしいと言った類じゃないかなぁ?
javaのテストで踊る何かが見えなかったので私も取り合えずプラグインを入れて試してみます。

オフライン

 

#3 2009-01-17 12:31:08

hir0
メンバ
登録日: 2008-09-28

Re: firefoxがつかえなくなりました。

大丈夫でしたよ。
javaはrpmをdebに変換してインストールしたような記憶が、、、

1、libjavaplugin_oji.so を探す。
  端末で
  # locate libjavaplugin_oji.so
     /usr/lib/jvm/java-6-sun-1.6.0.10/jre/plugin/i386/ns7/libjavaplugin_oji.so に有るみたい。

2、firefoxの本体にあるディレクトリの中のpluginsに移動。
  # cd /usr/lib/firefox-3.0.5/plugins       (私のインストールデレクトリ)  
  
3、libjavaplugin_oji.so ファイルのリンクを張る。
  # ln -s /usr/lib/jvm/java-6-sun-1.6.0.10/jre/plugin/i386/ns7/libjavaplugin_oji.so

4, 確認作業
  fitrfoxのアドレスバーにabout:pluginsと記入してEnterキー
     http://www.java.com/ja/download/help/testvm.xml
  なにかが動いてればOK?
 

最後の編集者: hir0 (2009-01-17 12:32:16)

オフライン

 

#4 2009-01-17 13:53:39

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: firefoxがつかえなくなりました。

水を差すようで悪いのですが、

Firefox 3でJavaアプレットを見るには、

パッケージ sun-java6-jre に加えて、 パッケージ sun-java6-plugin をインストールして
http://www.java.com/ja/download/help/testvm.xml

で出来ていますが、これではダメですか?

最後の編集者: STGSAGWAN (2009-01-17 13:54:50)

オフライン

 

#5 2009-01-17 19:29:51

pirupiru
メンバ
登録日: 2009-01-01

Re: firefoxがつかえなくなりました。

hir0様、わざわざ調べてくださってありがとうございます。
ご記入されたとうりに入力すると、成功しました。残念ながら自分のコマンドは消してしまったので、何が悪かったのかはわかりませんでした。気になりますが。

STGSAGWAN 様、回答ありがとうございます。きとんと動いています。

オフライン

 

Board footer

Powered by FluxBB