お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2007-06-21 18:34:12

ayu
新しいメンバ
登録日: 2007-06-21

haldaemon について

Ubuntu 7.04 デスクトップ版を ThinkPad R40e にインストールしました。

インストール後、マウスカーソルの移動やキーの入力がスムーズではないので
(割り込みが入って、引っ掛るような感じです)、

/etc/dbus-1/event.d/20hal stop

で、haldaemon を停止させたところ、症状は改善されたのですが、
当然のことながら、Gnome の起動時に、

内部エラー
failed to initialize HAL!

というメッセージが表示されるようになりました。

マウスカーソルの移動やキーの入力をスムーズにしつつ、
Gnome にエラーメッセージを出させないためには、
haldaemon の監視間隔を長く設定してやれば、良いのでは?

と考え、ググってみたのですが、
これ!といった情報がありませんでした。

キーやマウスの設定でも、調整してみたのですが、
根本的な改善には至りませんでした。

どなたか、同様の症状で上手い対処をされた方は、いらっしゃいますか?

オフライン

 

#2 2007-06-22 10:11:27

hito
管理者
登録日: 2007-03-18

Re: haldaemon について

ちょっと実際の現象を見ていないのでわかりませんが、haldを止めるのではなく、
https://bugs.launchpad.net/ubuntu/+source/casper/+bug/107516
にあるように起動時のKernelオプションに
ec_intr=0
を追加してやると引っかかる現象が改善したりしないでしょうか。

オフライン

 

#3 2007-06-22 10:54:21

ayu
新しいメンバ
登録日: 2007-06-21

Re: haldaemon について

hito による投稿:

ちょっと実際の現象を見ていないのでわかりませんが、haldを止めるのではなく、
https://bugs.launchpad.net/ubuntu/+source/casper/+bug/107516
にあるように起動時のKernelオプションに
ec_intr=0
を追加してやると引っかかる現象が改善したりしないでしょうか。

hito さん、返信、ありがとうございました。

> ちょっと実際の現象を見ていないのでわかりませんが、

説明不足で申し訳ありませんでした。
症状的には、

tttthiiiiiiiiiiiissss (本当は、this と打ちたい)

と、リピートが効き過ぎたり
(キーバッファに貯め込まれたものがいっぺんに吐き出されるような感じ)、あるいは、

au (本当は、ayu と打ちたい)

と、入力を取りこぼしたり、という状況です。

Bug #107516 in casper (Ubuntu): “loading ACPI modules and starting HALd took too long time”
https://bugs.launchpad.net/ubuntu/+source/casper/+bug/107516

こちらに投稿後、私もこのページを見つけ、試してみました。

ログイン後は、大分改善されたのですが、
ログイン時は、リピートが効き過ぎたり、逆にまったく入力できなかったり、と、
ユーザ名とパスワードの入力が、かなり悲惨な状態でした。

結局、

Bug #99356 in Ubuntu: “[Feisty] Keyboard repeats keystrokes like tttthiiiiiiiiiiiissss”
https://bugs.launchpad.net/ubuntu/+bug/99356

こちらのページを参考に、

・起動時の Kernel オプション(/boot/grub/menu.lst)に tsc=notsc を追加
・acpid を停止(システムメニュー → システム管理 → サービスの管理 → 電源の管理をチェックアウト)

させたところ、症状がパタっと、収まりました。

どうも、特定の ThinkPad のみに発生する症状のようです
(斜め読みですので、恐らくですが・・・)。

ノートですので、acpid を止めるのは、いかがなものか?
とも、思いましたが、
キータイプがスムーズにできないことの方が、あまりよろしくありませんので、
取りあえず、この対処法でしばらく使用してみることにします。

一応、自己解決、ということで、よろしくお願いいたします。
また、hito さん、返信、本当にありがとうございました。

オフライン

 

Board footer

Powered by FluxBB