お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2009-09-15 22:16:35

touko
メンバ
登録日: 2009-06-14

sshがつながりません。

「ssh: connect to host 192.168.1.3 port 22: Connection refused」というエラーメッセージが出てsshがつながりません。どのように修復すればよいか教えてください。よろしくお願いします。

オフライン

 

#2 2009-09-15 22:28:55

avidya
ゲスト

Re: sshがつながりません。

toukoさん による投稿:

「ssh: connect to host 192.168.1.3 port 22: Connection refused」というエラーメッセージが出てsshがつながりません。どのように修復すればよいか教えてください。

 これだけでは原因の特定は困難です。"Connection refused" とありますので設定関係だけでも三つのことが想起されます。一つめは firewall で port 22 が塞がれているかもしれない、ということです。二つめは ssh サーバの port が、22 から変更されているかもしれない、ということです。三つめはそもそも ssh のデーモンが停止しているのではないか、ということです。
 ssh のデーモンの設定を変更してはいませんか?あるいは firewall の設定を変更していませんか?または ssh のデーモン自体が動いていない、ということはありませんか?トラブル発生時は、最初に現状を把握、分析することが重要です。

 

#3 2009-09-15 22:31:30

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

sshのデーモンが動いているかどうかどのように確認すればよいのでしょうか?それは、サーバ側でしょうか?クライアント側でしょうか?

オフライン

 

#4 2009-09-15 22:41:46

avidya
ゲスト

Re: sshがつながりません。

 サーバ側になります。サーバで以下のコマンドを実行することで確認できます ( ssh デーモンが sshd の場合 )。

コード:

ps -A | grep sshd

 IP アドレスから、LAN 等のローカルなネットワーク内で完結する接続を行われようとしていると推察します ( そうとは限らないとも理解しています )。サーバ上で sshd を動かすように設定されているのでしょうか?

touko による投稿:

sshのデーモンが動いているかどうかどのように確認すればよいのでしょうか?

という質問があることから、サーバの管理者の方は別にいらっしゃるのでしょうか?もしサーバ管理者の方がいらっしゃるのならば、サーバ管理者の方に協力を依頼することが、もっとも問題解決の近道である、と考えます。

 

#5 2009-09-15 22:46:20

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

「ps -A | grep sshd」と入力したら「11889?       00:00:00 sshd」と表示されました。これは何を意味するのでしょうか?よろしくお願いします。

オフライン

 

#6 2009-09-15 22:57:42

avidya
ゲスト

Re: sshがつながりません。

toukoさん による投稿:

「ps -A | grep sshd」と入力したら「11889?       00:00:00 sshd」と表示されました。これは何を意味するのでしょうか?よろしくお願いします。

 ssh デーモンが起動しており、アクセスを待っている状態を示しています。これにより想起されることが三つから二つに減少します。一つめは firewall が sshd の port を塞いでいる、ということです。二つめは sshd の port が 22 と異なる port に設定されているということです。
 firewall の設定と sshd の設定を確認することをお薦めします。

 

#7 2009-09-15 23:03:46

avidya
ゲスト

Re: sshがつながりません。

最初に sshd の設定ファイルを見て、sshd への接続 Port 番号を確認してください。
次に firewall が当該 port へのアクセスを許可しているか確認してください。

 

#8 2009-09-15 23:52:20

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

sshdの設定ファイルはどこにあるのでしょうか?教えてください。
また、firewallは設定していないので関係ないと思われます。

オフライン

 

#9 2009-09-16 00:10:51

n_saito
メンバ
登録日: 2009-06-23

Re: sshがつながりません。

設定ファイルは /etc/ssh/sshd_config ですね。

# ssh_configもあるかと思いますが、こちらはクライアント側の設定ということで。

あと、エラーメッセージだけでなく、接続する際に-vオプションを使った結果も貼り付けると吉です。
オプションの与え方としては
ssh -v -l (ログインしたいアカウント) 192.168.1.3
というカンジです。

オフライン

 

#10 2009-09-16 00:34:20

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

設定ファイルのポートは22でした。
以下にssh -v -lの結果を張り付けておきますので、よろしくお願いいたします。

OpenSSH_5.1p1 Debian-5ubuntu1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 192.168.1.3 [192.168.1.3] port 22.
debug1: connect to address 192.168.1.3 port 22: Connection refused
ssh: connect to host 192.168.1.3 port 22: Connection refused

オフライン

 

#11 2009-09-16 02:30:57

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

クライアント側のポート22を開放してみましたが、やはり最初と同じエラーメッセージが出てしまいました。

オフライン

 

#12 2009-09-16 03:56:48

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: sshがつながりません。

接続するべきユーザが、サーバ側に、いないのでは?

オンライン

 

#13 2009-09-16 06:23:35

avidya
ゲスト

Re: sshがつながりません。

toukoさん による投稿:

クライアント側のポート22を開放してみましたが、やはり最初と同じエラーメッセージが出てしまいました。

 開放するのはサーバ側になります。
 その是非はともかく

toukoさん による投稿:

また、firewallは設定していないので関係ないと思われます。

とありますので、firewall のセンもなさそうですね。
 すると、si さんがおっしゃっているセンも充分ありそうです。

 

#14 2009-09-16 07:30:51

hmatsue
アドバイザ
登録日: 2009-03-10

Re: sshがつながりません。

以前は接続できていたのでしょうか。
認証の方式はどのようになっていますでしょうか。

オフライン

 

#15 2009-09-16 08:23:33

ry
メンバ
登録日: 2008-07-30

Re: sshがつながりません。

#1から#13までのやりとりから、ssh やデーモンの動作に関してかなりの初心者 (利用するだけの人) ではないかと推察した上で、失礼な質問をします

以下のそれぞれについて、確認した結果を教えてください

・接続先の「ssh サーバーの IP アドレス」
・接続先の ssh サーバー上の「/etc/ssh/sshd_config ファイルの内容」
・ssh コマンドを実行している「ssh クライアントの IP アドレス」
・ssh で接続するために実際に実行した「コマンド」と、そのときに「画面に出力された結果」
・接続先の ssh サーバーで 「ssh localhost コマンドを実行したときの結果」

オフライン

 

#16 2009-09-16 10:52:13

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

サーバ側の接続者の確認はどのようにしたらよいですか?

オフライン

 

#17 2009-09-16 12:50:00

hmatsue
アドバイザ
登録日: 2009-03-10

Re: sshがつながりません。

/var/log/auto.log
に認証の記録が残されます。
端末を開いて、

コード:

grep sshd /var/log/auth.log

とすると、sshd関連のログが表示されます。
#15のryさんの質問に答えていただくのが解決の近道だと思いますので、そちらの方もアップデート下さい。

オフライン

 

#18 2009-09-16 12:51:09

hmatsue
アドバイザ
登録日: 2009-03-10

Re: sshがつながりません。

ごめんなさい。Typoしてます。
/var/log/auto.logではなく、/var/log/auth.logです。

オフライン

 

#19 2009-09-16 15:45:30

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

grrep sshd /var/log/auth.logと入力したら次のように出ました。

Sep 16 15:32:05 rosie sshd[3597]: Server listening on 0.0.0.0 port 22.
Sep 16 15:32:05 rosie sshd[3597]: Server listening on :: port 22.


そして、ryさんへのお答えなのですが、

・接続先の「ssh サーバーの IP アドレス」
192.168.1.2

・接続先の ssh サーバー上の「/etc/ssh/sshd_config ファイルの内容」
# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile    %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

・ssh コマンドを実行している「ssh クライアントの IP アドレス」
192.168.1.3

・ssh で接続するために実際に実行した「コマンド」と、そのときに「画面に出力された結果」
「ssh <クライアント名>@192.168.1.3」というコマンドで
「ssh: connect to host 192.168.1.3 port 22: Connection refused」とういう結果が出た。

・接続先の ssh サーバーで 「ssh localhost コマンドを実行したときの結果」
The authenticity of host 'localhost (::1)' can't be established.
RSA key fingerprint is 04:e1:c4:a3:4a:87:2d:b1:a3:7b:09:8e:03:4b:30:9f.
Are you sure you want to continue connecting (yes/no)?
Host key verification failed.

以上です。よろしくお願いいたします。

オフライン

 

#20 2009-09-16 16:15:04

930
メンバ
登録日: 2009-06-23

Re: sshがつながりません。

touko さん による投稿:

・ssh で接続するために実際に実行した「コマンド」と、そのときに「画面に出力された結果」
「ssh <クライアント名>@192.168.1.3」というコマンドで
「ssh: connect to host 192.168.1.3 port 22: Connection refused」とういう結果が出た。

接続したいのは、192.168.1.2 のサーバーに接続したいのですよね?
であれば、

コード:

ssh <ユーザー名>@<接続先>

と入力して下さい。

具体的には、

コード:

ssh <ユーザー名>@192.168.1.2

です。

オフライン

 

#21 2009-09-16 17:52:37

touko
メンバ
登録日: 2009-06-14

Re: sshがつながりません。

できました!サーバとクライアントを間違えていました。どうもありがとうございました。

オフライン

 

Board footer

Powered by FluxBB