お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2011-06-27 00:02:22

picky
新しいメンバ
登録日: 2011-06-26

2ch ブラウザ JDを最新版にしたい。

Ubuntu 10.04を使用中です。
Synapticから2chブラウザのJDをインストールしたのですが、最新版にアップデート出来ません。
書き込みが出来ないので最新版にアップデートしたいです。

http://jd4linux.sourceforge.jp/
を見ると最新版は2.81以上のような記載があります。

Synapticからのプロパティ情報です。
メンテナ:Ikuya Awashiro <ikuya@fruitsbasket.info>
バージョン:1:2.6.0-100208-0ubuntu1
最新のインストール可能バージョン:1:2.6.0-100208-0ubuntu1

試したこと
https://forums.ubuntulinux.jp/viewtopic.php?id=4281を参考に

システムー>システム管理ー>ソフトウェア・ソースー>サードパーティのソフトウェア(tab)ー>
追加ー>APT line: 下記内容を入力
deb http://archive.ubuntulinux.jp/ubuntu-ja hardy-experimental/
ソースを追加ー>閉じるー>再読込ー>閉じる
システムー>システム管理ー>アップデート・マネジャー>アップデートをインストールー>閉じる
としましたが、バージョンアップ出来ませんでした。

端末からの実行結果
sudo apt-get install jd
jd はすでに最新バージョンです。
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
linux-headers-2.6.32-24 linux-headers-2.6.32-24-generic

お手上げ状態です。
ご教示頂けると幸いです。

オフライン

 

#2 2011-06-27 02:26:20

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: 2ch ブラウザ JDを最新版にしたい。

Ubuntuには、jd を積極的にサポートするメンテナーは、居らっしゃらないみたいですね。
パッケージとしてリポジトリに登録されているのは、11.04 でも 2.7.5 のようです。
どうしても最新版が必要なら、下記ページを参照し、svn版を、自分でビルドすることになりそうです。
http://sourceforge.jp/projects/jd4linux/wiki/OS%2f%E3%83%87%E3%82%A3%E3%82%B9%E3%83%88%E3%83%AA%E3%83%93%E3%83%A5%E3%83%BC%E3%82%B7%E3%83%A7%E3%83%B3%E5%88%A5%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E6%96%B9%E6%B3%95#h2-Ubuntu

オフライン

 

#3 2011-06-27 02:39:10

hir0
メンバ
登録日: 2008-09-28

Re: 2ch ブラウザ JDを最新版にしたい。

10.04に別バージョンのリポジトリが混ざってしまっているので再インストールしてください。
将来的にエラーが出ても構わない、何事も起こらなければラッキーと考えるならそのままでも大丈夫ですが8.04のリポジトリは削除してください。
混ざった物は元には戻らないと聞きますが、とりあえず8.04のリポジトリを削除した状態で

$ sudo apt-get clean
$ sudo apt-get update
$ sudo apt-get -f install
$ sudo apt-get update

をしておくと良いかもしれません、気休めかな?

インストールの方法ですが#1に書かれているURLからsvnを使用した方法で最新版がインストールされたりしませんか?
11.04の方法と9.04の方法が載っています。

10.04ですよね。 オプションに-y を付けるとyes/no の選択が出ないので(全てyesになる)、11.04の方法を実行して下さい。
「ttf-ipamonafont」は「ttf-mona」に変更して下さい。

--with-native はデフォルトで適用されるはずですので省略可能です。

オフライン

 

#4 2011-06-27 02:53:49

hir0
メンバ
登録日: 2008-09-28

Re: 2ch ブラウザ JDを最新版にしたい。

忘れていました。 最初に
$ sudo apt-get install build-essential

を実行して下さい。

オフライン

 

#5 2011-06-27 17:19:56

vbk
メンバ
From: Lake Hamana in Hamamatsu
登録日: 2009-12-22

Re: 2ch ブラウザ JDを最新版にしたい。

ちょっと気になることがありますので...。

jdのサイトに「ソース」というリンクがあるので、そこから落とせるtarballを展開してビルドしたほうがいいのではないでしょうか。
svnは普通開発に使うもので、中の物はバグが多数あると思われます。

siさん による投稿:

Ubuntuには、jd を積極的にサポートするメンテナーは、居らっしゃらないみたいですね。

debian sidやubuntu oneiricには既に2.8.1がアップされているので、そこそこ積極的なのかな〜とは思いますが、Ubuntuの場合リリース後は基本的にディストリビューションレベルでの変更しか受け付けないようなので、11.04以前でjd 2.8.1が提供されることは今後もないかもしれません。

オフライン

 

#6 2011-06-27 19:26:59

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: 2ch ブラウザ JDを最新版にしたい。

vbk による投稿:

svnは普通開発に使うもので、中の物はバグが多数あると思われます。

vbkさんはjdの最新事情にとても詳しいのですね。
jdのtrunkにバグが多いという感覚を持ち合わせているのは、最新ソースコードの追っかけでされているとか、開発に携わっているから、とかでしょうか?
私もjdに興味があって使おうかと思っていますが、そんなに「バグが多数」と言われてしまうと、trunkをビルドすることを躊躇してしまいます・・・。

オフライン

 

#7 2011-06-27 20:14:23

vbk
メンバ
From: Lake Hamana in Hamamatsu
登録日: 2009-12-22

Re: 2ch ブラウザ JDを最新版にしたい。

STGSAGWAN による投稿:

vbkさんはjdの最新事情にとても詳しいのですね。

誤解を与えてしまったようでスミマセン、、、
jdについて詳しいというわけではなく、単なる一般論として
開発中の所からダウンロード・ビルドして使うのは、リスクが高いということです。
(例えばFirefoxもNightly版を常用することは推奨されてませんし...)

開発者が正式版としてアップしてくれている物があるのなら、そちらを使ったほうが安心できませんか?という意味でした。

オフライン

 

#8 2011-06-27 22:40:00

ikuya
モデレータ
From: Osaka
登録日: 2006-10-20

Re: 2ch ブラウザ JDを最新版にしたい。

https://launchpad.net/~ikuya-fruitsbasket/+archive/ppa
にLucid用の最新版JDをアップロードしました。適宜お使いください。
Natty用は前からあります。

オフライン

 

#9 2011-06-28 02:02:11

picky
新しいメンバ
登録日: 2011-06-26

Re: 2ch ブラウザ JDを最新版にしたい。

略式で申し訳ないですが、みなさんアドバイスありがとうございます。

何から手をつければ良いか分かっていませんが、
deb http://archive.ubuntulinux.jp/ubuntu-ja hardy-experimental/
は削除しました。

ソースからのビルドは不安なので保留にしています。
まだLinuxになれてないので、何かあったときに解決出来なくなりそうなので・・・。


アップデートに関してはikuyaさんのリンク先を辿ればいいのでしょうか?
jd     1:2.8.1-110312-0ubuntu1~ppa1    Ikuya Awashiro (7 hours ago)

これっぽいのですが、何をどうすればアップデート出きるのか理解できていません。
どなたか噛み砕いて説明して頂けると幸いです。

引き続きよろしくお願い致します。

オフライン

 

#10 2011-06-28 11:18:56

petitbootang
メンバ
From: 東京都
登録日: 2009-02-12

Re: 2ch ブラウザ JDを最新版にしたい。

端末から、
$ sudo add-apt repository ppa:ikuya-fruitsbasket/ppa
$ sudo apt-get update
$ sudo apt-get install jd
とすれば良いと思います。

オフライン

 

#11 2011-06-28 11:39:01

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: 2ch ブラウザ JDを最新版にしたい。

picky による投稿:

アップデートに関してはikuyaさんのリンク先を辿ればいいのでしょうか?

端末を起動し、

コード:

sudo add-apt-repository ppa:ikuya-fruitsbasket/ppa

と入力し、jd 最新版のある ppa リポジトリを使えるようにします。
そして、synaptic等のパッケージマネージャを起動し、
「再読み込み」すれば、ikuya-fruitsbasket/ppa にある
jd が見えるようになるはずです。

ppa というのは、アプリの最新版やテスト版等を導入するためにある開発者、テスター向けのリポジトリ環境のようです。

###
私、大きな勘違いをし、間違ったことを言ったようです。
前言は、なかったことにしてください。m<(_._)>m
###

オフライン

 

#12 2011-06-29 21:32:27

picky
新しいメンバ
登録日: 2011-06-26

Re: 2ch ブラウザ JDを最新版にしたい。

みなさん。ありがとうございました。
無事アップデートすることが出来ました^^

書き込みもokでした。
これからもよろしくお願いします。

オフライン

 

#13 2014-01-13 23:19:14

picky
新しいメンバ
登録日: 2011-06-26

Re: 2ch ブラウザ JDを最新版にしたい。

Ubuntu 12.04 LTSを使用しています
以前、このトピックスでJDのアップデートをご教授頂きました

端末にて下記を実行したらJDを2.8.6-130518ににアップデートしたのですが
sudo add-apt-repository ppa:ikuya-fruitsbasket/ppa
$ sudo apt-get update
$ sudo apt-get install jd
最新版は2.8.7以降らしく最新版へアップデート出来ていません

以前は上のコマンドで最新版に出来ていたのですが
今回は最新版に出来なかった理由が分かりません

解決方法をご教授頂けると幸いです
よろしくお願い致します

オフライン

 

#14 2014-01-14 03:29:23

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: 2ch ブラウザ JDを最新版にしたい。

picky による投稿:

Ubuntu 12.04 LTSを使用しています
以前、このトピックスでJDのアップデートをご教授頂きました

端末にて下記を実行したらJDを2.8.6-130518ににアップデートしたのですが
sudo add-apt-repository ppa:ikuya-fruitsbasket/ppa
$ sudo apt-get update
$ sudo apt-get install jd
最新版は2.8.7以降らしく最新版へアップデート出来ていません

以前は上のコマンドで最新版に出来ていたのですが
今回は最新版に出来なかった理由が分かりません

解決方法をご教授頂けると幸いです
よろしくお願い致します

3時間前に 2.8.7 に更新されて要るようです。
もう一度、アップデートをトライしてみてください。

オフライン

 

#15 2014-01-14 22:59:58

picky
新しいメンバ
登録日: 2011-06-26

Re: 2ch ブラウザ JDを最新版にしたい。

$ sudo apt-get update
$ sudo apt-get install jd
上記のコマンドで2.8.7-140104にアップデート出来ました!
ただアップデートしても外部板が読み込めなかったのは残念でした

si様、ありがとうございました
いつも助かります。

オフライン

 

Board footer

Powered by FluxBB