お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2011-11-03 21:34:10

Linux7
メンバ
登録日: 2009-05-18

Ubuntu10.04 64bit で音が出ない

初心者サポートのところで返事がなかったので、こちらで改めて質問することにいたしました。

過去ログを調べて自分で解決しようとしたのですが、それでは解決しなかったり理解できないところがあったりでどうしても解決できそうにないので質問することにいたしました。
マザーボードはAsrock H67DE3を使っています。
フロントパネルのジャックにつなげるスピーカーを使おうとしています。

とりあえずドライバの問題かと思い、このマザーボードのカタログを見るとチップは「Realtek ALC892 オーディオコーデック」と書いてあったので、Realteckからドライバをダウンロードしてインストールしようとしました。
するとなぜか「サウンドの設定」の「ハードウェア」タブの部分に何も表示されなくなってしまいました。(ダミーが表示?)
この問題についてはカーネルの再インストールをすると解決したので大丈夫です。

次に
https://bugs.launchpad.net/ubuntu/+sour … bug/573378
を見るとデフォルトのカーネルではALC892をサポートしてないというような内容(英語を全部読めなかったので半端に読んだのですが…)が書いてあったので、カーネルをアップデートし、現在は"2.6.37-020637-generic"を使っております。

現在も音は出ていません。
どうしたら良いでしょうか?

オフライン

 

#2 2011-11-03 21:42:46

kokawa2003
メンバ
From: Kepler-10c
登録日: 2009-05-03

Re: Ubuntu10.04 64bit で音が出ない

↓これにそってしらべるか
https://wiki.ubuntulinux.jp/UbuntuTips/Hardware/SoundTroubleshooting
↓intel hdならこの手順をやってみてはどうだろうか?
https://help.ubuntu.com/community/HdaIntelSoundHowto

オフライン

 

#3 2011-11-04 16:54:33

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

https://wiki.ubuntulinux.jp/UbuntuTips/Hardware/SoundTroubleshooting
こちらの方は「ALSAレベルでサウンドデバイスが認識されているかの確認」の項目のように

$ cat /proc/asound/cards

とすると

0 [CMI8738        ]: CMI8738-MC6 - C-Media CMI8738
                      C-Media CMI8738 (model 55) at 0xd000, irq 16
1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfe640000 irq 47

となりました。次に

$ cat /proc/asound/card0/codec*  | grep -i codec

と打ち込んだところ

cat: /proc/asound/card0/codec*: No such file or directory

となりました。

$ cat /proc/asound/card1/codec*  | grep -i codec

ですと、

Codec: ATI R6xx HDMI

と表示されたのですが、私はHDMIを使いたいわけではありません。
デバイス番号が0の方が「No such file or directory」となるということは、デバイスが読み込まれていないということなのでしょうか?

オフライン

 

#4 2011-11-04 17:00:35

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

また
https://help.ubuntu.com/community/HdaIntelSoundHowto

https://forums.ubuntulinux.jp/viewtopic.php?id=11643
に書いてあるように、"/etc/modprobe.d/snd-hda-intel.conf"を作って"options snd-hda-intel model=(オプション)"を設定する方法も試してみましたが、そもそも新しめのALC892に対応しているオプションが無いためか効果はありませんでした。

オフライン

 

#5 2011-11-04 18:59:55

jet-kubuntu
メンバ
登録日: 2011-10-07

Re: Ubuntu10.04 64bit で音が出ない

素の(Ubuntuの)状態ではないようなので、以下の4点について回答するとわかりやすくなると思います。

(1) PC機種情報をもう少し書いた方が良いと思います。

(2) カーネルの再インストール&アップグレードはどのようにされたのかが良くわかりません。もう少し詳しくお願いします。

(3) 以下の2つのコマンドの結果をお願いします。

コード:

$ uname -a
$ cat /etc/lsb-release

(4) コーデックに関しては以下の2つのコマンドの結果をお願いします。

コード:

$ cat /proc/asound/card0/codec* | grep Codec
$ aplay -l

オフライン

 

#6 2011-11-04 22:33:28

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

返信してくださってありがとうございます。

(1)PCは自分で組み立てたもので、機種名はありません。サウンドカードも増設したものでなく、Asrock H67DE3のオンボードのものです。
ケースはScythe SCY-0311FEです。

(2)カーネルは
http://www.ramoonus.nl/2011/01/linux-kernel-2-6-37-installation-guide-for-ubuntu-linux/
のページにそってdebファイルをダウンロードしてインストールしました。

(3)コマンドの結果は以下の通りです。

$ uname -a
Linux desktop 2.6.37-020637-generic #201101050908 SMP Wed Jan 5 09:09:44 UTC 2011 x86_64 GNU/Linux

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.3 LTS"


(4)
$ cat /proc/asound/card0/codec* | grep Codec
cat: /proc/asound/card0/codec*: No such file or directory

$ aplay -l
**** ハードウェアデバイス PLAYBACK のリスト ****
カード 0: CMI8738 [C-Media CMI8738], デバイス 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 0: CMI8738 [C-Media CMI8738], デバイス 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 0: CMI8738 [C-Media CMI8738], デバイス 2: CMI8738-MC6 [C-Media PCI IEC958]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 1: Generic [HD-Audio Generic], デバイス 3: HDMI 0 [HDMI 0]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0

オフライン

 

#7 2011-11-08 21:54:12

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

その他必要な情報はありますか?

オフライン

 

#8 2011-11-09 18:12:01

jet-kubuntu
メンバ
登録日: 2011-10-07

Re: Ubuntu10.04 64bit で音が出ない

launchpad.net のバグのページが見れない(リンクが変)ので、ここに移動前のスレを見て見ました。
https://forums.ubuntulinux.jp/viewtopic.php?id=12413

launchpad.net のバグのページはこちらですね?
https://bugs.launchpad.net/ubuntu/+sour … bug/573378

ここに書いてあるのを見ると Ubuntu 10.04 のままの kernel 2.6.32 と alsa 1.0.21 でも認識までは出来ているようです。

#cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ID 892
Codec: Intel G45 DEVIBX

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-21-generic 2.6.32-21.32
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:

$ cat /proc/asound/card0/codec#* | grep Codec とコマンドすれば Codec: Realtek ID 892 と返ってくる状態です。

バグのページにはこのように書かれていました。

The default kernel installed with Ubuntu 10.04 has no full support for ALC892 Audio chip, available on for example the ASUS P7H55-M Pro motherboard. Instead, it reverts to a generic intel HD Audio chip, offering only stereo playback.

翻訳(Yahoo翻訳)してみると以下になりました。

Ubuntu 10.04でインストールされるデフォルト・カーネルは、ALC892 Audioチップ(たとえばASUS P7H55-Mプロ・マザーボードの上で利用できる)に対するフル・サポートを持ちません。 その代わりに、それは一般的な情報HD Audioチップに戻ります。そして、ステレオ再生だけを提供します。

Ubuntu10.04の標準のままでも、ステレオ2ch再生であれば動作するように思えるのですが、フロントパネルのジャックというのはPCケースのフロントパネルにある出力ジャック(ヘッドフォン出力?)のことでしょうか?

もっと全体を翻訳してみるとPPAからのカーネルの導入などのヒントも書いてありましたので、自動でサイト全体を翻訳してくれる翻訳サイトを使うか、chromium-browserなどで翻訳して見ると良いと思います。


話題からそれることなのですが、回答のつきにくい話題かな?と感じましたので以下に理由を。

私はUbuntuのチームメンバーでもありませんし、自治的なことを言ったりするのも得意ではないのですが、、、
「問題解決のためにカーネルをアップグレードしてみよう」ということがあるかもしれません。しかし、カーネルをアップグレードするために、Ubuntu公式や、UbuntuのPPA以外からのカーネルをインストールする方法を選択した場合、この「Ubuntu日本語フォーラム」で質問されても回答をもらえることが少ないように思います。
今回はカーネルのパッケージですが、その他のパッケージに関しても同じです。メーカーのサイトからのパッケージやソースビルドの問題であれば公式のものとして扱ってもらえると思うのですが、それ以外の個人ビルドパッケージなどは、UbuntuのPPAからのパッケージインストールのものまでが話題として有効ではないかと思います。

今回の個人ビルドパッケージの問題の場合でも解決策を回答することは出来るのですが、ここでそれを回答して他の人も次々と同じように実行し問題が出てきても困ると思うのです。
個人ビルドパッケージは個人で解決するのが本来ですし、どこかのサイトからの導入であればそちらのサイトで質問する、またはUbuntuフォーラム以外のQ&Aサイトで質問するのが妥当だと言えます。

以上の理由から、もし出来るなら Ubuntu 10.04 標準のカーネルの状態に戻してお話しをすすめることは出来ないでしょうか?と思っています。
もちろん、他の回答もあるはずなのでこのまま待つのも良いと思います。


-- 補足として --
今回の問題であれば、カーネルをアップグレードしたことによりALSAのパッケージが上手く動作していない状態が考えられますので、ALSAのDKMSパッケージをUbuntuのPPAから導入して、最新のALSAパッケージをUbuntuのPPAから導入すれば解決しそうでもあるのですが、私からはこれ以上の回答は上記の理由から、、、

オフライン

 

#9 2011-11-09 21:55:49

Mocchi
管理者
登録日: 2009-05-17

Re: Ubuntu10.04 64bit で音が出ない

Ubuntu 10.04 (Lucid Lynx)はLong Term Release (LTS)なので、Ubuntuのリポジトリからカーネルイメージの比較的新しいパッケージが提供されています。調べたところパッケージ「linux-image-2.6.38-12-generic」というのがあります。

パッケージ: linux-image @ packages.ubuntu.com

カーネルイメージに関してはこちらを利用してみてはいかがでしょう?

さて、ここらでこれまでの情報をまとめてみたいと思います。

1. マザーボードはAsrock H67DE3を使っている。スペックによると、搭載されているサウンドカードは「7.1チャネルHD Audioおよびコンテンツ保護機能 (Realtek ALC892 オーディオコーデック)」
2. この他に、「C-Media CMI8738」で表示されるサウンドカードを使っている(玄人志向のCMI8738-6CHLPあたり?)
3. コマンド「$ cat /proc/asound/cards;」ではどちらのサウンドカードも認識されている
4. コマンド「$ cat /proc/asound/card1/codec*  | grep -i codec」では「HDA-Intel」に搭載されているコーデックとして「Codec: ATI R6xx HDMI」が表示される
5. コマンド「$ cat /proc/asound/card0/codec* | grep Codec;」では「C-Media CMI8738」に搭載されているコーデックが表示されない
6. コマンド「$ aplay -l;」からは、「HDA-Intel」のHDMI出力と、「C-Media CMI8738」の出力が利用可能である

Linuxの場合、サウンドデバイスのドライバーはカーネルイメージに含まれているため、なるべく由来のはっきりしているカーネルイメージをインストールした上で相談していただけると、回答者も回答しやすいのかなという気がします。

というわけでリポジトリ提供のカーネルをインストールした上で再度、上記出力を教えて下さい。その際、jet-kubuntuさんが教えて下さったコマンド「$ uname -a;」で、今どのバージョンのカーネルで起動しているのかを確認できますので、きっと役立つでしょう。

オフライン

 

#10 2011-11-10 16:58:12

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

>jet-kubuntu様

自分でできるだけのことをやろうとした結果(カーネルのアップデート)が裏目に出たのですね。
今後気をつけることにします。
しかし過去のカーネル

$ uname -a
Linux desktop 2.6.32-26-generic #48-Ubuntu SMP Wed Nov 24 10:14:11 UTC 2010 x86_64 GNU/Linux

の状態で

$ cat /proc/asound/card0/codec#* | grep Codec

と打ってもやはり

cat: /proc/asound/card0/codec#*: No such file or directory

となってしまいます。
"aplay -l"では以下の通りです。

$ aplay -l
**** ハードウェアデバイス PLAYBACK のリスト ****
カード 0: CMI8738 [C-Media CMI8738], デバイス 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
  サブデバイス: 0/1
  サブデバイス #0: subdevice #0
カード 0: CMI8738 [C-Media CMI8738], デバイス 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 0: CMI8738 [C-Media CMI8738], デバイス 2: CMI8738-MC6 [C-Media PCI IEC958]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 1: Generic [HD-Audio Generic], デバイス 3: ATI HDMI [ATI HDMI]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0

オフライン

 

#11 2011-11-10 17:11:12

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

>Mocchi様
カーネルイメージを"linux-image-2.6.38-12-generic"に変えてみました。
リポジトリを追加してsynapticからインストールしました。

$ uname -a
Linux desktop 2.6.38-12-generic #51~lucid1-Ubuntu SMP Thu Sep 29 19:51:55 UTC 2011 x86_64 GNU/Linux

また、コマンドの出力も改めて書きます

$ cat /proc/asound/cards;
0 [CMI8738        ]: CMI8738-MC6 - C-Media CMI8738
                      C-Media CMI8738 (model 55) at 0xd000, irq 16
1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfe640000 irq 47

ちなみにこのCMI8738は「Cobra AW850 Deluxe」というサウンドカードのことではないかと思います。
こちらは5.1ch出力のサウンドカードでして、これも今は使うつもりはありません。
出力させたいのはjet-kubuntu様の言う通り、PCケースのフロントパネルにある出力ジャックのことです。

$ cat /proc/asound/card1/codec*  | grep -i codec
Codec: ATI R6xx HDMI

$ cat /proc/asound/card0/codec* | grep Codec;
cat: /proc/asound/card0/codec*: No such file or directory

$ aplay -l;
**** ハードウェアデバイス PLAYBACK のリスト ****
カード 0: CMI8738 [C-Media CMI8738], デバイス 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
  サブデバイス: 0/1
  サブデバイス #0: subdevice #0
カード 0: CMI8738 [C-Media CMI8738], デバイス 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 0: CMI8738 [C-Media CMI8738], デバイス 2: CMI8738-MC6 [C-Media PCI IEC958]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 1: Generic [HD-Audio Generic], デバイス 3: HDMI 0 [HDMI 0]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0

カーネルをアップデートしても特に変化はないようですね…。

オフライン

 

#12 2011-11-11 17:07:39

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

解決しそうなので何が原因だったのか書き記します。

$ cat /proc/asound/cards;

のコマンドでサウンドカード(ALC892オーディオコーデックのもの)が表示されないので、そもそもサウンドカードが認識されてないということで、BIOSを確認してみました。
今まではサウンドカードの設定を初期設定である「Auto」にしてあったので、これで良いのだと思っていましたが、これが原因の一つだったようです。
おそらく前述の「Cobra AW850 Deluxe」を挿してあるため、こちらを優先する設定になっていたのでしょう。
BIOSでのオンボードサウンドカードの設定を「Enabled」にし、再度コマンドを打ってみました。

$ cat /proc/asound/cards;
0 [CMI8738        ]: CMI8738-MC6 - C-Media CMI8738
                      C-Media CMI8738 (model 55) at 0xd000, irq 16
1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfe700000 irq 47
2 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfe640000 irq 48

$ cat /proc/asound/card1/codec*  | grep -i codec
Codec: Realtek ALC892

このように、サウンドカードが認識されるようになしました。
現在まだ音は出ていませんが、ここまでくれば自力で解決できると思います。
解決次第過程を書き込みますが、どうしてもわからなかったときはまた質問いたしますので、よろしくお願いいたします。

オフライン

 

#13 2011-11-11 17:20:58

Linux7
メンバ
登録日: 2009-05-18

Re: Ubuntu10.04 64bit で音が出ない

解決いたしました。

最後はお恥ずかしい話で申し訳ないのですが…。
BIOSのオンボード設定を完了したあとも音が出ないので試行錯誤したのですが…最後の原因はジャックが抜けていただけでした。
音が出ないためスピーカーが壊れているのかなど他の機器に変えて試してそのままだったようです。

つまり今回の音が出ない原因はマザーボードのオンボード設定だけだったようです。

アドバイスをしてくださった方々、どうもありがとうございました。

オフライン

 

Board footer

Powered by FluxBB