お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2012-09-10 16:45:07

futatsuya710
メンバ
登録日: 2012-08-27

Bug#999910は12.04.1LTSで改善?

よろしくお願いします。Ubuntuは12.04.1が初めての初心者です。

Firefoxでたまにフリーズするので、ネットで調べてみると、Ivy-Brige搭載の12.04(64bit)は内蔵GPUに負荷をかけるとフリーズするらしく、
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/999910
に記載されています。

私が使い始めた時には12.04.1LTS(64bit)がリリースされていたので、一応カーネルのバージョンを調べてみると、
3.2.0-30-generic
でした。これは対策済みのバージョンなのでしょうか?

10年ほど使い続けてきたWindows MeがInternet Explorer 6に対応できず、戦力外通告を出す結果となりました。
Meでフリーズは日常茶飯事だったので、フリーズ頻度は断然12.04.1の方が低いのですが、
Linux初心者としてはパッケージのアップデート、またはダウンロード中にフリーズすると、
システムファイルが壊れる恐れが有るのではと、不安を感じています。

https://forums.ubuntulinux.jp/viewtopic.php?pid=93731
上記のページも拝見させていただきました。
近々12.10がリリース予定で、対策が施される可能性が有るとの事。

Windows95→Me→7(32bit)即死→Ubuntu12.04.1LTS(64bit)
と、4台目のPCでOSには疎いのですが、アドバイスなどをいただければ幸いです。
よろしくお願い致します。

オフライン

 

#2 2012-09-10 18:02:38

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: Bug#999910は12.04.1LTSで改善?

Intel Ivy-Brige i7 3770 + Asrock Z77Pro4-Mで、Ubuntu12.04 64ビットデスクトップ版使ってます。
Ubuntu12.04初期は、そこそこ問題でましたので、nVidiaのグラボ付け、しのいでました。
最近また、他のPCをチェックするためグラボを外し、また、Intel グラフィックで使い始めましたが、問題は出ないようです。
(ただし、小生の使い方は、グラフィックを酷使するような使い方はしていません)

> Linux初心者としてはパッケージのアップデート、またはダウンロード中にフリーズすると、システムファイルが壊れる恐れが有るのではと、不安を感じています。
今時のPCは、パッケージのアップデート、やダウンロードでは、大した負荷はかかりません。
(同時に、Firefoxで、HD Flash動画をフル画面で見ながら、表計算ソフトで大量のデータ処理をさせる、みたいなことすれば、別かもしれませんが)

オフライン

 

#3 2012-09-10 19:25:59

futatsuya710
メンバ
登録日: 2012-08-27

Re: Bug#999910は12.04.1LTSで改善?

si様、メッセージありがとうございます。

最近nVidiaのグラボはGTX600シリーズのラインナップが増えてきたので、
空いているPCIeへの増設も考えています。
しかしLinuxのドライバインストールの仕方が分からず、購入できずにいます。
一応、nVidiaのホームページから、Linux64bit用のドライバがダウンロード可能な事は確認しました。
Linuxはデバイスを設置した後、ドライバをインストールする物だと、勝手に思い込んでいるのですが、
グラフィック関係だと、モニタ出力はどうなるのでしょうか?
今、マザーボードは同じZ77を使用しておりますので、グラボを増設した場合、
画像出力がZ77のバックパネルと、グラボの二系統になります。
先にドライバをインストールして大丈夫なのか知識が無く、
またデバイスを先に設置しても、動作不具合が起きる気がします。

テーマから話がそれてしまいましたが、ご助言をいただければと思います。

オフライン

 

#4 2012-09-10 21:45:08

makopi
メンバ
登録日: 2009-11-01

Re: Bug#999910は12.04.1LTSで改善?

自分の場合、
Intel i7-3770K + ASUS P8Z77-V + ASUS (Nvidia GT640) のグラボ + ディスプレイ一台で使っています。

Nvidia の driver を使うつもりでしたら、

1.ドライバーをダウンロードしてください。自分の場合、ホームディレクトリーに置いています。
 ファイル名は例えば NVIDIA-Linux-hoge.run としておきます。便宜置き換えてください。

2.グラボとディスプレイをつけてください。

3.電源を入れてBIOSが表示されるか確認してください。
 自分の場合グラボだけで4系統あるのですがその内、HDMI と DVI では表示を確認しています。(BIOSの設定変更はしていません。)
 マザボの方は確認していません。

4.Ubuntu を起動して端末を開きます。

5.端末上で
  sudo /etc/init.d/lightdm stop
  実行すると画面が真っ黒になります。

6.Control + ALT + F1 キーを3つ同時押し。
  CLI のログイン画面になるのでユーザー名とパスワードを入力。

7.そのまま
  sudo sh NVIDIA-Linux-hoge.run
  あとは確認事項に答えていきます。

8.終わったら再起動。
  sudo reboot

これで自分の環境ではHDで表示されました。(これはメモと記憶を元に書いています。)
この方法で注意する事は kernel がアップデートする度にドライバーをインストールしなければならない事です。

オフライン

 

#5 2012-09-10 22:19:27

futatsuya710
メンバ
登録日: 2012-08-27

Re: Bug#999910は12.04.1LTSで改善?

makopi様、分かりやすいご説明を、ありがとうございます。
特にカーネルは、Windowsを使い続けていた私には盲点でしたので、勉強になりました。
近いうちに試してみたいと思います。

オフライン

 

#6 2012-09-11 00:14:38

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: Bug#999910は12.04.1LTSで改善?

futatsuya710 による投稿:

最近nVidiaのグラボはGTX600シリーズのラインナップが増えてきたので、
空いているPCIeへの増設も考えています。
しかしLinuxのドライバインストールの仕方が分からず、購入できずにいます。
一応、nVidiaのホームページから、Linux64bit用のドライバがダウンロード可能な事は確認しました。

nVIdiaとAMDのグラボ・ドライバは、メニューの「システム設定」->「追加のドライバ」からインストールできます。
AMD Radeonで64ビット版は、インストールや使用上でトラブルことが多いので、あまりお薦めできませんが、nVIdiaなら、新しいグラフィック・チップ対応のドライバを入れたい場合を除き、これで良いと思います。
(最近、新規インストールしてないので、現状、ノートラブルでドライバ・インストールできるかは保証できませんが)

また、Ubuntuには、開発者やテスター向けの、PPAという、パッケージ公開の場があり、そこには比較的新しいドライバがアップされています。
私は、そこの X Updates を使っています。

オフライン

 

#7 2012-09-11 12:53:17

futatsuya710
メンバ
登録日: 2012-08-27

Re: Bug#999910は12.04.1LTSで改善?

si様、アドバイスありがとうございました。

Personal Package Archivesのページを拝見致しました。
developmentでしたが、12.10のドライバまで登場しているんですね。

X Updatesのページですが、
nvidia-graphics-drivers 304.43-0ubuntu1~**~xup1
が該当するのでしょうか?
また**の部分にprecise,oneiric,natty,lucidと4種類あるのですが、どれを選んだ方が良いのでしょうか?
下の方にもnvidia-settingが同じく4種類あり、これもやはり必要なのでしょうか?
マニュアル無しの作業ですので、ご助言いただけますと助かります。

googleからこのページを見ようとして、2度フリーズしました。他は何も使っていません。
インターネットは無線LANを使ってつないでいるのですが、画面右上の扇形の受信表示が通常で2つ、
たまに1つまで落ちる事が有ります。
必ず新しいページへリンクし始める瞬間に固まるので、
バリ3で使っていないために、通信不具合からフリーズするのかなとも思い始めました。

オフライン

 

#8 2012-09-11 13:30:09

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: Bug#999910は12.04.1LTSで改善?

futatsuya710 による投稿:

また**の部分にprecise,oneiric,natty,lucidと4種類あるのですが、どれを選んだ方が良いのでしょうか?
下の方にもnvidia-settingが同じく4種類あり、これもやはり必要なのでしょうか?

Ubuntuのリポジトリ(パッケージ配布場所)、パッケージ管理に慣れると何のことも無いのですが、知らないと訳分からんですよね。
precise,oneiric,natty,lucidというのは、Ubuntu各バージョンのニックネームで、12.04はpreciseです。
ppaのパッケージを使う方法は、ppa各ページの上の方に、「Adding this PPA to your system」のタイトルで説明があるように、
まず、リポジトリを自分のUbuntuに登録します。
あとは、通常通り、リポジトリデータの再読み込み、更新を行えば、目的のパッケージをインストールすることができるようになります。
つまり、パッケージ管理システムが、よしなに事を運んでくれるということです。
このあたりが、フリーウェアの集合体である、Linuxディストリビューションのメリットですよね。

具体的に「ppa:ubuntu-x-swat/x-updates」で、例をとると

コード:

## リポジトリ登録
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
### 途中、「Enter」キーの入力を促される ###
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install <インストールしたいパッケージ>

######
脱線しますが、お薦めのppa
ppa:ikoinoba/ppa : mozcの更新を追いかけてくれている
ppa:stebbins/handbrake-snapshots : 簡単にmp4動画に変換してくれる(開発版)
ppa:stebbins/handbrake-releases : 上記のリリース版

オフライン

 

#9 2012-09-11 13:40:36

si
メンバ
From: hokkaido kitami, jp
登録日: 2007-01-15

Re: Bug#999910は12.04.1LTSで改善?

futatsuya710 による投稿:

googleからこのページを見ようとして、2度フリーズしました。他は何も使っていません。
インターネットは無線LANを使ってつないでいるのですが、画面右上の扇形の受信表示が通常で2つ、
たまに1つまで落ちる事が有ります。
必ず新しいページへリンクし始める瞬間に固まるので、
バリ3で使っていないために、通信不具合からフリーズするのかなとも思い始めました。

パッケージのインストール、アップデート時に、フリーズすると、面倒なことになりかねませんので、極力、安定したネット状況で行った方が良いと思います。
無線lanの場合、接続が不安定になるというようなスレッドが、最近、散見されますので、このフォーラム内を検索し、ご自分の環境と似た状況がないか確認してみては如何でしょうか?

オフライン

 

#10 2012-09-11 15:24:26

futatsuya710
メンバ
登録日: 2012-08-27

Re: Bug#999910は12.04.1LTSで改善?

si様、重ね重ねアドバイスをいただき、ありがとうございます。
X Updatesについてご説明いただき、またまた勉強になりました。
また、お勧めのPPAもありがとうございました。

無線LANですが、生活上不便が出ない条件で、親機をできるだけ自分のPCに近付けただけでは、アンテナ1本でしたので、
アンテナの角度を調整して、やっと2本になっています。
通信速度ですが、フレッツ光なのに1~2Mbpsという貧弱さで、確かにこれが原因かも知れません。
ちなみに親機のスペックはn,g,bの450Mbps、子機は同じくn,g,bで150Mbpsです。
「Ubuntu Magazine Japan vol.6」で簡単に接続できたというBuffaloの「WLI-UC-GNM」を採用した所、
確かに簡単につながりはしました。
最近は強力なa波が登場しているみたいですが、田舎の木造一戸建てではa波無しで遠くの部屋まで受信できたので、
勝手にa波不要と判断してしまいました。
しかし、やはりマンションでは障害が多すぎるのでしょうか。
次は、無線受信の対策を練ってみます。

オフライン

 

#11 2012-09-11 15:29:30

hito
管理者
登録日: 2007-03-18

Re: Bug#999910は12.04.1LTSで改善?

futatsuya710 による投稿:

Firefoxでたまにフリーズするので、ネットで調べてみると、Ivy-Brige搭載の12.04(64bit)は内蔵GPUに負荷をかけるとフリーズするらしく、
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/999910
に記載されています。

私が使い始めた時には12.04.1LTS(64bit)がリリースされていたので、一応カーネルのバージョンを調べてみると、
3.2.0-30-generic
でした。これは対策済みのバージョンなのでしょうか?

端的には、12.04の現状は以下の通りです。
 ・「ひとまず」の対策が入っています。
 ・レアケースの不具合がまだ残っています。
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1034358

いずれも12.10では直っています。

で、お手元の現象がFirefoxに限定されるようであれば、ヘタにGPUを足す
のではなく、Firefoxの「編集」-「設定」-「詳細」を開いて、
「ハードウェアアクセラレーション機能を使用する」をオフにしておく、
というのがいいように思います。

なお、最新世代の(というかFermi以降の)NVIDIAドライバまわりは茨の道
が待っていたりするので、もし買い足すのであれば2xx世代のものか、あるいは
AMDのGPUを確保するのがいいような気がします。ただ、一般的なデスクトップ
用途ではIvyBridge世代の内蔵GPUでも充分なので、うまく問題を回避しながら
待つ、というのがベストな気はします。

オフライン

 

#12 2012-09-11 15:45:33

futatsuya710
メンバ
登録日: 2012-08-27

Re: Bug#999910は12.04.1LTSで改善?

hito様、バグに関する情報を示していただき、ありがとうございます。
ご案内いただいた通り、「ハードウェアアクセラレーション機能を使用する」をオフにしてみました。
これで、しばらく様子を見てみたいと思います。
加えて、12.10という方向を示していただけたので、安心しました。

オフライン

 

Board footer

Powered by FluxBB