お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2009-11-08 09:03:18

pakn
メンバ
登録日: 2009-11-03

adebe flash player plugin がインストールできません

1週間も経っていない初心者です。
環境:ubuntu 9.10 firefox 3.5.4

firefoxにてyoutubeの動画を見ようとすると上記プラグインのインストールを求められ
install_flash_player_10_linux.deb をインストールしようとすると多分?別のパッケージを
先に適用するように求められるまま実行したのですが、「install_flash_player_10_linux.debを開けません」
このパッケージは壊れているか開くことができません。このファイルのパーミッションを確認してください。
とパッケージ・インストーラがエラーとなります。
又、アップデートマネージャでは「一部のアップデータだけがインストール可能です」→アップグレード→
adebe-flashpluginは矛盾した状態にあり再インストールが必要ですが、そのためのアーカイブを見つける
ことができません。このパッケージを削除して先に進めますか?→はい→「矛盾した状態のパッケージ」
再インストールのためのアーカイブが見つからない。パッケージを手動で再インストールするか、システム
からパッケージを削除してください。
「パッケージの整理」でもえらーが発生して削除できません。
install_flash_player_10_linux.debのパーミッションも問題ありませんでした。

1。何でこのようになったのか?
2。手動での再インストール方法
3。システムからパッケージを削除する方法

2と3だけでもどなたかアドバイスいただけませんか?

オフライン

 

#2 2009-11-08 13:43:24

koisan1949
メンバ
From: Hyogo, Japan
登録日: 2007-11-11

Re: adebe flash player plugin がインストールできません

paknさん 理由は私もわかりません。
Debianパッケージ情報がエラーとなってるようです。一般的な対処方法はコマンドモードでする必要があります。
アプリケーション → アクセサリ → 端末 で、gnome端末がオープンします。
 まず、パッケージ情報の更新をしてみてください。
~$ sudo apt-get update <Enterキー>
  何がしかのパッケージっc表示されるはずです。

 あまり有益な情報がないときは、エラーの対処をする必要があります。
~$ sudo dpkg --audit <Enterキー>
 表示された内容をcopy $ past して貼り付けてください。
  やり方は、マウスで必要箇所をドラッグして、Shift+Ctrl+Cキーを同時に押すとコピーされます。
  それから、「このトピックに返事を投稿」欄へ、Ctrl+Vキーでペーストしてください。
  (これらは、ファイルの隣にある編集のメニューででもできます。)

普通は、このコマンドにより提示された指示に従えば解決できると思います。
~$ sudo dpkg --configure <パッケージ名> <Enterキー>

これでダメなときは、
~$ sudo dpkg --configure --pending <Enterキー>

これらを実行してもうまくいかなかった場合、取り敢えず削除して、再インストールしてください。
~$ sudo dpkg --remove  <パッケージ名> <Enterキー>

adobeのホームで、http://get.adobe.com/jp/flashplayer/Debianパッケージをdownloadしてください。
 「ダウンロードするバージョンを選択してください。」をクリックし、
 Ubuntu8.04+用 debファイル を選択指定すれば、downloadが開始されます。
これで修復すると思いますが。。。

オフライン

 

#3 2009-11-08 14:50:32

pakn
メンバ
登録日: 2009-11-03

Re: adebe flash player plugin がインストールできません

koisan1949さん
アドバイスありがとうございます。
結果としてはダメでした。
$ sudo dpkg --configure adobe-flashplugin
dpkg: adobe-flashplugin の処理中にエラーが発生しました (--configure):
パッケージが非常に矛盾した状態に陥りました。設定を試みる
前に再インストールすべきです。
以下のパッケージの処理中にエラーが発生しました:
adobe-flashplugin

$ sudo dpkg --audit
以下のパッケージはインストール中に重大な問題が発生したため混乱しています。
これらのパッケージ (とこれらに依存するパッケージ) が正しく動作するために
は、以下のパッケージを再インストールしなければなりません:
adobe-flashplugin    Adobe Flash Player plugin version 10

$ sudo dpkg --remove adobe-flashplugin
dpkg: adobe-flashplugin の処理中にエラーが発生しました (--remove):
パッケージが非常に矛盾した状態に陥りました。
削除を行う前にこのパッケージを再インストールすべきです。
以下のパッケージの処理中にエラーが発生しました:
adobe-flashplugin

よろしくお願いします。

オフライン

 

#4 2009-11-08 15:50:39

petitbootang
メンバ
From: 東京都
登録日: 2009-02-12

Re: adebe flash player plugin がインストールできません

http://d.hatena.ne.jp/tanzen/20091025/1256563955
もしかしたら ↑ こちらが参考になるかもしれません。
あと、flashplugin や adobereader などは日本語環境セットアップヘルパからインストールした方が無難です。
adobe のバイナリを使うとインストールには成功しても、うまく firefox のプラグインに登録されなかったりすることもあるので。

オフライン

 

#5 2009-11-08 15:51:45

koisan1949
メンバ
From: Hyogo, Japan
登録日: 2007-11-11

Re: adebe flash player plugin がインストールできません

ダメでしたか。私の場合、貴君の様なエラーに遭遇した経験がないため、申し訳ないです。
具体的にこうすれば修復できると明確に示せません。
さて、問題ない私のadobe-flashpluginのパッケージ情報は、Ubuntu9.10 において下記が結果です。
~$ sudo apt-cache show adobe-flashplugin

Package: adobe-flashplugin
Status: install ok installed
Priority: optional
Section: web
Installed-Size: 10120
Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
Architecture: i386
Version: 10.0.32.18-1
Replaces: flashplugin (<< 6)
Provides: flashplugin-nonfree
Depends: debconf | debconf-2.0, wget, fontconfig, libnspr4-dev, libnss3-dev, libcurl3, libatk1.0-0 (>= 1.13.2), libc6 (>= 2.6-1), libcairo2 (>= 1.4.0), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.2.1), libglib2.0-0 (>= 2.14.0), libgtk2.0-0 (>= 2.12.0), libpango1.0-0 (>= 1.18.3), libstdc++6 (>= 4.2.1), libx11-6, libxext6, libxt6
Suggests: firefox, konqueror-nsplugins, x-ttcidfont-conf, msttcorefonts, ttf-bitstream-vera | ttf-dejavu, ttf-xfree86-nonfree, xfs (>= 1:1.0.1-5)
Conflicts: flashplugin (<< 6), xfs (<< 1:1.0.1-5), flashplayer-mozilla
Description: Adobe Flash Player plugin version 10
This package will download the Flash Player from Adobe. It is a
Netscape/Mozilla type plugin. Any browser based on Netscape or Mozilla can use
the Flash plugin. This package officially supports the following browsers:
.
Firefox 2.x, Firefox 3.x, SeaMonkey 1.11
Original-Maintainer: DL-Flash Player Ubuntu <FlashPlayerUbuntu@adobe.com>

まず、パッケージキャッシュのクリアを実効。
~$ sudo apt-get autoclean
それから、adobe-flashpluginの完全削除。
~$ sudo apt-get --purge remove adobe-flashplugin

このとき、エラーが出たら、次のコマンドは操作しても無駄です。
エラーの内容を貼り付けてください。
~$ sudo apt-get install adobe-flashplugin
~$ sudo apt-get update

オフライン

 

#6 2009-11-08 17:05:12

pakn
メンバ
登録日: 2009-11-03

Re: adebe flash player plugin がインストールできません

koisan194さん>やっぱりだめでした。
petitbootangさん>http://d.hatena.ne.jp/tanzen/20091025/1256563955
で解決しました。ありがとうございます。映像も音声も再生できました。

因みに、コマンドの解説など分かりましたらよろしくお願いします。
1。rm /var/lib/dpkg/info/adobe-flashplugin.prerm
  /var/lib/dpkg/info/ にパッケージ情報が格納されていて該当をremoveした?
2。dpkg --remove --force-remove-reinstreq adobe-flashplugin
  これもパッケージ情報の削除に相当するのですよね?

この2つのコマンドがエラーメッセージで指示された「システムからパッケージを削除する」
に当たる訳ですよね?

オフライン

 

#7 2009-11-08 17:08:50

koisan1949
メンバ
From: Hyogo, Japan
登録日: 2007-11-11

Re: adebe flash player plugin がインストールできません

petitbootangさん が提示された対処方法でOKと思います。
そこで、蛇足ですが補足説明をしてみます。
1. Debian系Linuxの/varディレクトリ
 /var/lib/dpkg/info/  インストール済みパッケージのファイルリストが格納されている
2. $ sudo rm /var/lib/dpkg/info/adobe-flashplugin.prerm
 パッケージ情報が矛盾した状態になっているので、このadobe-flashpluginのリストを削除
3. $ sudo dpkg --remove --force-remove-reinstreq adobe-flashplugin

詳細
 例) Status: install ok installed   ... 3つの状態を記録しているフィールド
        選択状態, フラグ, インストール状態
 「パッケージのインストール状態には、dpkgにより6つの状態として管理されている」
  installed      インストール済みである
  half-installed   インストール作業は開始されたが、何らかの理由で完了していない
  non-installed   パッケージがインストールされていない
  unpacked     展開されたが設定がされていない
  half-configured  何らかの理由で設定作業が完了していない
  config-files    設定ファイルのみ残された状態

 また、「選択状態」
  install   cがインストールされることを示す
  deinstall  パッケージの設定ファイルを残して削除されることを示す
  purge   パッケージが完全に削除されることを示す
  hold    更新を行わないことを示すことを示すことを示すことを示すことを示す

--force-remove-reinstreqオプションを指定することで、壊れたパッケージを削除し、
   reinstreq により、再インストールのリクエスト(指定)を提示しています。
  技術評論社 「入門 Debian パッケージ」 の185pageに、記載されていました。
  この方法でのみ、対処できるようです。

オフライン

 

Board footer

Powered by FluxBB