お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2009-12-08 16:56:44

田んぼのトンボ09
新しいメンバ
登録日: 2009-05-22

9.10でsambaが起動時に立ち上がらない。

ubuntu の9.04からアップデート(アップグレード)して9.10を使用しています。
sambaで他のwin機のデータのバックアップ用として稼働しています。カーネル
をアップデートして2.6.31-16とそれ以前の2.6.31-15にしてからだと思いますが、
朝のPC起動時にsambaが自動起動しなくなりました。システム>設定>自動起動す
るアプリではsambaが起動する設定になっています。過去ログをみて、一度削除し
て再起動の上また設定して見たりしましたが、2.6.31-16になってからは立ち上がり
時にsambaは起動していません。
またこれも過去ログを見て、#sudo sysv-rc-conf.なども確認しましたがrunlebel
2.3.4.5は設定されていました。

端末から下記のように打つと
# /etc/init.d/samba restart
* Stopping Samba daemons
start-stop-daemon: warning: failed to kill 969: No such process   [ OK ]
* Starting Samba daemons                                                [ OK ]
と出ますので、sambaは起動時に働いていないようです。
上記の端末の操作を行うと他のwin機からubuntsの共用が可能になります。
毎回端末から起動していますが、pc起動時にsambaが機能する設定方法をお教えいた
だけるとありがたく思います。

オフライン

 

#2 2009-12-08 23:26:40

knxg9001
メンバ
From: Gifu
登録日: 2008-02-27

Re: 9.10でsambaが起動時に立ち上がらない。

とりあえず、リリースノートを読んで下さい。
sysv-rc-confやrun levelといった難しいことはわかりませんが、これとは別の問題でしょうか?

オフライン

 

#3 2009-12-09 11:31:31

田んぼのトンボ09
新しいメンバ
登録日: 2009-05-22

Re: 9.10でsambaが起動時に立ち上がらない。

knxg9001さん 

書き込みありがとうございます。リリースノートは気がつきませんでした。
端末でsudo service samba restartとして、念のためと思いubuntsを再起動しました。
win機で起動時からubuntsを認識してくれるようになりました。お手数をお掛けしました。
既知の問題だったのですね。9.10にアップグレードしたときにはsambaでつまずいた記憶が
無いような気がしていたのかもしれません。重ねてありがとうございます、大変助かりました。

オフライン

 

#4 2009-12-09 12:13:05

knxg9001
メンバ
From: Gifu
登録日: 2008-02-27

Re: 9.10でsambaが起動時に立ち上がらない。

田んぼのトンボ09さん による投稿:

端末でsudo service samba restartとして、念のためと思いubuntsを再起動しました。

これは、今までなのか、リリースノート読んだ後なのか、どちらですか?
後者なら、「システムの起動時にSambaが起動しないこともある」をSambaの再起動後、システムの再起動しては意味ないですよね。

オフライン

 

#5 2009-12-09 15:19:29

田んぼのトンボ09
新しいメンバ
登録日: 2009-05-22

Re: 9.10でsambaが起動時に立ち上がらない。

knxg9001さん による投稿:

これは、今までなのか、リリースノート読んだ後なのか、どちらですか?
後者なら、「システムの起動時にSambaが起動しないこともある」をSambaの再起動後、システムの再起動しては意味ないですよね。

お教えいただいたリリースノートを読んでから端末の操作をして、今後システム起動時にSambaが
起動するか確認するつもりで再起動しました。打ち込んだコマンドの意味を理解していないので、
sudo service samba restartと打ち込んだのは、今後システム起動時にSambaのサービスを自動
起動するコマンドと勝手に思い込んでいます。

オフライン

 

#6 2009-12-12 01:37:22

knxg9001
メンバ
From: Gifu
登録日: 2008-02-27

Re: 9.10でsambaが起動時に立ち上がらない。

今正常ならいいんじゃないでしょうか。必ず起きる問題ではない(失敗する可能性がある)みたいですから。

オフライン

 

#7 2009-12-12 17:35:05

田んぼのトンボ09
新しいメンバ
登録日: 2009-05-22

Re: 9.10でsambaが起動時に立ち上がらない。

knxg9001さん

いろいろ教えていただき、おかげさまで今のところシステム起動時にSambaが毎回
立ち上がっています。自身ではあまり理解せず、分かる人からみると無鉄砲な操作
をしたのかも知れませんが、正常に機能しているようですので助かりました。
ありがとうございました。

オフライン

 

#8 2009-12-12 23:29:40

knxg9001
メンバ
From: Gifu
登録日: 2008-02-27

Re: 9.10でsambaが起動時に立ち上がらない。

コード:

$ sudo service samba status
 [color=#FF0000]*[/color] nmbd is not running
 * smbd is running

本日何度目かのこの状態に遭遇ました。Good Luck!

オフライン

 

#9 2009-12-12 23:58:18

knxg9001
メンバ
From: Gifu
登録日: 2008-02-27

Re: 9.10でsambaが起動時に立ち上がらない。

#8の訂正

コード:

$ sudo service samba status
 * nmbd is not running
 * smbd is running

# コード内でカラーが使えませんでした。

オフライン

 

Board footer

Powered by FluxBB