お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2007-10-17 21:21:04

bunbun
メンバ
登録日: 2007-10-17

gnuplotがインストールできません。

$ sudo dpkg --install gnuplot_4.0.0-2.1_all.deb

と入力しましたが、エラー

(gnuplot_4.0.0-2.1_all.deb から) gnuplot を展開しています...
dpkg: 依存関係の問題により gnuplot の設定ができません:
gnuplot は以下に依存(depends)します: gnuplot-nox (= 4.0.0-2.1) ...しかし:
  パッケージ gnuplot-nox はインストールされていません。
gnuplot は以下に依存(depends)します: gnuplot-x11 (= 4.0.0-2.1) ...しかし:
  パッケージ gnuplot-x11 はインストールされていません。
dpkg: gnuplot の読み込みエラーです(--install):
依存関係の問題 - 設定を見送ります。

となり、上記にある依存関係の問題の解決方法がわかりません。
ちなみに、このパッケージはubuntu -- Package Download Selectionからdownload
しました。
 このエラーの後、

$gnuplot

とすると、gnuplotの画面はでますが、

Terminal type set to 'unknown'

となり、関数をplotしても関数は画面に表示されません。
おそらく 'unknown'の部分が'X11'になると思うのですが、どうなのでしょうか?

 わかりにくい質問だと思いますが、どうしてもgnuplotを使用したいのです。何か教えて頂けることがありましたら、よろしくお願いします。

オフライン

 

#2 2007-10-17 21:24:26

mizuno
管理者
From: Kyoto
登録日: 2007-02-28

Re: gnuplotがインストールできません。

sudo apt-get install gnuplot
としてください。
依存関係が自動的に解決されてインストールが行われます。私の環境では追加で
gnuplot-nox gnuplot-x11 libgd2-noxpm
の三つがインストールされました。

オフライン

 

#3 2007-10-17 22:33:16

bunbun
メンバ
登録日: 2007-10-17

Re: gnuplotがインストールできません。

mizuno  様

早急な投稿ありがとうございます。
教えて頂いた通りに行いましたところ、

usr1@usr1-desktop:~$ sudo apt-get install gnuplot
Password:
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています... 完了
パッケージ gnuplot はデータベースには存在しますが、利用できません。
おそらく、そのパッケージが見つからないか、もう古くなっているか、
あるいは別のソースからのみしか利用できないという状況が考えられます
E: パッケージ gnuplot にはインストール候補がありません

となってしまいます。
私はubunto 6.06を使用していますが、それと何か関係があるのでしょうか?

他にも
gd1.4.tar.gz
gnuplot-4.0.0.tar.gz
でインストールを試みましたがうまくいきませんでした。

オフライン

 

#4 2007-10-17 22:48:28

mizuno
管理者
From: Kyoto
登録日: 2007-02-28

Re: gnuplotがインストールできません。

こちらは 7.10 の環境で試したため、バージョンに起因する問題でしたら申し訳ありませんが解かりません。
とにかくどうしても gnuplot が必要なのであれば、2,3日中にリリースされる 7.10 をインストールしてみるのが早いかもしれません。

オフライン

 

#5 2007-10-17 22:49:36

anoir
モデレータ
From: Berkeley, CA
登録日: 2007-01-13

Re: gnuplotがインストールできません。

6.06でもgnuplotパッケージは存在します。

http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=gnuplot&searchon=names&subword=1&version=dapper&release=all

Universeは有効になっていますか?シナプティックのメニューなどから確認してください。

オフライン

 

#6 2007-10-17 23:26:20

bunbun
メンバ
登録日: 2007-10-17

Re: gnuplotがインストールできません。

mizuno 様

 投稿ありがとうございます。
anoir 様からuniverseの確認を、という情報を頂いたのでまずはこの確認を行いたいと
思います。また、投稿した際には御指導お願いします。

オフライン

 

#7 2007-10-17 23:35:46

bunbun
メンバ
登録日: 2007-10-17

Re: gnuplotがインストールできません。

anoir 様

 投稿ありがとうございます。
universeの確認を、と教えていただいたのですが、具体的にはどのような設定を
行えばよいのでしょうか?

Synapticでリポジトリの設定から
[インストールメディア]で、Ubuntu 6.06 LTS (Binary) コミュニティによるメンテナンス(Universe)
[インストールメディア]で、Ubuntu 6.06 LTS (Source) コミュニティによるメンテナンス(Universe)

を設定すればよいのでしょうか?また、どのように設定すればよいのでしょか?
 御返答お願いたします。

オフライン

 

#8 2007-10-17 23:50:42

RxOrca
メンバ
登録日: 2007-03-02

Re: gnuplotがインストールできません。

bunbun による投稿:

$ sudo dpkg --install gnuplot_4.0.0-2.1_all.deb

と入力しましたが、エラー

(gnuplot_4.0.0-2.1_all.deb から) gnuplot を展開しています...
dpkg: 依存関係の問題により gnuplot の設定ができません:
gnuplot は以下に依存(depends)します: gnuplot-nox (= 4.0.0-2.1) ...しかし:
  パッケージ gnuplot-nox はインストールされていません。
gnuplot は以下に依存(depends)します: gnuplot-x11 (= 4.0.0-2.1) ...しかし:
  パッケージ gnuplot-x11 はインストールされていません。
dpkg: gnuplot の読み込みエラーです(--install):
依存関係の問題 - 設定を見送ります。

もしかすると gnuplotはインストール済みってことになってるのではないでしょーか。(設定はエラーだけど)
なので
sudo dpkg -r  gnuplot でいったん削除してみるとか。

オフライン

 

#9 2007-10-18 12:43:04

bunbun
メンバ
登録日: 2007-10-17

Re: gnuplotがインストールできません。

RxOrca 様

 投稿してくださってありがとうございます。
教えて頂いたコマンド打ちましたところ、インストールはされていなかったようです。

オフライン

 

#10 2007-10-18 12:48:36

bunbun
メンバ
登録日: 2007-10-17

Re: gnuplotがインストールできません。

 なんとかuniverseを有効にしてgnuplotをインストールできました。
追加で

gnuplot-nox gnuplot-x11

がインストールされgnuplotを実行しましたが、

Terminal type set to 'unknown'

となり、'X11'となりません。私なりに調べいるところですが、
他にインストールするものがあるのか、設定方法等教えて頂けることが
ありましたらよろしくお願いします。

オフライン

 

#11 2007-10-18 15:45:31

bunbun
メンバ
登録日: 2007-10-17

Re: gnuplotがインストールできません。

ありがとうございました。

 なんとかgnuplotが動くようになりました。
universeを有効にした後、

Terminal type set to 'unknown'

となったため、原因はxが起動していないのかと思い/etc/X11/xorg.confを編集して
みたのですがうまくいかず、もとに戻し検索しいると

plotulis package

の必要性がみえてきたので、そこをうまくやってなんとか

Terminal type set to 'X11'

となり、図がplotされるようになりました。

 plotulis packageって? な状態なのでこれをチェックしていきたいと思います。


御指導いただいた方、大変ありがとうございました。また、よろしくお願いします。

オフライン

 

#12 2007-10-19 00:40:15

anoir
モデレータ
From: Berkeley, CA
登録日: 2007-01-13

Re: gnuplotがインストールできません。

うちの環境ではセットアップ直後にTerminal typeはX11になっていました。なっていない場合には

set terminal x11

で変更できます。これは単に表示するデバイスを切り替えるだけです。印刷に使うなら

set terminal postscript

にすればpsを出力します。可能なデバイスについては

set terminal

で確認できます。個人的にはプロットにはRを使っていますが。

オフライン

 

Board footer

Powered by FluxBB