お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2015-03-25 18:04:19

cingyan
メンバ
登録日: 2013-09-12

マウスに触れただけでスリープ解除しないようにしたい

自分としてはubuntu初心者のつもりですが、よろしくお願いします。
ubuntu14.10を使っています。デスクトップはLXDEです。

困っていることは、スリープ状態にしても、机にぶつかっただけでマウスが動いてしまいスリープ解除してしまうことです。

調べたところ、
http://www.gembook.org/2012-07-11.html
上記のページに解決策があったのですが、端末で、解説している通りの結果が出ないので、問題解決に至らないという状態です。

端末で実行したことを載せます。長いのですがご了承ください。関係ないと思われる出力は省略します。

$ sudo lsinput
[sudo] password for :
/dev/input/event3
   bustype : BUS_I8042
   vendor  : 0x2
   product : 0x5
   version : 0
   name    : "ImPS/2 Generic Wheel Mouse"
   phys    : "isa0060/serio1/input0"
   bits ev : EV_SYN EV_KEY EV_REL

$ cat /proc/acpi/wakeup
Device    S-state      Status   Sysfs node
SLPB      S4    *enabled   platform:PNP0C0E:00
P32      S4    *disabled  pci:0000:00:1e.0
UAR1      S4    *disabled  pnp:00:06
PEX0      S4    *disabled  pci:0000:00:1c.0
PEX1      S4    *disabled
PEX2      S4    *disabled  pci:0000:00:1c.2
PEX3      S4    *disabled  pci:0000:00:1c.3
PEX4      S4    *disabled  pci:0000:00:1c.4
PEX5      S4    *disabled  pci:0000:00:1c.5
UHC1      S3    *enabled   pci:0000:00:1d.0
UHC2      S3    *enabled   pci:0000:00:1d.1
UHC3      S3    *enabled   pci:0000:00:1d.2
UHC4      S3    *enabled   pci:0000:00:1d.3
EHCI      S3    *enabled   pci:0000:00:1d.7
AC9M      S4    *disabled
AZAL      S4    *disabled  pci:0000:00:1b.0

ここまで来て、ノードpciが分からない状態でつまづきました。

次にこの操作をしました。
$ sudo lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 01)
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GH (ICH7DH) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 RAID bus controller: Intel Corporation 82801GR/GDH (ICH7R/ICH7DH) SATA Controller [RAID mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
06:01.0 Communication controller: Conexant Systems, Inc. Device 2f40
06:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 01)

私としては、これを見ても分からず、対処ができません。
今後、どのようにすれば良いかご教示ください。

パソコンは、emachines J3228
マウスは、PS/2接続で、購入時に付属していた物です。
長くなりましたが、よろしくお願いします。

オフライン

 

#2 2015-04-19 22:58:34

udooon
メンバ
登録日: 2012-01-24

Re: マウスに触れただけでスリープ解除しないようにしたい

https://wiki.archlinux.org/index.php/Pm-utils#Advanced_configuration
/usr/lib/pm-utils/defaults を
/etc/pm/config.d/ にコピーして、修正。

38行目辺り

# SUSPEND_MODULES=""


SUSPEND_MODULES="psmouse"

に修正。

オフライン

 

#3 2015-04-20 17:52:39

cingyan
メンバ
登録日: 2013-09-12

Re: マウスに触れただけでスリープ解除しないようにしたい

回答ありがとうございました。
結果は、ダメでした。

端末から、sudoでコピーしたファイルをsudo geditでファイルを開き、編集し、再起動し、サスペンドを実行し、マウスを動かすと復帰してしまいました。

udooon様から示されたリンク先を確認してみましたが、英語読解力が乏しく理解できませんでした。翻訳しても同様です。

回答から見るとできそうな感じでしたが、何故かうまくいきません。

オフライン

 

#4 2015-04-21 12:19:48

udooon
メンバ
登録日: 2012-01-24

Re: マウスに触れただけでスリープ解除しないようにしたい

違っていたようなので、作ったファイルは削除するか、コメントアウトしておいてください。

BIOSで設定できないか確認した上で、下記を試してみればどうでしょうか。

http://blog.abhijeetr.com/2010/03/disable-wakeup-through-mouse-ps2-on.html

SLPB      S4    *enabled   platform:PNP0C0E:00

これを、disabledにすればどうでしょうか。
キーボードによる復帰もできなくなるかもしれませんが、その時は電源ボタンで復帰してみてください。

オフライン

 

#5 2015-04-21 18:08:21

cingyan
メンバ
登録日: 2013-09-12

Re: マウスに触れただけでスリープ解除しないようにしたい

回答ありがとうございました。

BIOSに設定できそうな項目は見当たりませんでした。

SLPBをdisabledにすると、おっしゃる通り、キーボードでの解除もできませんでした。
電源ボタンで復帰しました。

私としては、Shiftキーなどを押して復帰するのが理想でした。電源ボタンは本体なのでボタンも消耗することを思うとあまり使いたくありません。

USB接続のマウスの購入を検討します。WindowsでもPS/2はダメだったような気がします。USBならできることを願います。

オフライン

 

#6 2019-01-15 18:31:47

freestyle
新しいメンバ
登録日: 2011-10-17

Re: マウスに触れただけでスリープ解除しないようにしたい

USB無線マウス、USBキーボードを使っています。
以下で、うまく行きました。
$ sudo crontab -l
@reboot echo 'disabled' > /sys/bus/pci/devices/0000\:00\:1a.0/power/wakeup
@reboot echo 'disabled' > /sys/bus/pci/devices/0000\:00\:1d.0/power/wakeup

オフライン

 

#7 2019-01-16 15:52:48

cingyan
メンバ
登録日: 2013-09-12

Re: マウスに触れただけでスリープ解除しないようにしたい

いつか忘れましたが、私の最後の投稿以後、USB接続で無線のマウスに変更したら、スリーブ状態で、マウスを動かしてもスリーブ解除しない状態になりました。
キーボードのキーを押すと解除さ理想の状態になりました。
特に設定を行ったことはなかったと思います。

オフライン

 

Board footer

Powered by FluxBB