お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2017-08-06 21:34:11

takumi5417
新しいメンバ
登録日: 2017-08-05

ubuntu14.04上にlibvirt1.3.3 以上をインストールしたい。

ubuntu14.04上のKVMにNVIDIA GPUをパススルーするため
libvirt1.3.3以上をインストールする必要があるのですが、
https://libvirt.org/compiling.html
こちらのサイトを参考にインストールしようとしてみたのですが、
configure: error: You must install device-mapper-devel/libdevmapper to compile libvirt with mpath storage driver
と出てしまいます。 2つとも sudo apt-get install ではインストール出来ず
検索して探してみましたが、インストールできるものは見つかりませんでした。
どなたかインストール方法をご存知でしたら、回答お願いいたします。

ubuntuバージョン 14.04LTS

PCスペック

MB ASRock  Fatal1ty H87 Performance
CPU Core i7 4770
GPU MSI GTX950
RAM DDR3 20GB (8GBx2 4GBx2)

コード:

 [email protected]:~$ virsh version
コンパイル時に使用したライブラリ: libvirt 1.2.2
使用中のライブラリ: libvirt 1.2.2
使用中の API: QEMU 1.2.2
実行中のハイパーバイザー: QEMU 2.9.91

オフライン

 

#2 2017-08-07 09:19:18

limtake
メンバ
From: Japan
登録日: 2012-11-22

Re: ubuntu14.04上にlibvirt1.3.3 以上をインストールしたい。

takumi5417 による投稿:

configure: error: You must install device-mapper-devel/libdevmapper to compile libvirt with mpath storage driver

libdevmapperがないのでコンパイルできない、とエラーが出ているように思います。

$ sudo apt-cache search libdevmapper
でlibdevmapperを探すと、以下の結果のようになったので

コード:

$ sudo apt-cache search libdevmapper 
libdevmapper-dev - Linux Kernel Device Mapper header files
libdevmapper-event1.02.1 - Linux Kernel Device Mapper event support library
libdevmapper1.02.1 - Linux Kernel Device Mapper のユーザ空間ライブラリ

libdevmapper-devパッケージあたりをapt-get install でインストールすると、もしかしてうまく行くかもしれません。

オフライン

 

#3 2017-08-08 02:29:06

takumi5417
新しいメンバ
登録日: 2017-08-05

Re: ubuntu14.04上にlibvirt1.3.3 以上をインストールしたい。

アドバイスありがとうございました。どうやらビルドは成功したみたいです。

コード:

[email protected]:~$ virsh version
コンパイル時に使用したライブラリ: libvirt 3.6.0
使用中のライブラリ: libvirt 3.6.0
使用中の API: QEMU 3.6.0
実行中のハイパーバイザー: QEMU 2.9.91

途中こちらのサイト(https://gist.github.com/sandlbn/997d9b08406128914cce)
に書かれてある手順

sandlbn による投稿:

sudo apt-get install git build-essential xsltproc libxml-xpath-perl libyajl-dev libdevmapper-dev libpciaccess-dev libnl-dev systemtap-sdt-dev uuid-dev libtool autoconf pkg-config libxml2 libxml2-utils autopoint python-dev libnuma-dev gettext
git clone https://github.com/K1773R/numad.git
cd numad
make
sudo make install

とアドバイス通り libdevmapper-dev をインストールしてもビルド出来なかったためエラーから調べ、必要なツール(libxml2-dev  librbd-dev)をインストールすることで、
無事ビルドできたようです。アドバイスありがとうございました。

オフライン

 

Board footer

Powered by FluxBB