お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2019-12-30 16:30:49

tempest
新しいメンバ
登録日: 2019-12-30

【linux初心者】apt-get installできない。

apt-get installを実行すると以下のようなエラーが発生します。
解決方法がわからず困っています。
====================================================================================================================
~$ sudo apt-get install net-tools

パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています               
状態情報を読み取っています... 完了
これらを直すためには 'apt --fix-broken install' を実行する必要があるかもしれません。
以下のパッケージには満たせない依存関係があります:
bind9-host : 依存: libisc169 (= 1:9.11.3+dfsg-1ubuntu1.11) しかし、1:9.11.3+dfsg-1ubuntu1.8 はインストールされようとしています
dnsutils : 依存: libisc169 (= 1:9.11.3+dfsg-1ubuntu1.11) しかし、1:9.11.3+dfsg-1ubuntu1.8 はインストールされようとしています
libbind9-160 : 依存: libisc169 (= 1:9.11.3+dfsg-1ubuntu1.11) しかし、1:9.11.3+dfsg-1ubuntu1.8 はインストールされようとしています
libdns1100 : 依存: libisc169 (= 1:9.11.3+dfsg-1ubuntu1.11) しかし、1:9.11.3+dfsg-1ubuntu1.8 はインストールされようとしています
libirs160 : 依存: libisc169 (= 1:9.11.3+dfsg-1ubuntu1.11) しかし、1:9.11.3+dfsg-1ubuntu1.8 はインストールされようとしています
libisccc160 : 依存: libisc169 (= 1:9.11.3+dfsg-1ubuntu1.11) しかし、1:9.11.3+dfsg-1ubuntu1.8 はインストールされようとしています
libisccfg160 : 依存: libisc169 (= 1:9.11.3+dfsg-1ubuntu1.11) しかし、1:9.11.3+dfsg-1ubuntu1.8 はインストールされようとしています
E: 未解決の依存関係です。'apt --fix-broken install' を実行してみてください (または解法を明示してください)。

~$ sudo apt --fix-broken install

パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています               
状態情報を読み取っています... 完了
依存関係を解決しています ... 完了
以下の追加パッケージがインストールされます:
  libisc169
以下のパッケージはアップグレードされます:
  libisc169
アップグレード: 1 個、新規インストール: 0 個、削除: 0 個、保留: 137 個。
7 個のパッケージが完全にインストールまたは削除されていません。
237 kB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 0 B のディスク容量が消費されます。
続行しますか? [Y/n] y
dpkg: 警告: パッケージ 'bind9-host' のファイル一覧ファイルがありません。このパッケージには、現在インストールされているファイルがないものとします
dpkg: 警告: パッケージ 'libisccc160:amd64' のファイル一覧ファイルがありません。このパッケージには、現在インストールされているファイルがないものとします
dpkg: 警告: パッケージ 'libirs160:amd64' のファイル一覧ファイルがありません。このパッケージには、現在インストールされているファイルがないものとします
dpkg: 警告: パッケージ 'libbind9-160:amd64' のファイル一覧ファイルがありません。このパッケージには、現在インストールされているファイルがないものとします
dpkg: 警告: パッケージ 'dnsutils' のファイル一覧ファイルがありません。このパッケージには、現在インストールされているファイルがないものとします
dpkg: 警告: パッケージ 'libisccfg160:amd64' のファイル一覧ファイルがありません。このパッケージには、現在インストールされているファイルがないものとします
dpkg: 警告: パッケージ 'libdns1100:amd64' のファイル一覧ファイルがありません。このパッケージには、現在インストールされているファイルがないものとします
(データベースを読み込んでいます ... 現在 171811 個のファイルとディレクトリがインストールされています。)
.../libisc169_1%3a9.11.3+dfsg-1ubuntu1.11_amd64.deb を展開する準備をしています ...
libisc169:amd64 (1:9.11.3+dfsg-1ubuntu1.11) で (1:9.11.3+dfsg-1ubuntu1.8 に) 上書き展開しています ...
dpkg-deb (サブプロセス): アーカイブメンバーを伸張しています: lzma エラー: 圧縮データが壊れています
dpkg-deb: エラー: <伸張> subprocess returned error exit status 2
dpkg: アーカイブ /var/cache/apt/archives/libisc169_1%3a9.11.3+dfsg-1ubuntu1.11_amd64.deb の処理中にエラーが発生しました (--unpack):
'./usr/lib/x86_64-linux-gnu/libisc-pkcs11.so.169.0.1' の展開済みデータを '/usr/lib/x86_64-linux-gnu/libisc-pkcs11.so.169.0.1.dpkg-new' にコピーできません: ファイルまたはストリームの予期しない終わりです
処理中にエラーが発生しました:
/var/cache/apt/archives/libisc169_1%3a9.11.3+dfsg-1ubuntu1.11_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

====================================================================================================================

オフライン

 

#2 2019-12-30 17:52:38

array
メンバ
登録日: 2007-03-13

Re: 【linux初心者】apt-get installできない。

Ubuntuのバージョンが書いていないのでアレですが。
17.04位からnet-toolsは非推奨となっていてインストールされなくなっています。IPを知りたいのであれば

コード:

ip address show

でどうでしょう?
他のコマンドも ip で使えるようです。

オフライン

 

#3 2019-12-30 19:43:04

tempest
新しいメンバ
登録日: 2019-12-30

Re: 【linux初心者】apt-get installできない。

array による投稿:

Ubuntuのバージョンが書いていないのでアレですが。
17.04位からnet-toolsは非推奨となっていてインストールされなくなっています。IPを知りたいのであれば

コード:

ip address show

でどうでしょう?
他のコマンドも ip で使えるようです。

バージョンは18.04になります。
net-toolsだけでなく、
apt-get upgrade もできません。
何が問題なのか分かりますでしょうか…??

オフライン

 

#4 2019-12-31 06:45:45

ry
メンバ
登録日: 2008-07-30

Re: 【linux初心者】apt-get installできない。

apt-get update はやりました?

オフライン

 

Board footer

Powered by FluxBB