お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2020-10-12 12:13:07

shamushamu
新しいメンバ
登録日: 2020-10-12

初めてエラーコードが出て、解決に困っています。

GitBushを用いて環境構築を行っています。
実現したいことはモックの起動です。
その前段階でデータベースを作成したいのですが、上手くいっておらず今回のコマンドを入力いたしました。
プログラミング初心者の学生ですので、頂いた回答に対して追加の質問で返させていただくことがあるかもしれません。
何卒ご了承ください。

こちら自分の環境です。
Windows10
rbenv 2.7.1
ubunts 20.04

【発生している問題・エラーメッセージ】
/usr/lib/ruby/2.7.0/yaml.rb:3: warning: It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.
Traceback (most recent call last):

【完了させたいコマンド】
yarn run dev

【ネットで調べて試したこと】
・ibyamlのインストール
・Rubyのアンインストールとインストール

【補足情報】
Rubyのインストールの際に、
Installing ruby-2.7.1...
Installed ruby-2.7.1 to /home/vagrant/.rbenv/versions/2.7.1
と表示されていたのですが、
ruby --version
を行うと
ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-linux-gnu]
と表示されており、バージョンが違うことも気になっています。

オフライン

 

Board footer

Powered by FluxBB