お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2021-01-20 10:34:26

redred
メンバ
登録日: 2020-05-27

kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

現在ubuntu 20.04LTSのkernelは自動アップデートによって5.8に更新されているようです。
ubuntu 20.04LTSのセキュリティサポート期間は2025年4月までとのことですが、それは随時新しいkernelを使っていることが前提ですか?
それとも、kernelは古い5.4を使い続けても、kernel部分のセキュリティアップデートは2025年4月まで随時入ってくるものなのでしょうか?

オフライン

 

#2 2021-01-21 10:35:46

elliptic
メンバ
登録日: 2020-03-05

Re: kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

redred による投稿:

ubuntu 20.04LTSのセキュリティサポート期間は2025年4月までとのことですが、それは随時新しいkernelを使っていることが前提ですか?
それとも、kernelは古い5.4を使い続けても、kernel部分のセキュリティアップデートは2025年4月まで随時入ってくるものなのでしょうか?

第278回 Ubuntuカーネルとの付き合い方:Ubuntu Weekly Recipe|gihyo.jp … 技術評論社
https://gihyo.jp/admin/serial/01/ubuntu-recipe/0278?page=3
によると

まずGAカーネルについては,「⁠最新のバージョンのみ5年サポート」です。「⁠カーネルとパッケージのバージョン」で説明したように,カーネルのABIが変更されるとカーネルのパッケージ名が変更されます。このとき,5年サポートの対象になるのは,ABIが更新された後のパッケージのみとなります。

次にHWEカーネルについては,「⁠元になったリリースのサポート期間に準じる」ことになります。

古くなったカーネルはたとえLTSのリポジトリに存在していても,サポート期間がLTSではないパッケージと同じになります。また,原則としてセキュリティパッチは新しいカーネルのみに適用されるので,古いカーネルを使い続けることは避けるようにしましょう。

と書かれてます。

オフライン

 

#3 2021-01-21 10:50:46

redred
メンバ
登録日: 2020-05-27

Re: kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

elliptic さま

ありがとうございます。
紹介いただいた記事をじっくり読み込んでみます。

オフライン

 

#4 2021-01-21 13:14:58

redred
メンバ
登録日: 2020-05-27

Re: kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

上記記事を読み込んでみました。
どなたか、こういう理解で正しいか添削いただけないでしょうか?
記事はもう古いので、最新状況での相違もあればご指摘をお願いいたします。

私の理解
①isoが20.04.0 LTS初期でインストールしたカーネルはGEカーネルであり、カーネルは5.4のまま5年間パッチでサポートされる
②isoが20.04.1 LTS以降でインストールしたカーネルはHWEカーネルであり、カーネルは9ヶ月サポートなので、サポートが切れる前に順次カーネルバージョンが上がっていく。
結論、古いカーネル5.4を使い続けるなら、①iosが20.04.0 LTS初期でインストールするがよし

オフライン

 

#5 2021-01-21 19:09:03

rohizuka
メンバ
登録日: 2009-06-25

Re: kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

https://wiki.ubuntu.com/Kernel/LTSEnablementStack
20.04.1まではGA kernelでインストール。2020/08/06 リリース
20.04.2からHWE kernelでインストール。 2021/02/04 リリース予定
GA kernelを望む場合は20.04.1を選択すると良いでしょう。

オフライン

 

#6 2021-01-21 19:41:54

redred
メンバ
登録日: 2020-05-27

Re: kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

ありがとうございます。
wikiもじっくり読んでみます。

オフライン

 

#7 2021-01-22 01:18:05

rohizuka
メンバ
登録日: 2009-06-25

Re: kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

すみません、20.04のリリースノートを読み返してみたら私の説明は正しくなかったみたいです。
https://wiki.ubuntu.com/FocalFossa/Rele … vMMgwwzDX-

デスクトップ版のUbuntuは、常にHWE(Hardware Enablement)カーネルを利用するようになりました。つまり、Ubuntuデスクトップについては、20.04.2がリリースされたあと2022年の夏まで6ヶ月ごとに新しいカーネルに更新され続けることになります

    日本語注:2021年1月16日時点ではまだ20.04.2はリリースされていませんが、20.04.1をインストールした環境であれば、すでに21.10の5.8カーネルに更新されるようになっています。

ubuntu-ja-20.04-desktop-amd64.iso(2020/05/09)でVirtualBoxにインストールしてみましたが、HWEカーネルでインストールされました。
デスクトップ版のUbuntu20.04でGA kernelを使い続けるのはカーネルのメタパッケージその他を入れ替える必要があるそうです。
https://zenn.dev/ikuya/articles/be6af2948d4b67

オフライン

 

#8 2021-01-22 06:44:51

redred
メンバ
登録日: 2020-05-27

Re: kernelは古い5.4を使い続けても大丈夫なものですか?、ubuntu 20.04LTS

rohizuka さま

リカバーありがとうございます。
勉強になりました。

みなさま、私の理解 修正版で正しいか添削いただけないでしょうか?

私の理解 修正版1
20.04LTSは、
①デスクトップ版のカーネルは、HWEカーネルであり、ubuntu半年毎版で使われているバージョンのカーネルを追いかけるようにバージョンが上がってゆく。
②デスクトップ版以外のカーネルは5.4で、5.4ベースのまま5年間パッチでセキュリティアップデート等がサポートされる
③20.04LTSでカーネル5.4を使い続けるのなら、
a.デスクトップ版に細工を施すか、※
b.デスクトップ版以外にデスクトップ環境を乗せて使う

※デスクトップ版での5.4継続使用で、5.4ベースのまま5年間パッチでセキュリティアップデート等がサポートされるのかは不明につき、引き続き情報求む。

オフライン

 

Board footer

Powered by FluxBB