お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2021-01-28 21:25:08

BlueDragon
メンバ
登録日: 2019-12-02

libopenmpi-devがどうしてもインストールできません。

Ubuntu Serever18.04ですが、libopenmpi-devがどうしてもインストールできません。

sudo apt-get update
sudo apt-get install libopenmpi-dev

としますが、

E: unable to locate package libopenmpi-dev

となってしまいます。

Ubuntu Serever20.04にアップデートしてもダメで、locateできないのだから、容量かなと思い、

パーティションを適当に切りなおして、Ubuntu Server18.04からインストールしなおしてみましたが、だめです。

これがどのくらいのファイルサイズで、どこにインストールされるのかもちょっとよくわかっていません。

cmake や python3-devなんかは、apt-get install コマンドでインストールできますので、

なぜ、これだけが、インストールできないのかわかりません。

よろしくお願いいたします。

オフライン

 

#2 2021-01-28 22:01:18

BlueDragon
メンバ
登録日: 2019-12-02

Re: libopenmpi-devがどうしてもインストールできません。

universeをリポジトリに追加したところ、インストールが進みました。

sudo add-apt-repository universe
sudo apt-get update

sudo apt-get install libopenmpi-dev

オフライン

 

Board footer

Powered by FluxBB