お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2021-07-21 13:33:40

furuse
新しいメンバ
登録日: 2021-07-08

apt と apt-get

ubuntu server 20.04
apt update、apt upgrade が「Failed to fetch」エラーとなり、apt-get update、apt-get upgrade はうまくいきましたが
この2つのコマンドにはどのような違いがあるのでしょうか?
どなたかどうぞご教示ください。よろしくお願いします。

実行したコマンドと結果は以下の通りです。

①「apt update」実行
# apt update
Hit:1 http://jp.archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://jp.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:3 http://jp.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:4 http://jp.archive.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:5 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1,126 kB]
Get:6 http://jp.archive.ubuntu.com/ubuntu focal-updates/main Translation-en [245 kB]
Get:7 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [13.8 kB]
Get:8 http://jp.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [364 kB]
Get:9 http://jp.archive.ubuntu.com/ubuntu focal-updates/restricted Translation-en [52.7 kB]
Get:10 http://jp.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 c-n-f Metadata [428 B]
Ign:11 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
Ign:12 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata
Ign:13 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages
Ign:14 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en
Ign:15 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata
Ign:16 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 Packages
Ign:17 http://jp.archive.ubuntu.com/ubuntu focal-security/main Translation-en
Ign:18 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata
Ign:19 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 Packages
Ign:20 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted Translation-en
Ign:21 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata
Ign:22 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages
Ign:23 http://jp.archive.ubuntu.com/ubuntu focal-security/universe Translation-en
Ign:24 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata
Ign:25 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages
Ign:26 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse Translation-en
Ign:27 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 c-n-f Metadata
Ign:11 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
Ign:12 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata
Ign:13 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages
Ign:14 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en
Ign:15 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata
Ign:16 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 Packages
Ign:17 http://jp.archive.ubuntu.com/ubuntu focal-security/main Translation-en
Ign:18 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata
Ign:19 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 Packages
Ign:20 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted Translation-en
Ign:21 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata
Ign:22 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages
Ign:23 http://jp.archive.ubuntu.com/ubuntu focal-security/universe Translation-en
Ign:24 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata
Ign:25 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages
Ign:26 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse Translation-en
Ign:27 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 c-n-f Metadata
Ign:11 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
Ign:12 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata
Ign:13 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages
Ign:14 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en
Ign:15 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata
Ign:16 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 Packages
Ign:17 http://jp.archive.ubuntu.com/ubuntu focal-security/main Translation-en
Ign:18 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata
Ign:19 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 Packages
Ign:20 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted Translation-en
Ign:21 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata
Ign:22 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages
Ign:23 http://jp.archive.ubuntu.com/ubuntu focal-security/universe Translation-en
Ign:24 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata
Ign:25 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages
Ign:26 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse Translation-en
Ign:27 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 c-n-f Metadata
Ign:11 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
Err:12 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:13 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:14 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:15 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Ign:16 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 Packages
Ign:17 http://jp.archive.ubuntu.com/ubuntu focal-security/main Translation-en
Err:18 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:19 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 Packages
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:20 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted Translation-en
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:21 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:22 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:23 http://jp.archive.ubuntu.com/ubuntu focal-security/universe Translation-en
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:24 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:25 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:26 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse Translation-en
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Err:27 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 c-n-f Metadata
  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
Ign:16 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 Packages
Fetched 2,129 kB in 50s (42.2 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
6 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-updates/universe/cnf/Commands-amd64  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-updates/multiverse/binary-amd64/Packages.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-updates/multiverse/i18n/Translation-en.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-updates/multiverse/cnf/Commands-amd64  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/main/cnf/Commands-amd64  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/restricted/binary-amd64/Packages.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/restricted/i18n/Translation-en.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/restricted/cnf/Commands-amd64  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/universe/binary-amd64/Packages.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/universe/i18n/Translation-en.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/universe/cnf/Commands-amd64  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/multiverse/binary-amd64/Packages.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/multiverse/i18n/Translation-en.gz  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/focal-security/multiverse/cnf/Commands-amd64  Unable to connect to jp.archive.ubuntu.com:http: [IP: 160.26.2.187 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.

②「Failed to fetch」エラーとなったためパッケージリストを削除して、再度「apt-update」
# rm -rf /var/lib/apt/lists/*
# ls -la /var/lib/apt/lists/
total 16
drwxr-xr-x 2 root root 12288 Jul 21 12:55 .
drwxr-xr-x 5 root root  4096 Jul 19 13:22 ..
# apt update
Get:1 http://jp.archive.ubuntu.com/ubuntu focal InRelease [265 kB]
Get:2 http://jp.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:3 http://jp.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:4 http://jp.archive.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:5 http://jp.archive.ubuntu.com/ubuntu focal/main amd64 Packages [970 kB]
Get:6 http://jp.archive.ubuntu.com/ubuntu focal/main Translation-en [506 kB]
Get:7 http://jp.archive.ubuntu.com/ubuntu focal/main amd64 c-n-f Metadata [29.5 kB]
Get:8 http://jp.archive.ubuntu.com/ubuntu focal/restricted amd64 Packages [22.0 kB]
Get:9 http://jp.archive.ubuntu.com/ubuntu focal/restricted Translation-en [6,212 B]
Get:10 http://jp.archive.ubuntu.com/ubuntu focal/restricted amd64 c-n-f Metadata [392 B]
Get:11 http://jp.archive.ubuntu.com/ubuntu focal/universe amd64 Packages [8,628 kB]
Get:12 http://jp.archive.ubuntu.com/ubuntu focal/universe Translation-en [5,124 kB]
Get:13 http://jp.archive.ubuntu.com/ubuntu focal/universe amd64 c-n-f Metadata [265 kB]
Get:14 http://jp.archive.ubuntu.com/ubuntu focal/multiverse amd64 Packages [144 kB]
Get:15 http://jp.archive.ubuntu.com/ubuntu focal/multiverse Translation-en [104 kB]
Get:16 http://jp.archive.ubuntu.com/ubuntu focal/multiverse amd64 c-n-f Metadata [9,136 B]
Get:17 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1,126 kB]
Get:18 http://jp.archive.ubuntu.com/ubuntu focal-updates/main Translation-en [245 kB]
Get:19 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [13.8 kB]
Get:20 http://jp.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [364 kB]
Get:21 http://jp.archive.ubuntu.com/ubuntu focal-updates/restricted Translation-en [52.7 kB]
Get:22 http://jp.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 c-n-f Metadata [428 B]
Get:23 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [843 kB]
Get:24 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe Translation-en [176 kB]
Get:25 http://jp.archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata [18.4 kB]
Get:26 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages [27.5 kB]
Get:27 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en [6,780 B]
Get:28 http://jp.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata [684 B]
Get:29 http://jp.archive.ubuntu.com/ubuntu focal-backports/main amd64 Packages [2,568 B]
Get:30 http://jp.archive.ubuntu.com/ubuntu focal-backports/main Translation-en [1,120 B]
Get:31 http://jp.archive.ubuntu.com/ubuntu focal-backports/main amd64 c-n-f Metadata [400 B]
Get:32 http://jp.archive.ubuntu.com/ubuntu focal-backports/restricted amd64 c-n-f Metadata [116 B]
Get:33 http://jp.archive.ubuntu.com/ubuntu focal-backports/universe amd64 Packages [5,792 B]
Get:34 http://jp.archive.ubuntu.com/ubuntu focal-backports/universe Translation-en [2,060 B]
Get:35 http://jp.archive.ubuntu.com/ubuntu focal-backports/universe amd64 c-n-f Metadata [288 B]
Get:36 http://jp.archive.ubuntu.com/ubuntu focal-backports/multiverse amd64 c-n-f Metadata [116 B]
Get:37 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 Packages [789 kB]
Get:38 http://jp.archive.ubuntu.com/ubuntu focal-security/main Translation-en [154 kB]
Get:39 http://jp.archive.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [8,284 B]
Get:40 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [327 kB]
Get:41 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted Translation-en [47.4 kB]
Get:42 http://jp.archive.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata [428 B]
Get:43 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages [633 kB]
Get:44 http://jp.archive.ubuntu.com/ubuntu focal-security/universe Translation-en [97.5 kB]
Get:45 http://jp.archive.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata [11.9 kB]
Get:46 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages [23.8 kB]
Get:47 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse Translation-en [4,624 B]
Get:48 http://jp.archive.ubuntu.com/ubuntu focal-security/multiverse amd64 c-n-f Metadata [560 B]
Fetched 21.4 MB in 55s (392 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
18 packages can be upgraded. Run 'apt list --upgradable' to see them.

※今度はエラーがでなかったようです。

③「apt upgrade」で「Failed to fetch」エラーになった
# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-5.4.0-80 linux-headers-5.4.0-80-generic
  linux-image-5.4.0-80-generic linux-modules-5.4.0-80-generic
  linux-modules-extra-5.4.0-80-generic
The following packages will be upgraded:
  apache2 apache2-bin apache2-data apache2-utils libnss-systemd libpam-systemd
  libsystemd0 libudev1 linux-generic linux-headers-generic linux-image-generic
  logwatch python3-distupgrade systemd systemd-sysv systemd-timesyncd
  ubuntu-release-upgrader-core udev
18 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
11 standard security updates
Need to get 83.5 MB of archives.
After this operation, 377 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Ign:1 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libnss-systemd amd64 245.4-4ubuntu3.10
Ign:2 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 udev amd64 245.4-4ubuntu3.10
Ign:3 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libudev1 amd64 245.4-4ubuntu3.10
Ign:4 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd-sysv amd64 245.4-4ubuntu3.10
Ign:5 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd-timesyncd amd64 245.4-4ubuntu3.10
Ign:6 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libpam-systemd amd64 245.4-4ubuntu3.10
Ign:7 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd amd64 245.4-4ubuntu3.10
Ign:8 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libsystemd0 amd64 245.4-4ubuntu3.10
Err:9 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2 amd64 2.4.41-4ubuntu3.4
  Unable to connect to jp.archive.ubuntu.com:http:
Err:10 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2-bin amd64 2.4.41-4ubuntu3.4
  Unable to connect to jp.archive.ubuntu.com:http:
Err:11 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2-data all 2.4.41-4ubuntu3.4
  Unable to connect to jp.archive.ubuntu.com:http:
Err:12 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2-utils amd64 2.4.41-4ubuntu3.4
  Unable to connect to jp.archive.ubuntu.com:http:
Err:13 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 ubuntu-release-upgrader-core all 1:20.04.35
  Unable to connect to jp.archive.ubuntu.com:http:
Err:14 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 python3-distupgrade all 1:20.04.35
  Unable to connect to jp.archive.ubuntu.com:http:
Ign:15 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-modules-5.4.0-80-generic amd64 5.4.0-80.90
Ign:16 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-image-5.4.0-80-generic amd64 5.4.0-80.90
Ign:17 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-modules-extra-5.4.0-80-generic amd64 5.4.0-80.90
Ign:18 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-generic amd64 5.4.0.80.84
Ign:19 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-image-generic amd64 5.4.0.80.84
Ign:20 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-80 all 5.4.0-80.90
Ign:21 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-80-generic amd64 5.4.0-80.90
Ign:22 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-generic amd64 5.4.0.80.84
Err:23 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 logwatch all 7.5.2-1ubuntu1.3
  Unable to connect to jp.archive.ubuntu.com:http:
Err:1 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libnss-systemd amd64 245.4-4ubuntu3.10
  Could not connect to jp.archive.ubuntu.com:80 (160.26.2.187), connection timed out
Err:2 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 udev amd64 245.4-4ubuntu3.10
  Unable to connect to jp.archive.ubuntu.com:http:
Err:3 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libudev1 amd64 245.4-4ubuntu3.10
  Unable to connect to jp.archive.ubuntu.com:http:
Err:4 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd-sysv amd64 245.4-4ubuntu3.10
  Unable to connect to jp.archive.ubuntu.com:http:
Err:5 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd-timesyncd amd64 245.4-4ubuntu3.10
  Unable to connect to jp.archive.ubuntu.com:http:
Err:6 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libpam-systemd amd64 245.4-4ubuntu3.10
  Unable to connect to jp.archive.ubuntu.com:http:
Err:7 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd amd64 245.4-4ubuntu3.10
  Unable to connect to jp.archive.ubuntu.com:http:
Err:8 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libsystemd0 amd64 245.4-4ubuntu3.10
  Unable to connect to jp.archive.ubuntu.com:http:
Err:15 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-modules-5.4.0-80-generic amd64 5.4.0-80.90
  Unable to connect to jp.archive.ubuntu.com:http:
Err:16 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-image-5.4.0-80-generic amd64 5.4.0-80.90
  Unable to connect to jp.archive.ubuntu.com:http:
Err:17 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-modules-extra-5.4.0-80-generic amd64 5.4.0-80.90
  Unable to connect to jp.archive.ubuntu.com:http:
Err:18 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-generic amd64 5.4.0.80.84
  Unable to connect to jp.archive.ubuntu.com:http:
Err:19 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-image-generic amd64 5.4.0.80.84
  Unable to connect to jp.archive.ubuntu.com:http:
Err:20 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-80 all 5.4.0-80.90
  Unable to connect to jp.archive.ubuntu.com:http:
Err:21 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-80-generic amd64 5.4.0-80.90
  Unable to connect to jp.archive.ubuntu.com:http:
Err:22 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-generic amd64 5.4.0.80.84
  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/libnss-systemd_245.4-4ubuntu3.10_amd64.deb  Could not connect to jp.archive.ubuntu.com:80 (160.26.2.187), connection timed out
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/udev_245.4-4ubuntu3.10_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/libudev1_245.4-4ubuntu3.10_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/systemd-sysv_245.4-4ubuntu3.10_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/systemd-timesyncd_245.4-4ubuntu3.10_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/libpam-systemd_245.4-4ubuntu3.10_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/systemd_245.4-4ubuntu3.10_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/s/systemd/libsystemd0_245.4-4ubuntu3.10_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apache2/apache2_2.4.41-4ubuntu3.4_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-bin_2.4.41-4ubuntu3.4_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-data_2.4.41-4ubuntu3.4_all.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-utils_2.4.41-4ubuntu3.4_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-release-upgrader/ubuntu-release-upgrader-core_20.04.35_all.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-release-upgrader/python3-distupgrade_20.04.35_all.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-modules-5.4.0-80-generic_5.4.0-80.90_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux-signed/linux-image-5.4.0-80-generic_5.4.0-80.90_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-modules-extra-5.4.0-80-generic_5.4.0-80.90_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-generic_5.4.0.80.84_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-image-generic_5.4.0.80.84_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-headers-5.4.0-80_5.4.0-80.90_all.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-headers-5.4.0-80-generic_5.4.0-80.90_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-headers-generic_5.4.0.80.84_amd64.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/pool/main/l/logwatch/logwatch_7.5.2-1ubuntu1.3_all.deb  Unable to connect to jp.archive.ubuntu.com:http:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

④「apt」ではなく「apt-get」に替えて「update」
# apt-get update
Hit:1 http://jp.archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://jp.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:3 http://jp.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:4 http://jp.archive.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Fetched 328 kB in 19s (16.9 kB/s)
Reading package lists... Done

⑤「apt-upgrade」
# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
The following packages will be upgraded:
  apache2 apache2-bin apache2-data apache2-utils libnss-systemd libpam-systemd
  libsystemd0 libudev1 logwatch python3-distupgrade systemd systemd-sysv
  systemd-timesyncd ubuntu-release-upgrader-core udev
15 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
8 standard security updates
Need to get 7,857 kB of archives.
After this operation, 16.4 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libnss-systemd amd64 245.4-4ubuntu3.10 [96.2 kB]
Get:2 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 udev amd64 245.4-4ubuntu3.10 [1,365 kB]
Get:3 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libudev1 amd64 245.4-4ubuntu3.10 [78.2 kB]
Get:4 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd-sysv amd64 245.4-4ubuntu3.10 [10.3 kB]
Get:5 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd-timesyncd amd64 245.4-4ubuntu3.10 [28.1 kB]
Get:6 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libpam-systemd amd64 245.4-4ubuntu3.10 [186 kB]
Get:7 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 systemd amd64 245.4-4ubuntu3.10 [3,810 kB]
Get:8 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 libsystemd0 amd64 245.4-4ubuntu3.10 [271 kB]
Get:9 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2 amd64 2.4.41-4ubuntu3.4 [95.5 kB]
Get:10 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2-bin amd64 2.4.41-4ubuntu3.4 [1,180 kB]
Get:11 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2-data all 2.4.41-4ubuntu3.4 [159 kB]
Get:12 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 apache2-utils amd64 2.4.41-4ubuntu3.4 [84.0 kB]
Get:13 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 ubuntu-release-upgrader-core all 1:20.04.35 [23.9 kB]
Get:14 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 python3-distupgrade all 1:20.04.35 [104 kB]
Get:15 http://jp.archive.ubuntu.com/ubuntu focal-updates/main amd64 logwatch all 7.5.2-1ubuntu1.3 [366 kB]
Fetched 7,857 kB in 46s (171 kB/s)
(Reading database ... 77779 files and directories currently installed.)
Preparing to unpack .../libnss-systemd_245.4-4ubuntu3.10_amd64.deb ...
Unpacking libnss-systemd:amd64 (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Preparing to unpack .../udev_245.4-4ubuntu3.10_amd64.deb ...
Unpacking udev (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Preparing to unpack .../libudev1_245.4-4ubuntu3.10_amd64.deb ...
Unpacking libudev1:amd64 (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Setting up libudev1:amd64 (245.4-4ubuntu3.10) ...
(Reading database ... 77779 files and directories currently installed.)
Preparing to unpack .../systemd-sysv_245.4-4ubuntu3.10_amd64.deb ...
Unpacking systemd-sysv (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Preparing to unpack .../systemd-timesyncd_245.4-4ubuntu3.10_amd64.deb ...
Unpacking systemd-timesyncd (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Preparing to unpack .../libpam-systemd_245.4-4ubuntu3.10_amd64.deb ...
Unpacking libpam-systemd:amd64 (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Preparing to unpack .../systemd_245.4-4ubuntu3.10_amd64.deb ...
Unpacking systemd (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Preparing to unpack .../libsystemd0_245.4-4ubuntu3.10_amd64.deb ...
Unpacking libsystemd0:amd64 (245.4-4ubuntu3.10) over (245.4-4ubuntu3.7) ...
Setting up libsystemd0:amd64 (245.4-4ubuntu3.10) ...
(Reading database ... 77780 files and directories currently installed.)
Preparing to unpack .../0-apache2_2.4.41-4ubuntu3.4_amd64.deb ...
Unpacking apache2 (2.4.41-4ubuntu3.4) over (2.4.41-4ubuntu3.3) ...
Preparing to unpack .../1-apache2-bin_2.4.41-4ubuntu3.4_amd64.deb ...
Unpacking apache2-bin (2.4.41-4ubuntu3.4) over (2.4.41-4ubuntu3.3) ...
Preparing to unpack .../2-apache2-data_2.4.41-4ubuntu3.4_all.deb ...
Unpacking apache2-data (2.4.41-4ubuntu3.4) over (2.4.41-4ubuntu3.3) ...
Preparing to unpack .../3-apache2-utils_2.4.41-4ubuntu3.4_amd64.deb ...
Unpacking apache2-utils (2.4.41-4ubuntu3.4) over (2.4.41-4ubuntu3.3) ...
Preparing to unpack .../4-ubuntu-release-upgrader-core_1%3a20.04.35_all.deb ...
Unpacking ubuntu-release-upgrader-core (1:20.04.35) over (1:20.04.33) ...
Preparing to unpack .../5-python3-distupgrade_1%3a20.04.35_all.deb ...
Unpacking python3-distupgrade (1:20.04.35) over (1:20.04.33) ...
Preparing to unpack .../6-logwatch_7.5.2-1ubuntu1.3_all.deb ...
Unpacking logwatch (7.5.2-1ubuntu1.3) over (7.5.2-1ubuntu1.2) ...
Setting up apache2-bin (2.4.41-4ubuntu3.4) ...
Setting up python3-distupgrade (1:20.04.35) ...
Setting up udev (245.4-4ubuntu3.10) ...
update-initramfs: deferring update (trigger activated)
Setting up ubuntu-release-upgrader-core (1:20.04.35) ...
Setting up apache2-data (2.4.41-4ubuntu3.4) ...
Setting up logwatch (7.5.2-1ubuntu1.3) ...
Setting up apache2-utils (2.4.41-4ubuntu3.4) ...
Setting up apache2 (2.4.41-4ubuntu3.4) ...
Setting up systemd-timesyncd (245.4-4ubuntu3.10) ...
Setting up systemd (245.4-4ubuntu3.10) ...
Installing new version of config file /etc/dhcp/dhclient-enter-hooks.d/resolved ...
Setting up systemd-sysv (245.4-4ubuntu3.10) ...
Setting up libnss-systemd:amd64 (245.4-4ubuntu3.10) ...
Setting up libpam-systemd:amd64 (245.4-4ubuntu3.10) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
Processing triggers for ufw (0.36-6) ...
Rules updated for profile 'Apache'
Skipped reloading firewall
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...
Processing triggers for initramfs-tools (0.136ubuntu6.6) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-77-generic

サーバ構築の際のパッケージインストールには「apt install」としてエラーは出ませんでした。
皆様、どうぞよろしくお願いします。

オフライン

 

Board footer

Powered by FluxBB