お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2022-05-28 17:24:24

arucat
メンバ
登録日: 2009-02-03

snap版のBOINC Managerがエラーで動作しない

こんにちは。

Ubuntu 22.04LTSを使用しています。
Ubuntu Softwareから「BOINC Manager」をインストールしたのですが、クライアントを再起動してください
というエラーが出てBOINC Managerが動作しません。

CUIからBOINC-clientの起動を試みたのですが、どうも動的リンクで設定されているlibstdc++.so.3が無いため
起動しないようです。
lddコマンドで確認したら下記のようになりました。

$ldd boinc
        linux-gate.so.1 (0xf7f37000)
        libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7f15000)
        libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xf7f02000)
        libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7efd000)
        libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7df5000)
        libstdc++.so.3 => not found
        libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7bc0000)
        libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7b99000)
        /lib/ld-linux.so.2 (0xf7f39000)

現在は、libstdc++.so.6が最新のようですが、要求されたlibstdc++.so.3に対してlibstdc++.so.6を設定する
方法はあるんでしょうか?
無知ですみません。対処方法を教えてください。

オフライン

 

Board footer

Powered by FluxBB