お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2007-05-19 00:21:27

takashi
新しいメンバ
登録日: 2007-05-19

berylのインストール

本でみて興味をもちberylをインストールしようとしているのですが
パッケージマネージャーでberylを選択すると
以下のように表示されてパッケージに依存関係が存在し、リポジトリが有効であるかを確認せよとのコメントがでるのですが
、本の通りにやっているのに、なぜなのかがわかりません。
対策とともに教えてください。


beryl:
依存: beryl-core しかしそれはインストールされません
依存: libberylsettings0 しかしそれはインストールされません
依存: libberyldecoration0 しかしそれはインストールされません
依存: beryl-plugins しかしそれはインストールされません
依存: beryl-settings しかしそれはインストールされません
依存: emerald しかしそれはインストールされません または
    aquamarine しかしそれはインストールされません または
    heliodor しかしそれはインストールされません または
    yawd  しかしインストール可能なパッケージではありません または
    compiz-gnome しかしそれはインストールされません
依存: beryl-manager しかしそれはインストールされません

オフライン

 

#2 2007-05-19 00:40:29

gmax
メンバ
From: 兵庫県
登録日: 2006-10-24

Re: berylのインストール

>本の通りにやっているのに、なぜなのかがわかりません。

どの本でしょうか?というより、何をどうしたのかを具体的に書いていただいた方が回答しやすいと思います。
今回の場合は依存するパッケージが見付からない状態、ということはどこからパッケージを取得するようになっているのかから提示していただく必要があると思います。

beryl関連のパッケージは、現状universeと呼ばれるパッケージ群に含まれていますので、/etc/apt/sources.listの中に、

deb http://jp.archive.ubuntu.com/ubuntu/ feisty universe

という行があれば、依存するパッケージもふくめてインストールされるはずです。

私のところでは現状、下記のようなパッケージがインストールされています。参考までに。

コード:

ii  beryl                                         0.2.1.dfsg+git20070318-0ubuntu2            Compositing window manager, decorator and th
ii  beryl-core                                    0.2.1.dfsg+git20070318-0ubuntu2            Compositing window manager - Beryl Project
ii  beryl-kubuntu                                 0.2.1+git20070318-0ubuntu2                 Simplified Plugin and configuration tool - B
ii  beryl-manager                                 0.2.1-0ubuntu1                             Tray application launcher tool - Beryl Proje
ii  beryl-plugins                                 0.2.1-0ubuntu2                             Collection of plugins for Beryl
ii  beryl-plugins-data                            0.2.1-0ubuntu2                             Plugins data - Beryl Project
ii  beryl-plugins-unsupported                     0.2.1-0ubuntu1                             Collection of extra plugins for Beryl
ii  beryl-plugins-unsupported-data                0.2.1-0ubuntu1                             Unsupported Plugins Data
ii  beryl-settings                                0.2.1-0ubuntu1                             Plugin and configuration tool - Beryl Projec
ii  beryl-settings-bindings                       0.2.1-0ubuntu1                             Plugin and configuration tool - Beryl Projec
ii  beryl-settings-simple                         0.2.1+git20070318-0ubuntu2                 Simplified Plugin and configuration tool - B
ii  emerald                                       0.2.1-0ubuntu1                             Decorator for beryl
ii  libberyldecoration0                           0.2.1.dfsg+git20070318-0ubuntu2            Settings library for plugins - Beryl Project
ii  libberylsettings0                             0.2.1.dfsg+git20070318-0ubuntu2            Settings library for plugins - Beryl Project
ii  libberylsettings0-gconf                       0.2.1.dfsg+git20070318-0ubuntu2            Settings library for plugins - Beryl Project
ii  libberylsettings0-kconfig                     0.2.1.dfsg+git20070318-0ubuntu2            Settings library for plugins - Beryl Project
ii  libemeraldengine0                             0.2.1-0ubuntu1                             Decoration engines for beryl

オフライン

 

#3 2007-05-19 01:24:47

takashi
新しいメンバ
登録日: 2007-05-19

Re: berylのインストール

返信ありがとうございます。Linux100%という雑誌です。

とりあえずグラフィックドライバのインストールをしてから、

deb http://download.tuxfamily.org/3v1deb edgy beryl-svn
deb-src http://download.tuxfamily.org/3v1deb edgy beryl-svn

を加えたところまでです。

オフライン

 

#4 2007-05-19 01:39:35

takashi
新しいメンバ
登録日: 2007-05-19

Re: berylのインストール

早速、
deb http://jp.archive.ubuntu.com/ubuntu/ feisty universe
を加えてみたのですが、まだ未解決の依存関係があるというふうに全く同じコメントが出てきちゃいました。

オフライン

 

#5 2007-05-19 01:43:20

gmax
メンバ
From: 兵庫県
登録日: 2006-10-24

Re: berylのインストール

確認ですが、お使いのUbuntuはEdgyでしょうか?
最新版のFeistyを前提に考えていましたが、もし、Feistyをお使いであれば上記のedgy用ではなく

deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy

を追加してはどうかと思います。

私もちょっとやってみます。

参考:
http://download.tuxfamily.org/3v1deb/dists/feisty/eyecandy/index.html

オフライン

 

#6 2007-05-19 01:47:33

takashi
新しいメンバ
登録日: 2007-05-19

Re: berylのインストール

物知らずですいません。
EdgyとかFeistyはよくわからないのですが、6.06LTSを入れています。

オフライン

 

#7 2007-05-19 01:57:28

gmax
メンバ
From: 兵庫県
登録日: 2006-10-24

Re: berylのインストール

安定性や成熟度ということなら6.06LTSも良いのですが、berylのような先進機能をお望みなら新しいものを入れていただいた方がいいでしょう。ちょうどいい記事が出ましたので、こちらを参考にFeistyを入れてみてはいかがでしょうか。

http://itpro.nikkeibp.co.jp/article/COLUMN/20070507/270108/

Feistyで先のリポジトリからBerylを取り込んだ場合のレポートは別途。

オフライン

 

#8 2007-05-19 02:09:30

takashi
新しいメンバ
登録日: 2007-05-19

Re: berylのインストール

わかりました。Feistyをいれて改めて試してみます。色々と教えていただきありがとうございます。
またつまずいた時は、よろしくお願いします。

オフライン

 

#9 2007-05-19 02:26:30

gmax
メンバ
From: 兵庫県
登録日: 2006-10-24

Re: berylのインストール

私の場合は先にubuntuでリリースされていたberylが入っていたのでちょっと手がかかりましたが、とりあえずは試されたリポジトリのberylは動きました。素のFeistyならさほど苦労はないでしょう。参考までにインストールされたパッケージは以下。

コード:

$ dpkg --list | grep beryl
ii  beryl                                         0.3.0+git20070324~3v1ubuntu4               Compositing window manager, decorator and th
ii  beryl-core                                    0.3.0+git20070324~3v1ubuntu4               Compositing window manager - Beryl Project
ii  beryl-manager                                 0.3.0+git20070323~3v1ubuntu2               Tray application launcher tool - Beryl Proje
ii  beryl-plugins                                 0.3.0+git20070404~3v1ubuntu4               Collection of plugins for Beryl
ii  beryl-plugins-data                            0.3.0+git20070404~3v1ubuntu4               Plugins data - Beryl Project
ii  beryl-plugins-unsupported                     0.3.0+git20070323~3v1ubuntu4               Collection of extra plugins for Beryl
ii  beryl-plugins-unsupported-data                0.3.0+git20070323~3v1ubuntu4               Unsupported Plugins Data
ii  beryl-settings                                0.3.0+git20070320~3v1ubuntu2               Plugin and configuration tool - Beryl Projec
ii  beryl-settings-bindings                       0.3.0+git20070317~3v1ubuntu2               Plugin and configuration tool - Beryl Projec
ii  beryl-settings-simple                         0.3.0+git20070320~3v1ubuntu2               Simplified Plugin and configuration tool - B
ii  emerald                                       0.3.0+git20070321~3v1ubuntu2               Decorator for beryl
ii  libberyldecoration0                           0.3.0+git20070324~3v1ubuntu4               Settings library for plugins - Beryl Project
ii  libberylsettings0                             0.3.0+git20070324~3v1ubuntu4               Settings library for plugins - Beryl Project
ii  libberylsettings0-gconf                       0.3.0+git20070324~3v1ubuntu4               Settings library for plugins - Beryl Project
ii  libemeraldengine0                             0.3.0+git20070321~3v1ubuntu2               Decoration engines for beryl

しかし、現時点ではリビジョンはひとつおくれますが、安定性を求めるならこちらのほうがいいと思います。

http://ubuntu.beryl-project.org/dists/feisty/main/

オフライン

 

#10 2007-05-21 11:49:42

gmax
メンバ
From: 兵庫県
登録日: 2006-10-24

Re: berylのインストール

後日談というか補足です。

http://download.tuxfamily.org/3v1deb/dists/feisty/eyecandy/index.html

で配布されているberylをインストールしたところ、 berylとberyl-managerがapt-get autoremoveで削除可能だと表示されるようになりました。当然このふたつを削除してしまうと.....ダメですよね;P

どうもパッケージで設定している依存関係に若干の問題があるように思います。いわれるままに削除しなければそれでいいのですが。御注意下さい。

オフライン

 

Board footer

Powered by FluxBB