お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2009-05-15 01:30:01

ounatreb
メンバ
登録日: 2009-05-15

Ubuntu 9.04 で動画が再生できません

はじめまして。
初心者です。
どうかよろしくお願いします。

こちらのフォーラムで「9.04」・「動画」で検索を掛け、
https://forums.ubuntulinux.jp/viewtopic.php?id=4778
https://forums.ubuntulinux.jp/viewtopic.php?pid=30563
などを拝見させていただきましたが、解決に至りませんでした。

これまで 8.04 を使用していました。
9.04 がリリースされたとのことで、8.10〜9.04へとアップしました。

まず、その段階で 8.04 で何の問題もなかった動画再生ができなくなりました。
(8.10 では確認しませんでした。)

ファイルは手元にAVI形式のみしかなかったので、それらで試しました。
コーデックはMPEG-4やDivX系など数種類です。
どのファイルも 8.04 のときには確実に再生できていたものばかりです。

その後、コーデック類を再インストールしたり、プレーヤーを再インストール
したりしましたが、症状は変わりませんでした。

肝心の症状についてですが、動画ファイルをダブルクリック、もしくは右クリックで
アプリケーションから直接開こうとすると、真っ黒のビューワー画面が
ほんの一瞬だけ開き、その瞬間にアプリケーションごと落ちてしまいます。

ただし、アプリケーションのみの起動であれば問題なくできます。

「動画プレーヤー(totem)」・「VLC」・「MPlayer」で試しましたが、
ともに全く同じ結果でした。

これは「Ubuntu」自体のアップデートに問題があったのだろうと思い込み
仕方なくハードディスクを初期化し、今度は「9.04」を一からクリーン
インストールし直し、インストール後にコーデック類をインストールし、
再度動画を開こうとしたのですが、前述の症状と全く同じでした。
(前述と同様、三種のプレーヤーで確認。
 クリーンインストールも二回試しましたが、結果は変わりませんでした。)

動画ファイルを疑い、「Windows」で起動し開いてみましたが、どのファイルも
問題なく再生できました。

・クリーンインストール直後でも同じ症状
・Windowsで再生確認の取れたファイル
・アプリケーション自体は起動する
・コーデック類はインストール済み
・一瞬で落ちるため、エラーメッセージが出ていたとしても確認すらできない

という状況で、インターネットで同症状の情報も得られず、こちらで質問させて
いただきました。

最後に、マシンスペックは「Dell GX270 P4-2.6GB 512MB」です。

「Ubuntu」は快適で気に入っており、今後も使用したいと考えているので、
お分かりになる方、どうぞよろしくお願いします。

最後の編集者: ounatreb (2009-05-15 01:35:02)

オフライン

 

#2 2009-05-15 02:12:12

ack
メンバ
登録日: 2007-06-01

Re: Ubuntu 9.04 で動画が再生できません

ounatreb による投稿:

これまで 8.04 を使用していました。

~略~

真っ黒のビューワー画面がほんの一瞬だけ開き、その瞬間にアプリケーションごと落ちてしまいます。
ただし、アプリケーションのみの起動であれば問題なくできます。

~略~

・クリーンインストール直後でも同じ症状
・Windowsで再生確認の取れたファイル
・アプリケーション自体は起動する
・コーデック類はインストール済み
・一瞬で落ちるため、エラーメッセージが出ていたとしても確認すらできない

~略~

最後に、マシンスペックは「Dell GX270 P4-2.6GB 512MB」です。

一部略して引用させて頂きました。

Dell GX270 は検索したところ i865G の製品のようで、またご報告頂いている症状からほぼ間違いなく

https://wiki.ubuntu.com/JauntyJackalope/ReleaseNotes/ja

Intelグラフィックカードの性能が悪くなっています

Intelビデオチップセットのユーザによると、Ubuntu 8.10はそれまでと比べて性能が悪くなっているようです( 252094 )。問題のほとんどはUbuntu 9.04で解決していますが、一部まだ未解決のものがあります。

の件と思います。
このリリースノートにある
・xorg.conf にオプションを書き込んでみる
・古いバージョンのドライバを試してみる
の他、
http://gihyo.jp/admin/clip/01/ubuntu-topics/200905/01

Xドライバの最新版

9.04がリリースされましたが,幾つかの問題が発見されています(注1)。
中でもXのintelドライバのバグの影響は大きく,

~略~

Xの開発チームが9.04用の新しいドライバをPPAで提供し始めました。

の新しいドライバを試してみる、それでもダメなら仕方がないので8.04に戻るしかないかもしれません。

オフライン

 

#3 2009-05-15 15:55:43

ounatreb
メンバ
登録日: 2009-05-15

Re: Ubuntu 9.04 で動画が再生できません

ackさま

早々のアドバイスをありがとうございます。

仕事が終わったら早速試してみたいと思います。

また改めて結果報告させていただきます。

取り急ぎ、お礼まで・・・。
ありがとうございます。

オフライン

 

#4 2009-05-15 23:05:12

ounatreb
メンバ
登録日: 2009-05-15

Re: Ubuntu 9.04 で動画が再生できません

ackさま

結果を報告させていただきます。

まず「xorg.conf にオプションを書き込んでみる」を行い、再起動してみたところ
画面一面が様々な色の細かい縦ラインで埋め尽くされているような状態になり、
何も見えない状況となり、失敗しました。

次に「古いバージョンのドライバを試してみる」の手順を、Webの翻訳機能を使って
訳しながら一つずつ行い、再起動後に動画ファイルを開いてみましたが、
結果は変わりませんでした。

最後に「新しいドライバを試してみる」を行いました。
こちらの方法もWebの翻訳機能を使って訳しながら行ったのですが、
合っているかどうか自信がないので、行った手順も記載させていただきます。

1.「sudo gedit /etc/apt/sources.list」で、
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
を追加記述。

2.下記URL、
 https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/
 から、「xserver-xorg-video-intel - 2:2.7.1-0ubuntu1~xup~1」の
 「xserver-xorg-video-intel-dbg_2.7.1-0ubuntu1~xup~1_i386.deb」と、
 「xserver-xorg-video-intel_2.7.1-0ubuntu1~xup~1_i386.deb」の二つをダウンロード。

3.ダウンロードした二つをダブルクリックで開き、インストールを試みるが
 依存関係のエラーが表示され、インストールできず。

4.「システム」→「システム管理」→「Syapticパッケージ・マネージャ」で
 「xserver-xorg-video-intel」と「xserver-xorg-video-intel-dbg」を選択し、
 「再インストール指定」→「適用」。

上記の4番目の手順で、3番目の内容がクリアできているのだとすれば、新ドライバが
インストールできたものだと考え、再起動。

しかし、結果は変わりませんでした。

この手順で合っているのであれば、「8.04」に戻すしかないようです・・・。

オフライン

 

#5 2009-05-15 23:33:20

ack
メンバ
登録日: 2007-06-01

Re: Ubuntu 9.04 で動画が再生できません

どれもダメでしたか・・・残念です。

なお、新しいドライバを試す、は

ounatreb による投稿:

1.「sudo gedit /etc/apt/sources.list」で、
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
を追加記述。

の後に、端末で

コード:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com AF1CDFA9

で公開鍵を追加、その後アップデートマネージャでシステム全体をアップデートするのが良いと思います。

アップデート後

コード:

dpkg -l | grep "xserver-xorg-video-intel"

を実行して、2:2.7.1-0ubuntu1~xup~1 のバージョン表記のある行が出てくれば新しいドライバはインストールされています。

ounatreb による投稿:

この手順で合っているのであれば、「8.04」に戻すしかないようです・・・。

デスクトップなどは見えているということで、性能が悪いとしても動画プレイヤーに動画が出ればよい、ということであれば

http://linuxsalad.blogspot.com/2007/08/blog-post_15.html
を参考に、Xvなし に設定を変えれば映像は出るようになると思います。

ただし、動画再生に良く適している、というわけではない方法で描画するためCPU負荷は上がります。
※実際のところ、昨今のCPUパワーがあれば結構なところまで乗り切れますが。

VLC、mplayerなどの出力設定も、xv や gl などに相当するものが使われていたり、自動認識になっている設定を x11 に変えれば
9.04のまま動画が再生できると思います。

オフライン

 

#6 2009-05-16 00:55:26

ounatreb
メンバ
登録日: 2009-05-15

Re: Ubuntu 9.04 で動画が再生できません

ackさま

アドバイスをありがとうございます。

> コード : sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com AF1CDFA9
>
> で公開鍵を追加、その後アップデートマネージャでシステム全体をアップデートするのが良いと思います。
>
> アップデート後
>
> コード:
>
> dpkg -l | grep "xserver-xorg-video-intel"
>
> を実行して、2:2.7.1-0ubuntu1~xup~1 のバージョン表記のある行が出てくれば新しいドライバはインストールされています。

上記の「公開鍵を追加」以下ができていなかったので、もう一度、新ドライバを入れ直しました。
その後、「dpkg -l | grep "xserver-xorg-video-intel"」で「2:2.7.1-0ubuntu1~xup~1」の行も
出てきましたが、残念ながら結果は変わりませんでした。


> Xvなし に設定を変えれば映像は出るようになると思います。

貴重な情報をありがとうございます。
この情報どおりに設定したら見事に再生できました!!

動画再生に重きを置いた使用方法ではなく、全く動画が再生できないという状況に困っていた程度
ですので、取り敢えずはこの状態で行こうと思います。

今後、すっきりと解決する方法ができれば良いのですが・・・。

最後に、もう一つだけ質問させていただいてもよろしいでしょうか?

この方法は結局、何がどう変わったということなんでしょうか?
(お教えいただいたページでは「〜起きる可能性があります」という表現だけでしたので・・・。)

もし、よろしければ後学のために教えていただけますと幸いです。

オフライン

 

#7 2009-05-16 01:17:40

ack
メンバ
登録日: 2007-06-01

Re: Ubuntu 9.04 で動画が再生できません

ounatreb による投稿:

この方法は結局、何がどう変わったということなんでしょうか?

私の理解が完璧に正しいとは思えませんが、現在Xorgが比較的大規模な改造の途中で、そのあおりを受けてIntelドライバのアクセラレーションが効かなくなってしまっており
X Video Extensionによるオーバレイ表示が出来なくなっているので、Xlibによる描画に変更した・・・という事になります。
※用語の使い方等ぜんぜん自信ないです。

誤解を承知で例えると、Windows環境でドライバの不都合でDirectXオーバレイが出来なくなってしまったので、GDIで描画するように設定した、に近い状況のはず、です。

オフライン

 

#8 2009-05-16 01:50:54

ounatreb
メンバ
登録日: 2009-05-15

Re: Ubuntu 9.04 で動画が再生できません

ackさま

ご教示、ありがとうございます。

「なるほど!!」です。
非常に分かりやすく、本当に助かりました。

この度は、ご親切・ご丁寧にありがとうございました。

オフライン

 

#9 2009-10-13 23:43:38

osawaget
新しいメンバ
登録日: 2009-10-13

Re: Ubuntu 9.04 で動画が再生できません

9.04でtotemで動画が見られませんでしたが、ふとしたことで見られるようになりました。
まず、リズムボックスミュージクプレイヤーでラジオのどれかをたちあげる。
そのあとtotemを立ち上げる。
何の苦も無く立ち上がります。
できればこの行為をワンボタンでしたいところです。

オフライン

 

#10 2009-10-14 10:18:14

ack
メンバ
登録日: 2007-06-01

Re: Ubuntu 9.04 で動画が再生できません

osawaget による投稿:

まず、リズムボックスミュージクプレイヤーでラジオのどれかをたちあげる。
そのあとtotemを立ち上げる。
何の苦も無く立ち上がります。

映像表示には問題ないとすると、リズムボックスとtotemで共通して使用している他の部分は・・・と考えて
GStreamerのオーディオ部分が怪しそうです。
(totemの、バックエンドであるGStreamerの初期化?取り扱い?に何かバグがあるのでは推測)

http://linuxsalad.blogspot.com/2007/08/blog-post_15.html

gstreamer-properties

の起動方法が載っていますが、この gstreamer-properties のオーディオ部分の設定を
別のものに変えてみるといかがでしょう?
例えば「デフォルト出力」の「プラグイン」をALSAに変更し、「デバイス」でオーディオハードウェアの出力と
おぼしきものを明示的に指定してみる、などです。

オフライン

 

#11 2009-10-14 23:16:34

osawaget
新しいメンバ
登録日: 2009-10-13

Re: Ubuntu 9.04 で動画が再生できません

>この gstreamer-properties のオーディオ部分の設定を
>別のものに変えてみるといかがでしょう?

試しましたが、どうもうまく行かないようです。
totemに関してはデコードのことがよく言われますが、
私のような初心者が言うのも変ですが簡単なバグなような気がします。

オフライン

 

#12 2009-10-15 22:21:47

hir0
メンバ
登録日: 2008-09-28

Re: Ubuntu 9.04 で動画が再生できません

$ sudo apt-get install ubuntu-restricted-extras

インストール済みなら
$ sudo apt-get --reinstall install ubuntu-restricted-extras

の後に、
$ sudo /usr/share/doc/libdvdread4/install-css.sh

はどうでしょうか。

オフライン

 

#13 2009-10-16 23:43:34

osawaget
新しいメンバ
登録日: 2009-10-13

Re: Ubuntu 9.04 で動画が再生できません

ありがとうございます。
$ sudo /usr/share/doc/libdvdread4/install-css.sh はcannot found
でした。
初心者の私にはつらいところです。

オフライン

 

#14 2009-10-17 23:49:13

hir0
メンバ
登録日: 2008-09-28

Re: Ubuntu 9.04 で動画が再生できません

command not found と No such file or directoryは再現出来たのですが、[cannot found] はよわりましたね、実例の報告が無いメッセージです。
install-css.shを実行することで問題が必ず解決すると言う事では無いですが、これはこれで通常では無い状態です。

$ sudo apt-get update
$ sudo apt-get -f install
$ cd /usr/share/doc/libdvdread4
$ sudo sh ./install-css.sh


上から純に
・情報の更新
・依存関係の修復
・ディレクトリを移動
・直接install-css.shを実行

何かエラーやメッセージが出れば全てコピペしてもらえないでしょうか。

オフライン

 

#15 2009-10-20 23:44:57

osawaget
新しいメンバ
登録日: 2009-10-13

Re: Ubuntu 9.04 で動画が再生できません

うーん、少し待ってね。忙しくて症状を追跡できませぬ。
それと、情報をもう少し報告すると、

ミュージックプレイヤーを開いてその次にtotemで動画を再生する。
動画の再生が始まると、ミュージックプレイヤーは閉じても動画の再生は行われる。
動画ファイルを複数登録していると、次の動画の再生のときにtotemが落ちる。

私のインストしたV9.04では、NEC中古、富士通の2台とも同じ症状が出る。

オフライン

 

#16 2009-10-21 00:15:01

hir0
メンバ
登録日: 2008-09-28

Re: Ubuntu 9.04 で動画が再生できません

あー、すみません。
#9~辺りの経過を見過ごしていました。
少し気になったのですが

私のインストしたV9.04では、NEC中古、富士通の2台とも同じ症状が出る。

再生に使用しているメディアの方に特殊性は無いでしょうかね?

オフライン

 

#17 2009-10-24 17:47:55

osawaget
新しいメンバ
登録日: 2009-10-13

Re: Ubuntu 9.04 で動画が再生できません

回答の補足です。3分から5分程度のmpeg2ファイルを4本です。
報告のとおり、ミュージックのおまじないをすれば視聴可能です。
当然、ウィンドウズ2000+GOMプレイヤで問題無しでした。
明日暇になればトライいたします。

オフライン

 

#18 2009-11-07 23:53:04

osawaget
新しいメンバ
登録日: 2009-10-13

Re: Ubuntu 9.04 で動画が再生できません

昨日、少しは暇ができたので、解決法を探ろうとしました。そのまえにubuntuのアップデートを行ったところ、今度は何の苦もなくtotemにて動画再生ができました。
ありゃ?
すぐに消え去った端末のエラーログを調べるつもりでしたが。
まあ、動画が見られるようになったから良いか。
調査報告に参加できなくてもうしわけない。

オフライン

 

Board footer

Powered by FluxBB