お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2009-04-22 12:07:15

marki
新しいメンバ
登録日: 2008-12-12

OpenOfficeで印刷した時に特定の文字が印刷されない。

初めまして、ubuntuを使い始めて半年くらいになりますが、
会社で事務用として活用しておりますが、表題のような問題が発生してます。

初めにこちらの機器構成を書いておきます。

ソフトウェアのバージョン
Ubuntu8.10
OpenOffice2.4.1
CUPS1.3.9-2Ubuntu9.1

プリンタの接続(2機)など
1、
Epson VP-1200U(ドットインパクト)
ローカルにUSB接続
ドライバはUbuntu付属のEpson Dot Matrix Foomatic/epsonc[en](推奨)

2、
Canon LBP-1120
ウィンドウズXPにUSB接続してるプリンタにSambaで接続
ドライバはCanonのHPよりダウンロードしたものを書庫ユーティリティー(マネージャー?)からインストール

以上が機器構成です。

以下に現れた症状を上げてみます。

症状1
OpenOfficeSpreadsheet2.4.1の表
フォント:IPAモナーPゴシック
プリンタ:LBP-1120
以上の組み合わせで”る”が印刷されない

症状2
OpenOfficeSpreadsheet2.4.1の表
フォント:VL Pゴシック
プリンタ:VP-1200U
以上の組み合わせで漢字の”柄”が印刷されない

症状3
OpenOfficeSpreadsheet2.4.1の表
フォント:VL Pゴシック
プリンタ:VP-1200UとLBP-1120
以上の組み合わせで”シ”が印刷されない

いずれの場合も詰めて印刷されます。
例:かるがるともちあげた→かがともちあげた

”か が ともちあげた”とは印刷されません

現れる症状は今のところ以上です。

解決法をご存知の方がいらっしゃいましたらよろしくお願いします。

オフライン

 

#2 2009-04-22 20:32:58

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: OpenOfficeで印刷した時に特定の文字が印刷されない。

marki さん

http://search.luky.org/oo/openoffice.2005/msg04752.html
http://search.luky.org/oo/openoffice.2005/msg04755.html

上記はOOo3ですが、現象が似ている気がします。

オフライン

 

#3 2009-04-22 21:13:22

marki
新しいメンバ
登録日: 2008-12-12

Re: OpenOfficeで印刷した時に特定の文字が印刷されない。

STGSAGWAN 様
さっそくのレスありがとうございます。
リンク先読ませていただきました。
フォントの置き換えが原因かもと言うことで、この情報を元に明日がんばってみます。

貴重な情報ありがとうございました。

オフライン

 

#4 2009-06-02 17:57:16

とろぴかる
メンバ
登録日: 2007-05-23

Re: OpenOfficeで印刷した時に特定の文字が印刷されない。

私も同様の現象が発生して苦労しました。
私の場合は、以下の環境です。
OS:9.04
OpenOffice:3.10(OpenOffice.orgより取得)

結論を書きますと、どうやらOpenOfficeからCUPSのドライバに出力する際のバグのようです。
それが、OpenOffice側なのかCUPS側なのかはわかりませんでした。

簡単な回避策は、OpenOfficeよりPDFに変換して、Adobe Readerで出力すると普通に出力できます。

その他の方法として、
私の場合は、cupsのバージョンを下げることにより回避しました。
まず、次のページよりdebパッケージをダウンロードします。
http://www.debian.org/distrib/packages
ダウンロードするパッケージは以下のパッケージです。
cups_1.3.8-1lenny5_i386.deb
ghostscript_8.62.dfsg.1-3.2lenny1_i386.deb
gs-common_8.62.dfsg.1-3.2lenny1_all.deb
libgs8_8.62.dfsg.1-3.2lenny1_i386.deb
synapticでこれらを削除した後、
dpkg -iでインストールしてください。
libgs8をとりあえず先に入れてください。
gs-commonの場合は、次のようにしてください。
sudo dpkg -i --ignore-depends=ghostscript gs-common_8.62.dfsg.1-3.2lenny1_all.deb
あとは、普通に入るはずです。

cupsのバージョンは要注意ですね。
では。

オフライン

 

#5 2009-06-02 22:23:08

marki
新しいメンバ
登録日: 2008-12-12

Re: OpenOfficeで印刷した時に特定の文字が印刷されない。

トロピカル様

バージョンダウンの情報ありがとうございます。
本日さっそく試してみましたので、結果をご報告いたします。

てこずりましたが、cups 1.3.8・・・以下4っつのファイルのダウンロードには成功しました。
次に、SYNAPTICより、CUPS、GS-COMMON、LIBGS8を削除(Ghostscriptはどういうわけか入ってなかったです)
*このときにPSファイルビュワーのEvinceが削除されてしまったので、後からインストール。

インストールには、GUIからがんばってみましたが、依存関係で、最新のCupsがインストールされたりで・・・断念!!
コマンドラインよりdpkgでインストールに成功しました。
このとき、インストールの順番が間違ってるとだめなようでしたが(最初にLibgs8はインストールしました。)
いろいろやってるうちに出来てしまったので、順番は覚えてません。

インストールは完了ということで、プリンタ出力しようとすると、
ドライバが使えないというような内容のエラーでしたので、キャノンのHPより
以下のファイルをダウンロードしてプリンタドライバの再インストールのようなことをしました。

cndrvdrv-common_1.80-1_i386.deb
cndrvcups-capt_1.80-1_i386.deb   (二つとも今回の作業で削除する前に使っていたドライバファイルです)

インストール後、プリンタを再設定したところ無事に印刷されました。

今のところ、依然あったような文字の欠落は見つかりませんが、何かありましたらご報告いたします。

バージョンダウンにより、今までおかしかったBoldの印刷もよくなったようなので、
しばらく使ってみます。

大変参考になる情報をありがとうございました。

オフライン

 

#6 2009-06-03 08:46:36

とろぴかる
メンバ
登録日: 2007-05-23

Re: OpenOfficeで印刷した時に特定の文字が印刷されない。

marki様
無事出力できたようで、何よりです。
パッケージの順番は、おそらくですが、
libgs -.> gs-common -> ghostscript -> cups
の順番でいいような気がします。
まあ、いろいろしたら入るでしょう。

プリンタは私もCanonでLBP5900SEです。
ドライバも同じものを使っています。
このドライバはgs-espを使っているらしく、
そのあたりも影響しているような気もします。
ただ、OpenOffice以外は出力できるので、
なんとも言いづらいではありますが。

まあ、出力できれば良しとしましょう。
では、よいUbuntuライフを!!

オフライン

 

Board footer

Powered by FluxBB