お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2007-07-12 19:09:50

kita
メンバ
登録日: 2007-06-24

起動するたびに音が出たり出なかったりします

起動ごとに音が出たり出なかったりしますCDは音がでます。
色々と検索していますが素人で良く分かりません。
下記は検索した書き込みを参考にしています。これを参考にお教え頂きたいです。fedora7が上手く出来ませんでしたので日経Linuxに付録のUbuntu7.04をインストしました。インターネット観閲(動画)はOKです
インターネットにMplayer DVDはVLCplayerです。
PCのスペックはFMV CE7/855 CPU855メモリー512 HD40G サウンドカード追加です、宜しくお願いします

デバイスの情報
desktop:~$  cat /proc/asound/devices
  2:        : timer
  3:        : sequencer
  4: [ 0- 0]: digital audio playback
  5: [ 0- 0]: digital audio capture
  6: [ 0]   : control
  7: [ 1- 0]: hardware dependent
  8: [ 1- 0]: raw midi
  9: [ 1- 3]: digital audio playback
10: [ 1- 2]: digital audio playback
11: [ 1- 2]: digital audio capture
12: [ 1- 1]: digital audio capture
13: [ 1- 0]: digital audio playback
14: [ 1- 0]: digital audio capture
15: [ 1]   : control
16: [ 1- 2]: hardware dependent
17: [ 1- 1]: raw midi
18: [ 1- 2]: raw midi


desktop:~$ aplay -l
**** ハードウェアデバイス PLAYBACK のリスト ****
カード 0: rev20 [VIA 82C686A/B rev20], デバイス 0: VIA 82C686A/B rev20 [VIA 82C686A/B rev20]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
カード 1: Live [SBLive! Value [CT4830]], デバイス 0: emu10k1 [ADC Capture/Standard PCM Playback]
  サブデバイス: 32/32
  サブデバイス #0: subdevice #0
  サブデバイス #1: subdevice #1
  サブデバイス #2: subdevice #2
  サブデバイス #3: subdevice #3
  サブデバイス #4: subdevice #4
  サブデバイス #5: subdevice #5
  サブデバイス #6: subdevice #6
  サブデバイス #7: subdevice #7
  サブデバイス #8: subdevice #8
  サブデバイス #9: subdevice #9
  サブデバイス #10: subdevice #10
  サブデバイス #11: subdevice #11
  サブデバイス #12: subdevice #12
  サブデバイス #13: subdevice #13
  サブデバイス #14: subdevice #14
  サブデバイス #15: subdevice #15
  サブデバイス #16: subdevice #16
  サブデバイス #17: subdevice #17
  サブデバイス #18: subdevice #18
  サブデバイス #19: subdevice #19
  サブデバイス #20: subdevice #20
  サブデバイス #21: subdevice #21
  サブデバイス #22: subdevice #22
  サブデバイス #23: subdevice #23
  サブデバイス #24: subdevice #24
  サブデバイス #25: subdevice #25
  サブデバイス #26: subdevice #26
  サブデバイス #27: subdevice #27
  サブデバイス #28: subdevice #28
  サブデバイス #29: subdevice #29
  サブデバイス #30: subdevice #30
  サブデバイス #31: subdevice #31
カード 1: Live [SBLive! Value [CT4830]], デバイス 2: emu10k1 efx [Multichannel Capture/PT Playback]
  サブデバイス: 8/8
  サブデバイス #0: subdevice #0
  サブデバイス #1: subdevice #1
  サブデバイス #2: subdevice #2
  サブデバイス #3: subdevice #3
  サブデバイス #4: subdevice #4
  サブデバイス #5: subdevice #5
  サブデバイス #6: subdevice #6
  サブデバイス #7: subdevice #7
カード 1: Live [SBLive! Value [CT4830]], デバイス 3: emu10k1 [Multichannel Playback]
  サブデバイス: 1/1
  サブデバイス #0: subdevice #0
モジュル名
desktop:~$ cat /proc/asound/modules
0 snd_via82xx
1 snd_emu10k1
desktop:~$

よろしくお願いします

オフライン

 

#2 2007-07-13 22:07:10

compuliver
新しいメンバ
登録日: 2007-07-13

Re: 起動するたびに音が出たり出なかったりします

これに参考してください:cool:

http://haraita9283.blog98.fc2.com/blog-entry-103.html

最後の編集者: compuliver (2007-07-13 22:07:40)

オフライン

 

#3 2007-07-14 00:02:51

kita
メンバ
登録日: 2007-06-24

Re: 起動するたびに音が出たり出なかったりします

今晩は、有難う御座います GoogleでUbuntuで音が出ないで検索してお教え頂いたのと同じのがヒットしたのでよく読んで理解しようとしたのですが良く分からず書き込みしました
http://haraita9283.blog98.fc2.com/blog-entry-103.html(内容はこことまったく同じです)
だから、教えて頂く人にもいくらか参考になるかと思いここと同じことを調べて載せました。
今は4〜5回位SWを入り切りして音がでるまでやっています。
ダメな時は再インストしょうかとも考えています。
なかなかおじさんには難しい
fedoraのときにも皆さんにお手間をかけた

オフライン

 

#4 2007-07-14 06:00:23

hirakawa
メンバ
登録日: 2006-12-25

Re: 起動するたびに音が出たり出なかったりします

リンク先の記事は、要するにサウンドカードが2つ以上ある場合に、起動時に認識される順番が不定であるので音が出たりでなかったり
するので、順番を固定しましょう・・・という内容です。

で、
$ cat /proc/asound/devices
などの記述は、
「アプリケーション」→「アクセサリー」→「端末」で端末を立ち上げ、
なんとか $
という表示でカーソルが点滅していますので、そこに「cat /proc/asound/devices」と入力(できれば当該ブログからコピー&ペースト)
してエンターで、記事の次行以降の表示になるということを表しています。
解決法までの記事は、blog作者がこうやって原因を突き止めたという経験談ですね。同様にやってみると理解できるかも。

で、解決法にある
「これを参考に /etc/modprobe.d/sound を編集します。」
というのは
$ sudo gedit /etc/modprobe.d/sound
として、その内容を編集する(あるいは新規ファイルとなった場合は新たに作成する)ということです。

端末での操作は難しく感じるかもしれませんが、挑戦してみてください。

なお、このblogの方と同様の原因だったとしたら、再インストールしても改善されません。

蛇足ながら、端末を終了するには
$ exit
です。

オフライン

 

#5 2007-07-14 19:39:55

kita
メンバ
登録日: 2007-06-24

Re: 起動するたびに音が出たり出なかったりします

ありがとう御座います。ご指摘の内容通りです
この3連休仕事で来週時間をみて頑張ります
fedora6まではなんとかなっていましたがfedora7になって難しくなったので
Ubuntuにしてみたらデスクトップおじさんには目にウロコのようなOSでした
これからも色々とお邪魔しますので皆さん宜しくです。

オフライン

 

#6 2007-07-17 14:32:56

kita
メンバ
登録日: 2007-06-24

Re: 起動するたびに音が出たり出なかったりします

いつもお世話になります。http://haraita9283.blog98.fc2.com/blog-entry-103.html 参考にして
/etc/modprobe.d/sound を編集保存と挑戦してみましたが上手く
いかなかったのでおじさん風解決策を強行しました
皆さん笑うだろうな・・・きっと
サウンドカードを外して内蔵サウンドカード一つにしました
今の処OKみたいです。

compuliverさんhirakawaさんどうも有難う御座いました
これからも宜しくお願いします

オフライン

 

Board footer

Powered by FluxBB