お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2009-12-02 05:25:46

gateway716
新しいメンバ
登録日: 2009-11-19

Latitude D610へ9.10インストール後、起動しない

始めて投稿します。ubuntu は初心者なのですがよろしくお願いします。
Dell Latitude D610でUbuntu 9.04を使用していたのですが、9.10がリリースされたので
再インストールを試みました。
アップデートではなく、クリーンインストールです。
インストールが完了し、再起動すると...
no such device:XXXXX
faild to boot default entries
press any key to continue
と出て起動しません。
$ sudo fdisk -lを見ると
ディスク /dev/sda: 160.0 GB, 160041885696 バイト
ヘッド 255, セクタ 63, シリンダ 19457
Units = シリンダ数 of 16065 * 512 = 8225280 バイト
Disk identifier: 0x00057692

デバイス ブート     始点        終点    ブロック   Id システム
/dev/sda1   *           1       18708   150271978+  83  Linux
/dev/sda2           18709       19457     6016342+   5  拡張領域
/dev/sda5           18709       19457     6016311   82  Linux スワップ / Solaris

ディスク /dev/sdb: 4020 MB, 4020240384 バイト
ヘッド 92, セクタ 27, シリンダ 3161
Units = シリンダ数 of 2484 * 512 = 1271808 バイト
Disk identifier: 0x8e39156c
としてHDDは認識されています。
対処方がありましたら教えて下さい。お願いいたします。

オフライン

 

#2 2009-12-02 23:00:11

kiyoshi
拒否
From: Linux-Loving-Person
登録日: 2007-02-07

Re: Latitude D610へ9.10インストール後、起動しない

※規約違反により追放されたユーザの投稿は、ログインユーザにのみ表示されます。

オフライン

 

#3 2009-12-03 12:20:54

gateway716
新しいメンバ
登録日: 2009-11-19

Re: Latitude D610へ9.10インストール後、起動しない

お返事ありがとうございます。
インストールはubuntu-ja-9.10-desktop-i386.isoのCDーR及びUnetbootinで作成したUSBどちらも
試してみましたが結果は同様でした。元データについてもMD5値も確認して異常の無いことも確認しました。

中古のLaptopを購入したためHDDは取り替えてあります。
インストール先はHdd全体を使用するを選択しました。
Ubuntu9.04からのアップデートで9.10にすることはできましたがクリーンインストールでは
つまづいてしまいます。

私もググってみたところ、Ubuntu Forumで次の記事を見つけました。

http://ubuntuforums.org/showthread.php?t=1344096

どうやら私だけではないようです(汗)
英語なのでどこまでできるかやってみないと解りませんが結果を
また報告させていただきます。

同じようにつまづいた方達のためになればいいのですが。

オフライン

 

#4 2009-12-03 17:18:24

gateway716
新しいメンバ
登録日: 2009-11-19

Re: Latitude D610へ9.10インストール後、起動しない

早速、試してみたところ、結果は良好です。
私のような初心者でもできるよう、手順を明記しておきます。
1 LIVE CDで起動時する際、F6でオプションを選択し、Escキーを押します。
2 起動オプション file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz の’boot=casper’を’root=/dev/sda1’に
  書き換えてEnterキーを押すとHDDから起動し、Ubuntuが立ち上がります。
3 端末を立ち上げます。
4 sudo nautilusと打ち込みEnterを押します。(パスワードを求められるので入力して下さい。)
5 メニューバーの’場所’からコンピュータ/ファイルシステムを開きます。
6 'boot' フォルダを開き、その中の'grub' フォルダを開きます。
7 その中から ’grub.cfg' を探し、「右クリック」「プロパティ」を選択します。
8 プロパティから「アクセス権」タブを選択して所有者:rootのアクセスを「読み込み専用」から「読み書き」に変更し、閉じます。
9 'grub.cfg' を右クリックし「geditで開く」を選択してファイルを開きます。
10 内容を確認し、以下の部分を探して下さい。
### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-14-generic" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
set quiet=1
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set ba123456-7890-abcd-efghijklmnop
linux /boot/vmlinuz-2.6.31-14-generic root=UUID=ba123456-7890-abcd-efghijklmnop ro quiet splash
initrd /boot/initrd.img-2.6.31-14-generic
}

11 上の内容の4行目から6行目及び8行目を削除し、以下の内容に書き換えます。
### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-15-generic" {
set root=(hd0,1)
linux /boot/vmlinuz-2.6.31-15-generic root=UUID=ba123456-7890-abcd-efghijklmnop ro quiet splash
initrd /boot/initrd.img-2.6.31-15-generic
}
12 内容を確認したら「保存」を行い、項目7・8の方法でアクセス権を「読み込み専用」に戻します。
13 再起動すると'hd0,1'(本体HDD=sda1)からブートし、Ubuntu 9.10 が立ち上がります。(解決)

ほとんど http://newyork.ubuntuforums.org/showthread.php?p=8389636 の内容ですが。
お返事を下さった kiyoshiさん、ありがとうございました。

オフライン

 

#5 2009-12-03 22:51:10

kiyoshi
拒否
From: Linux-Loving-Person
登録日: 2007-02-07

Re: Latitude D610へ9.10インストール後、起動しない

※規約違反により追放されたユーザの投稿は、ログインユーザにのみ表示されます。

オフライン

 

#6 2009-12-04 00:45:40

kiyoshi
拒否
From: Linux-Loving-Person
登録日: 2007-02-07

Re: Latitude D610へ9.10インストール後、起動しない

※規約違反により追放されたユーザの投稿は、ログインユーザにのみ表示されます。

オフライン

 

#7 2009-12-04 01:10:34

kiyoshi
拒否
From: Linux-Loving-Person
登録日: 2007-02-07

Re: Latitude D610へ9.10インストール後、起動しない

※規約違反により追放されたユーザの投稿は、ログインユーザにのみ表示されます。

オフライン

 

#8 2009-12-04 02:56:05

gateway716
新しいメンバ
登録日: 2009-11-19

Re: Latitude D610へ9.10インストール後、起動しない

kiyoshiさん、ご指摘ありがとうございます。
確かに
$ sudo update-grub
を行うと元の状況になることを確認しました。甘くはないですね(笑)

初歩的な質問で恐縮ですが、kiyoshiさんの方法、
/etc/grub.d/10_linux

if [ -n ${have_grubenv} ]; then save_env recordfail; fi
の最初に
#
を付けてコメントアウトするというのは
#if [ -n ${have_grubenv} ]; then save_env recordfail; fi
として保存をかけて
$ sudo update-grub
を行うということでよろしいのでしょうか?
お手すきの時でも教えて下さい。お願いします。

オフライン

 

#9 2009-12-04 03:02:05

gateway716
新しいメンバ
登録日: 2009-11-19

Re: Latitude D610へ9.10インストール後、起動しない

それと
http://newyork.ubuntuforums.org/showpost.php?p=8392336
の#2ですが、
/etc/default/grub
を確認したところ、変更しなくても
GRUB_DISABLE_LINUX_UUID=true
となっていました。
私も再度、対策を探して報告させていただきます。
kiyoshiさん遅くまでありがとうございます。

オフライン

 

#10 2009-12-04 03:06:10

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: Latitude D610へ9.10インストール後、起動しない

#4のgateway716さんへ

#4の別解に相当しますが、

「Grub 2 problem, error: no such device」
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/403408

に載っている回避策を整理すると・・・

1. Shiftキーでgrubメニューに入り、eを押し編集モードへ →
"search --nofloppy ..."で始まる行を削除 → Ctrl+Xでブート

2. 端末で実行

コード:

$ sudo gedit /usr/lib/grub/grub-mkconfig_lib

3. 次の3行をコメントアウト
編集前

if fs_uuid="`${grub_probe} --device ${device} --target=fs_uuid 2> /dev/null`" ; then
    echo "search --no-floppy --fs-uuid --set ${fs_uuid}"
fi

編集後

# if fs_uuid="`${grub_probe} --device ${device} --target=fs_uuid 2> /dev/null`" ; then
#     echo "search --no-floppy --fs-uuid --set ${fs_uuid}"
# fi

4. 端末で実行

コード:

$ sudo update-grub

5. 再起動

以上です。

--
注意点として、/usr/lib/grub/grub-mkconfig_lib は grub-commonパッケージに属すので、そのパッケージがアップデートされると上書きされて元に戻ります。
ですが、その頻度はカーネルアップデートの頻度より低いでしょう。

オフライン

 

#11 2009-12-04 09:22:19

gateway716
新しいメンバ
登録日: 2009-11-19

Re: Latitude D610へ9.10インストール後、起動しない

STGSAGWANさん。ありがとうございます。

試してみましたところ、正常に起動しました。

Ubuntu9.04ではこのようなことはなく使用できていたことからGRUB2の影響なのでしょうか。
インストールCDでHDDを起動させてGRUB1にしてしまうか、それともsda1をパーテーションで区切って
認識させるかなんて素人考えをしていました。
最悪、9.04からのアップグレードで使い続けよう。なんて逃げまで考えてました。

パッケージのアップデートを考えずに済むような対策はないものか、探して報告できたらいいなと闘志が湧いてきました(笑)
そのためにはどこが不具合を発生させているのか、根本を理解しないといけませんね。
Ubuntuを使い始めてから半年、このような問題は初めてでフォーラムにお邪魔しましたが
皆さんの暖かい回答に感謝しています。ありがとうございます。

オフライン

 

#12 2009-12-04 23:07:16

kiyoshi
拒否
From: Linux-Loving-Person
登録日: 2007-02-07

Re: Latitude D610へ9.10インストール後、起動しない

※規約違反により追放されたユーザの投稿は、ログインユーザにのみ表示されます。

オフライン

 

#13 2009-12-05 01:36:17

gateway716
新しいメンバ
登録日: 2009-11-19

Re: Latitude D610へ9.10インストール後、起動しない

kiyoshiさん ありがとうございます。
今日は報告できる成果はありませんが
Linux、Ubuntu関連の本を買い集めてきました。(公休だったもので)
専門用語も多く、テキストエディタの内容等、それぞれ意味があり新しい言語を学ぶようです(汗)

用意されていた環境を使うだけのコンピュータ生活でしたが、
苦労して解決できた時の喜びまで感じることができる(笑)
ハマってしまいそうです。

私のような素人にも丁寧に教えて下さったkiyoshiさんやSTGSAGWANさんには感謝しています。
もっと勉強して私のような初心者に恩返しをできたらいいのですが。
Ubuntuの「意味」とても素敵だなぁ~なんてしみじみしてしまいました。
おやすみなさい。

オフライン

 

#14 2009-12-14 20:13:03

STGSAGWAN
メンバ
登録日: 2008-11-12

Re: Latitude D610へ9.10インストール後、起動しない

本日
「Grub 2 problem, error: no such device」
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/403408
のステータス変更通知が来ました。

Status in GRand Unified Bootloader: Unknown
Status in “grub2” package in Ubuntu: Confirmed
Status in “grub2” package in Debian: Fix Released

実際のアップデートとして来るにはもう少しかかるでしょうが、進展はあるようです。

オフライン

 

#15 2009-12-17 00:10:03

gateway716
新しいメンバ
登録日: 2009-11-19

Re: Latitude D610へ9.10インストール後、起動しない

STGSAGWANさん ありがとうございます。
「Grub 2 problem, error: no such device」
https://bugs.launchpad.net/ubuntu/+sour … bug/403408
のステータス変更を確認しました。
困っていたのは私だけではないのですね。
その後は、おかげさまで教えていただいた方法にしてから一度のアップデートで同様の状態になりましたが、再度
コメントアウトを行いなんとか凌いでいます。
解決に向け勉強はしていますが、私のような初心者ではなかなか難しいものがあります。
勉強を続けながらアップデートを待ってみます。

オフライン

 

Board footer

Powered by FluxBB