お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2008-01-12 21:09:03

harupin
メンバ
登録日: 2008-01-04

キーボード

こんばんは harupinです。
最近 とてもお世話になっています。

キーボードの日本語入力がおかしいです。
日本語入力のon、offを初めは 「半角/全角」ボタンで切り替えできてました。
テキストモードで初期設定をやり直したのですが、その際に再起動した折に
キーボードの設定が XwindowとGNOMEでの設定が異なります みたいなコメントが出て
よくわからないまま yesかnoのどちらかを選んでしまいました。

それ以来切り替えはanthyのツールバーでの マウス操作でしかできません。
日本語入力には困らないのですが 記号がさっぱり無茶苦茶です。
SCIM入力メソッドの設定での変更はまったく効きません。
「半角/全角」ボタンは「‘」が打ち込まれます。

端末での操作になるのでしょうか?
かなりの初心者なのでよろしくお願いします。

オフライン

 

#2 2008-01-12 21:37:17

hito
管理者
登録日: 2007-03-18

Re: キーボード

何が起きているのかを把握したいので、端末(アプリケーション->アクセサリ->端末)で、

$ cat /etc/X11/xorg.conf | grep XkbModel

を実行して、結果を貼り付けてください。

もしも端末からの操作が嫌であれば、
システム -> 設定 -> キーボード -> レイアウトで、
・キーボードの型式
・レイアウト
にそれぞれ何が入っているのかを教えてください。

オフライン

 

#3 2008-01-12 22:30:03

harupin
メンバ
登録日: 2008-01-04

Re: キーボード

こんばんは hitoさん 
続けてお世話になります。
指示どおりの物を張り付けます。よろしくお願いします

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc106"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "stylus"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "eraser"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "cursor"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "vesa"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "BenQ G900"
        Option          "DPMS"
        HorizSync       31-83
        VertRefresh     55-76
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor         "BenQ G900"
        DefaultDepth    24
        SubSection "Display"
                Modes           "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"

# Uncomment if you have a wacom tablet
#       InputDevice     "stylus"        "SendCoreEvents"
#       InputDevice     "cursor"        "SendCoreEvents"
#       InputDevice     "eraser"        "SendCoreEvents"
EndSection
cat: l: No such file or directory
cat: grep: No such file or directory
cat: XkbModel: No such file or directory
yoshiki@yoshiki-2th:~$

オフライン

 

#4 2008-01-12 22:39:02

harupin
メンバ
登録日: 2008-01-04

Re: キーボード

追加で

キーボードの設定
・キーボードの型式 ; Japanese 106-key
・レイアウト    ;U.S. English
           Japan

です。
ひらがな入力はかろうじてそのまま打ち込めます。
記号は手当たり次第に打って探しています。
よろしくお願いします。

オフライン

 

#5 2008-01-12 23:42:14

hito
管理者
登録日: 2007-03-18

Re: キーボード

この状況であれば、システム -> 設定 -> キーボード -> レイアウトで、
レイアウトとして Japan を選択した状態にしてください。それで直ります。

オフライン

 

#6 2008-01-13 00:08:34

harupin
メンバ
登録日: 2008-01-04

Re: キーボード

ありがとうございます。

そのレイアウトではJapanに●がついた状態にはなってはいるんです。
ちなみに US Englishを選択しようとしても、●は付かないです。
Japanから動かないです。

もう一度テキストモードをやり直してみましょうか?
昨日、今日とほんとお世話になります。
ありがとうございます
自分は明日も仕事なんデス。
今日はこのくらいで、 おやすみなさい

オフライン

 

#7 2008-01-13 12:02:49

Shibata
管理者
From: 東京
登録日: 2006-10-25

Re: キーボード

一度、「キーボードの型式」のほうをEnglishか何かに設定してから、Japanese 106-keyに戻してみてはどうでしょう。

ちなみに、
$ cat /etc/X11/xorg.conf | grep XkbModel
真ん中の縦棒はl(小文字のエル)やI(大文字のアイ)ではなく、パイプと呼ばれるものです。日本語キーボードだと、BackSpaceの右隣にある、真ん中に切れ目のある縦棒です。覚えておくと便利ですよ。

オフライン

 

#8 2008-01-13 18:17:00

harupin
メンバ
登録日: 2008-01-04

Re: キーボード

こんばんはharupinです。

Shibataさんコメントありがとうございます。

えー端末での初期設定みたいな奴をもう一度やってみました。
キーボードの設定のところでUSとなっていたので これで解決と思い Japanになおして
終了。再起動したところ 以下のメッセージが出ました。

Xウィンドウのキーボード設定が現在のGNOMEの設定と異なります。
model”pc106"layout”US"and no optinを想定していましたが、次の様な設定を検出しました。:
model”pc106”、layout"Japan” and no option
どちらの設定を利用しますか?
  「Xの設定」  「GNOMREの設定」

で私はカンでGNOMEを選びました。
でもダメでした。変化がありませんでした。

再挑戦しました。
その結果は再起動したのち 以下のメッセージが出ました。

XKB の設定を有効にする際にエラーが発生しました。

この問題は、いろいろな状況に依存して発生します:

- ライブラリ libxklavier のバグ

- Xサーバのバグ (xkbcomp、xmodmap コマンド)

- 実装で互換性のないライブラリ libxkbfile を使ったXサーバ



Xサーバのバージョン情報:

The X.Org Foundation

10300000



この状態をバグとして報告する場合は、次の結果も追記して下さい:

- xprop -root | grep XKB の出力

- gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd の出力

再挑戦して変化がありました。
キーボードの打ち込みが 再挑戦後は記号その他も表示どおり打てます。
 「Ctrl」+「C」でのコピーもできるようになりました。
どうもできないのは切り替えの「半角/全角」のキーが反応しません。

難しいですね。 なんとなく再インストールしようかと・・・・・。

オフライン

 

#9 2008-01-13 18:59:11

RxOrca
メンバ
登録日: 2007-03-02

Re: キーボード

harupin による投稿:

その際に再起動した折に
キーボードの設定が XwindowとGNOMEでの設定が異なります みたいなコメントが出て
よくわからないまま yesかnoのどちらかを選んでしまいました。

σ(^^) のトコでも同じ現象だったです。
そのダイアログに対して右側のボタンはダメだったよーな気が …。
でも左側を選択しても, 次回起動時に同じダイアログが現れるです。毎回毎回。

結局 …
σ(^^) の場合は, 「キーボードの型式」で Appleだか Acerだかに設定 …
で, しばらく使ってみて, 再度「キーボードの型式」で Japanese 106-keyを選ぶと, その後は再起動してもダイアログが現れなくなったです。

ググってみると他にこんなページが見つかったです。
XとGNOMEでキーボードが異なる?
キーボード設定 gnomeの設定を使う とは?


harupin による投稿:

そのレイアウトではJapanに●がついた状態にはなってはいるんです。
ちなみに US Englishを選択しようとしても、●は付かないです。
Japanから動かないです。

関係ないカモだけどとりあえず
「レイアウト」と「デフォルト」の項目のうち, 「デフォルト」のトコでクリックする必要があるです。(行を選択するんじゃなく)

オフライン

 

#10 2008-01-13 21:49:21

harupin
メンバ
登録日: 2008-01-04

Re: キーボード

RxOrcaさん こんばんはandありがとうございます。

現状は システム>設定>キーボード のキーボードの型式は不明になっています。
変更いようとすると 毎回以下のコメントが出ます。
「その結果は再起動したのち 以下のメッセージが出ました。
XKB の設定を有効にする際にエラーが発生しました。
この問題は、いろいろな状況に依存して発生します:
- ライブラリ libxklavier のバグ
- Xサーバのバグ (xkbcomp、xmodmap コマンド)
- 実装で互換性のないライブラリ libxkbfile を使ったXサーバ
Xサーバのバージョン情報:
The X.Org Foundation
10300000
この状態をバグとして報告する場合は、次の結果も追記して下さい:
- xprop -root | grep XKB の出力
- gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd の出力」

何となく こんなことになっているのは私ぐらいだろうと思っていましたが
結構 体験者がいると思うと 変な安心感が出てきました。

オフライン

 

#11 2008-01-14 13:37:47

harupin
メンバ
登録日: 2008-01-04

Re: キーボード

こんにちは harupinです。
今日は お休みなので 今朝から 再インストールしています。
勉強のために もう少し頑張ろうかとも 思いましたが、
やはり 簡単な方法を取ってしまいました。
只今 元の状態に戻している所ですが
いろいろ設定していたんだな〜と自分で感じています。

また分からないことが出てくると思いますので 
今後も よろしくお願いします。

オフライン

 

#12 2008-01-14 17:04:22

RxOrca
メンバ
登録日: 2007-03-02

Re: キーボード

harupin による投稿:

今朝から 再インストールしています。
勉強のために もう少し頑張ろうかとも 思いましたが、
やはり 簡単な方法を取ってしまいました。

実は, σ(^^) も最初間違った方を選んで, 何かが変になった記憶があるです。
何がどのよーに変だったか, どーやって元に戻したか, それらは忘却の彼方だったり。(^^;

次回からはログイン時に書き換わらない方を選ぶよーにしたけど, 毎回ダイアログが出てきてしまうよーになったです。

んで, 今後は 何かそーゆー類の設定を行う前に xorg.confなどをバックアップしておくと, トラブル時に有効カモです。

オフライン

 

#13 2008-01-15 00:43:12

harupin
メンバ
登録日: 2008-01-04

Re: キーボード

こんばんは、harupinです。
adobeのflashplayerのインストールにかなりてこずったけれど
今は 快適に思います。

そう言えば 最初の「外観の設定」の時に xorg.confをバックアップするように
指示されていたのでバックアップしていました。
せっかくのバックアップを全く使うことも思いつかず 再インストールしてしまいました。
バックアップファイルの使い方を勉強してから再インストールしてもよかったかなぁ〜。
と後の祭り、
まずは 端末をマスターしたいですね。
コマンドは当然知らないし、使い方もしらないもので。

ありがとね。

オフライン

 

Board footer

Powered by FluxBB