お知らせ

  • 利用規約を守って投稿してください。また、よくある質問および投稿の手引きも参照してください。
  • メッセージの投稿にはアカウントが必要です。未登録の方は、ユーザ登録ページからアカウントを作成することができます。

#1 2007-10-04 18:02:09

KyousukeTanabe
新しいメンバ
登録日: 2007-10-04

Emacs にてAlt+<, Alt+>が効かない

Emacs でファイルの先頭に飛ぶコマンド "Alt+<"
もしくは、ファイルの末尾に飛ぶコマンド "Alt+>"
が使用できません

"Alt+<" の挙動はミニバッファに
No M-x tags-search or M-x tags-query-replace in progress
と表示され
”Alt+>"の挙動はミニバッファに
Find tag:
と表示されます。

おそらく
Alt+<  → Alt+.
Alt+>  → Alt+,
と解釈されて、Altを押下した後のshiftキーが効いていないようなのです

windowsからputtyでubuntuにログインしてemacsを起動すると
正常にAlt+<,Alt+<ともに実行されることから
ubuntuのディスクトップ環境に問題があるかと思っています


正常に動作するような方法わかる方いませんでしょうか
また、他の方も同じように再現するのでしょうか

#Ubuntu 7.04
#GNU Emacs 21.4.1です

オフライン

 

#2 2007-10-04 23:20:02

yama
メンバ
登録日: 2006-10-23

Re: Emacs にてAlt+<, Alt+>が効かない

Alt キーの代わりに Esc キーでもダメですか?

念のためにお聞きしますが、AltとShiftキーを押しっ放しの状態で、<>それぞれ押しているんですよね?

同じ環境で特に問題が出ていないです。システムのキーボード設定でレイアウトを見直してみてください。

オフライン

 

#3 2007-10-05 12:48:53

KyousukeTanabe
新しいメンバ
登録日: 2007-10-04

Re: Emacs にてAlt+<, Alt+>が効かない

> Alt キーの代わりに Esc キーでもダメですか?

Escでは正常に動作いたします。
ただMetaはAltで使うのになれてしまっていますのでこちらで動作させたいと思いまして・・

>念のためにお聞きしますが、AltとShiftキーを押しっ放しの状態で、<>それぞれ押しているんですよね?
はいそうです。

>同じ環境で特に問題が出ていないです。システムのキーボード設定でレイアウトを見直してみてください。
そうですか。確認ありがとうございます。

書き忘れてしまいましたが、ubuntuはVMware上で動作をさせています。(親OS:windows vista  子OS:Ubuntu)
#それが関係してるかはわかりませんが。

また、最初からubuntuをインストールしなおして、Emacsだけ入れて実行しましたが再現しました。

引き続き調査してみます。

オフライン

 

#4 2007-10-05 13:08:23

yama
メンバ
登録日: 2006-10-23

Re: Emacs にてAlt+<, Alt+>が効かない

VMwareで使っていませんので当て推量ですが、VMwareが問題かも知れませんね。
VMwareがキー入力を先に取得しているため、そこで問題が起きているかもしれません。

オフライン

 

#5 2007-10-05 18:50:58

mizuno
管理者
From: Kyoto
登録日: 2007-02-28

Re: Emacs にてAlt+<, Alt+>が効かない

Gnome の システム -> 設定 -> キーボードの設定 -> レイアウトのオプション を確認してください。
Group Shift/Lock behavior -> Alt+Shift changes group にチェックが入っている場合は、外してみてください。

オフライン

 

#6 2007-10-05 20:45:04

KyousukeTanabe
新しいメンバ
登録日: 2007-10-04

Re: Emacs にてAlt+<, Alt+>が効かない

mizuno様
ありがとうございます。
>Gnome の システム -> 設定 -> キーボードの設定 -> レイアウトのオプション を確認してください。
>Group Shift/Lock behavior -> Alt+Shift changes group にチェックが入っている場合は、外してみてください。

上記の項目を見たころチェックが入っていました。
チェックを外したら動作するようになりました。

yama様 mizuno様
ありがとうございました。

オフライン

 

Board footer

Powered by FluxBB